Le Français

P3D V4 Stutters

Recommended Posts

Hello everyone! I know there are a few threads about stutters, however, mine seem a bit different. When I am on the ground it is silky smooth. As soon as I get into the air it stutters. I lock my frames at 33 which it very stable, however, I get a lot of stutters. I am running ChasePlane with the PMDG 777. VSYNC & Triple Buffer is turned on. Could PTA cause any of this? Closing AS16 did not change anything. When I got to the spotview outside I get no stutters.

Thank you in advance for your help! PS: I have Hotfix 1 installed. Don't remember it being that bad before.

Clem

  • Upvote 1

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I hope you've locked your framerate externally and not used P3D's own framerate limiter? That's very heavy on performance and generally not recommended to use.

Share this post


Link to post
10 minutes ago, Sethos1988 said:

I hope you've locked your framerate externally and not used P3D's own framerate limiter? That's very heavy on performance and generally not recommended to use.

No I have not....Not using NI. Is it really a must to lock at 30 using NI? But before I didn't notice the stutter....Not sure what I touched or installed. I did add AM=84 for my i7-4770 OC to 4.2GHz. Also running a GTX780.

Share this post


Link to post

If you are not using a 30 hz monitor, try turning off the vsync and the triple buffering.

As a side note, I have my frames locked at 32 in the sim, and do not have any stutters. Of course, I do not have any heavy hitter aircraft installed yet, either. Waiting on the Aerosoft scarebus, and the Majestic Q.

Share this post


Link to post

Try 85 for your affinity mask, and try FFTF at .01. Having a monitor capable of 30hz and set internal frames to 33 is my cure for stutters

Share this post


Link to post

Although all systems are different and even though this works for me it may not work for you, but its best if I share it. 

I did some testing today with HT on and off, I have gained better results with turning HT off. For example - at Fly Tampas Amsterdam with HT enabled I was getting between 27 and 31fps with a lot of stuttering, that is with the PMDG 777, Envtex, AS (Beta) and SPAI at 30%. Disabling HT increased my fps to an average of 33 to 35 even as high as 47 in the less populated area of the airport (looking towards 36L). My stutters are almost completely gone and I can finally enjoy such complex and detailed airports without looking at a slideshow. 

As V4 grows in popularity I hope to see some new tweaks we can implement into our cfg to improve performance more, not only that but I hope LM do some better optimising with V4 especially when it comes to SSAA and Dynamic Lighting. 

Share this post


Link to post

I'm actually experiencing the same thing, on a relatively plain vanilla v4 install (just PMDG products for beta testing purposes) and a couple of utilities.  I can easily run 45-80+ FPS in almost any situation, but locking at ~37 FPS external (144 Hz monitor) seems to be amazingly smooth for me on the ground, then stutters noticeably airborne.  Haven't found a solution yet among a combination of sliders, NVI, .cfg, and other variables.

 

i7 7700k @4.8 GHz, ASUS STRIX GTX 1080

Share this post


Link to post

Thanks everyone! My monitor only does 60Hz. I also have AM 84 with HT on. Tried with no AM & AM85 and not difference.

Share this post


Link to post

On a side note, I did upgrade to the latest Nvidia drivers 384.76 on 6/28/17. Could this stutters be caused by drivers? Also, could PTA cause stutters? 

Thanks!

Clem

Share this post


Link to post

Does anybody try not using an AM?  In version 3, yes I used AM and AM 84 was found to be the best for me. In ver 4, I no longer run an AM, also don't tweak anything else in config file.

Just this morning, for fun, I went thru 3 different AM settings and all of them gave me stutters ( I also tried different frame lock and vsynch options)- they all gave me stutters. So I went back to no AM, frames unlimited with just vsynch enabled. Smooth, no stutters. Of course all systems can need slight different settings, but just to haul off and changing everything around cause we all learned them (starting with FSX) doesn't necessarily get you anywhere in version 4.

Just my experience.  

Share this post


Link to post

I have stutters at cruise as well, seems to be related to high fps. There are intermittent stutters if fps touches or exceeds 60, even with vsync+triple buffering on. Applying AM=170 (which is similar to 85) appears to have helped a lot with it but not completely eliminated them.

Share this post


Link to post

If you have road traffic setting on, this may be the cause.

I only had mine set at 10% and it made stutters much worse.

If you already have it at 0%, then try limiting frames with nvidia inspector to 30.5 fps and in the sim run at unlimited.

This works well for me.

 

Stu

Share this post


Link to post

I have found the culprit setting on my system to be terrain texture resolution slider. Anything above 5m is inducing intermittent stutter in cruise while I had it set 60cm in v3 without any problems where it didn't cause stutter even with slider to full right while in v4 at the max setting stutters profusely. Any suggestions on what might be causing this? I have already tried adding texturemaxload, and changing affinitymask to no effect.

Edit: I was keeping p3d process priority high to keep other programs from interfering but turns out it had reverse effect and caused this stutter. Returning it to normal priority made the sim back smooth again. Didn't see it happen in v3 so didn't strike immediately.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now