ejoiner

How to reduce excessive bloom in EF?

Recommended Posts

The EF discussion thread has become a little long.  I am wondering how to concisely turn down the excessive bloom in REX Environment force?   I have HDR on in the sim, but bloom turned down to zero.   I have played some with the HDR settings in the mini UI, but it doesnt seem to really be doing the trick.  Anybody with a step by step cure for this?  

Eric

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

A hotfix is on its way, hopefully to address this issue about the excessive bloom. For now, you can adjust the exposurekey and bloomthreshold, make sure to click 'save variable', and each you time you start a flight, you need to 'load variable'. 

  • Like 1

Share this post


Link to post

What is your "Output dynamic range" set to in the NVIDIA Control Panel? I get mad blooming if I set it to limited.

  • Like 1

Share this post


Link to post

Ironic! I just came to AVSIM to see if there was any info on this. I've been messing with HDR in the sim and EF, everything has been too bright, even adjusting things down wasn't enough. Good to hear about a hotfix on the way, thanks for that info @jmrtlara

For now I will just turn off HDR. Other than that it has been a real treat so far, great piece of software. 

Share this post


Link to post
Posted (edited)

Hi.  I looked at the Nvidia control panel... where do I find "Output Dynamic range"?   I didnt see it anywhere!

 

Edited by ejoiner

Share this post


Link to post
Posted (edited)
On 5/2/2019 at 3:24 AM, ejoiner said:

The EF discussion thread has become a little long.  I am wondering how to concisely turn down the excessive bloom in REX Environment force?   I have HDR on in the sim, but bloom turned down to zero.   I have played some with the HDR settings in the mini UI, but it doesnt seem to really be doing the trick.  Anybody with a step by step cure for this?  

Eric

Eric, at this time there is no way (or at least for some users like you and me) to use the HDR option in EF.

Launch your sim, and have a look at the option "Turn HDR off" in the Mini UI (it's in category Shaders). Turning it off will give you again full control of the HDR sliders within P3D so you can again adjust HDR to your liking.

Edited by GEKtheReaper

Share this post


Link to post
Posted (edited)

Could you post a screenshot of what excessive bloom looks like? I need to tweak my PTA settings but would like to see what a real life example looks like. BTW, I am not an EF user, just one who is curious.

If not, no problem!

Thanks,

P.

Edited by pgde

Share this post


Link to post
Posted (edited)

Hi Simmers!

This is how I managed the excessive bloom in P3D with REX EF. I use P3D 4.5 and installed AS, SF, EF AND the latest updates/version of REX EF (should be 2 updates/hotfixes till now), or just download the latest REX EF version. I do not have Envshade and ASCA installed.

  • Deleted Shaders and P3D folder "Shader HSHL"
  • Repair P3D Client (to install the deleted folder "Shader HSHL"
  • I did use PTA ONLY to adjust VC Lightning! But I would recommend to test this first without an applied PTA Profile (you don´t have to uninstall the PTA  tool in my opinion)
  • Start P3D without REX EF
  • Set desired HDR settings in P3D GUI (HDR ticked on and sliders set to desired position - TopDown: 1.00 - 0.05 - 1.10 in my case)
  • Start a scenario to let the shaders build by P3D
  • Close P3D
  • Start REX EF
  • Important: Set REX EF to Automated Mode
  • Start P3D
  • Start a scenario in daytime (not for sure if that is important, but I did started this scenario at 12:00 o´Clock and without any weather program like AS)
  • Important: Switch to an outside view and stay there! (I will explain later why I did this)
  • In REX EF mini GUI, under section "Shader" should be displayed "Turn Off HDR" (this should be the text shown up, so your Rex Shaders are now "on"/"activated"!!).
  • Reset in REX EF mini GUI to "Manufactoring Settings" (tickbox in the upper section), 
  • Tick "Recompile Shaders" in REX mini GUI  under "Shaders" (so you still are in the outside view)
  • Important: Set in REX mini GUI in the "Rex Anhanced HDR" section the "TimeDelta to o.ooo"
  • Set the Rest of the HDR settings as desired (ExposureKey, BloomBlurSigma, etc.). I didn't change anything with exception the "TimeDelta to 0.000" (This was important in my case
  • Save settings in the upper section in Rex mini GUI (this tickbox is new in the latest Version of REX EF)

That should be it!

In my case only this way helped me to avoid excessive bloom. The trick was TimeDelta 0.000 and stay in outside view.

Now I will explain the "TimeDelta 0.000" setting. In my case this helped to avoid, that the excessive bloom came back after switching and panning views or playing with the TimePreview of P3D (from daytime to nighttime and then back to daytime). For example I did recognize, that using a PMDG 747-8 (just tested with that one), otherwise the excessive bloom returned and often stays till I switch to an outside view again. After switching to an outside view, the excessive bloom reduced (probably due the TimeDelta standard 0.250 Setting). That irritated me. That´s the main reason why I did my HDR settings only in the outside view and set TimeDelta to 0.000!

Interesting to me seemed also, that this excessive bloom behavior is worse in a PMDG plane (tested only with 747-8) as in a standard P3D plane (F22 Raptor). it seemed to me, that in case of using a standard F22 Raptor, the excessive bloom did also reduce if you are and stay inside the cockpit! That "reducing" wasn't the case in a PMDG 747-8 cockpit. Only if I switched to an outside view OR moved my view from inside the cockpit to just a few inches outside the cockpit (actually moved my eyepoint through the cockpit window from inside to outside), I saw how REX EF reduced the excessive bloom. This behavior affected on my display as well with or without VR! That behavior I managed by setting TimeDelta to 0.000.

Please report back if this helps generally. I will not discuss why I did all this steps or if they are necessary or not. It  just worked for me and that´s why I share it with you all. Decice by yourself if you would give it a try or not.

Good luck to you and happy simming!

Best regards, Marcus

 

Edited by mpo910

Share this post


Link to post

@mpo910 Marcus, that's impressive for sure. I bought but uninstalled EF until all the turmoil dies down, so I'm running ASP4, SF3D, and using a PTA preset I love with expressions for some dynamic changes (Gerard's All Months) so the bloom is perfect and the VC is also. SF3D loads dynamic 3D cloud models based on ASP4 wx. 

So, my question is, what am I missing if I don't go through this very elaborate exercise to "fix" EF?

Thanks,

Bruce

Share this post


Link to post
20 minutes ago, bbuckley said:

I bought but uninstalled EF until all the turmoil dies down,

I will do this also by the end of today. EF is way to buggy at this time for me.

21 minutes ago, bbuckley said:

SF3D loads dynamic 3D cloud models based on ASP4 wx

Yes it does but it will load only ONE texture set (it will not make use of ALL the sets within SF3D).

23 minutes ago, bbuckley said:

So, my question is, what am I missing if I don't go through this very elaborate exercise to "fix" EF?

EF uses ALL the possible cloud combinations present in SF3D + will alter some shaders, change illumination, allows cloud "growing" (called morphing) a.s.o. (BUT ONLY IF IT WORKS).

Basicaly with PTA you tune once the shaders acc to your liking and they never change. I you want to generate different looks you will have to create different presets that again will not change dynamically.

E.g. If you takeoff on a sunny day at Airport A where the ocean is perfect blue and super reflective and land at airport B in cloudy and rainy weather, the ocean will still be as same as blue and reflective as in location A (which is not that realistic at all). With EF the lighting of the scene will change with the weather conditions so you would see in location B a greyish ocean that is not that reflective.

Share this post


Link to post

This thread should be stickied.

 

 

Share this post


Link to post

This is now fixed along with the water/wave motion. We have also added some real-time PBR functions as well as a Save State for the mini in-sim UI.

We're hoping to release this pretty quickly now.

  • Like 6
  • Upvote 1

Share this post


Link to post
6 minutes ago, timest said:

We're hoping to release this pretty quickly now.

If you keep releasing stuff while I'm at work and so unable to get it nor try it, I'll turn green, massive with purple pants and pay you a visit 😆...

  • Like 4

Share this post


Link to post
1 hour ago, timest said:

This is now fixed along with the water/wave motion. We have also added some real-time PBR functions as well as a Save State for the mini in-sim UI.

We're hoping to release this pretty quickly now.

That sounds great Tim, thank you for listening to requests and working fast to fix/improve EF.

When.........today UK time.....come on......need it now........OK am joking 🙂 Look forward to it.

  • Like 3

Share this post


Link to post
9 hours ago, GEKtheReaper said:

If you keep releasing stuff while I'm at work and so unable to get it nor try it, I'll turn green, massive with purple pants and pay you a visit 😆...

😄

7 hours ago, Nyxx said:

That sounds great Tim, thank you for listening to requests and working fast to fix/improve EF.

When.........today UK time.....come on......need it now........OK am joking 🙂 Look forward to it.

Cheers David.

Share this post


Link to post
On 5/10/2019 at 4:52 AM, timest said:

This is now fixed along with the water/wave motion. We have also added some real-time PBR functions as well as a Save State for the mini in-sim UI.

We're hoping to release this pretty quickly now.

Tim, does this address the VC issues that I keep seeing people mention?

Share this post


Link to post

There is a new Open Beta in the forums. You can install it and see if fixed.

Thanks

Federico

Share this post


Link to post

@fs1

Where is the open beta located? Can't find it somehow.....

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now