Jump to content
Sign in to follow this  
SirDan

Patch Version 1.7.14.0

Recommended Posts

Long time lurker, first time poster. Came home today to try and patch this via the MS Store app, and all I get is "downloading" or "downloading microsoft flight simulator" and nothing happening. I can pause and try to reinstall it, but nothing happens. If I try to cancel the install, it says If I stop it the game will be completely removed. I'm on an internet capped plan and would hate to have to burn through another 100 or whatever GBs to redownload this.


Anyone else have this happening to them? Maybe the servers are just overwhelmed ATM? 

Share this post


Link to post
Share on other sites

It also seems to me that other stuff has changed, more than is mentioned in the patch notes.

It seems smoother for me, even over London with the enhanced scenery.

I can really whiz around outside with the external camera view - dead smooth, even with the night lighting.  (2560x1440 at 140% running on a 1080Ti not overclocked) I don't remember it being this smooth before.

It did get choppy at one stage after a few minutes, but then I realised the sky was full of strobes and lights of other aircraft (I am using off-line AI traffic).  They were everywhere 🤣 Definitely far too many.  (maybe another bug). 

I went into the menus and set airliner and light aircraft traffic both to 10 percent, and it came back smooth again. 👍

Not sure of the right way to check the version number to prove it has updated, but I noticed that when pressing Alt-Return to come out of full screen, the window title bar showed 1.7.14.0.

Edited by bobcat999
  • Like 1

Call me Bob or Rob, I don't mind, but I prefer Rob.

I like to trick airline passengers into thinking I have my own swimming pool in my back yard by painting a large blue rectangle on my patio!

Intel 13900K in a ROG Strix Z690 motherboard with water cooling, Asus RTX 4080, 32 GB 3600 DDR4 RAM, 3 x Samsung 1 TB NVME M.2, with MSFS on a Samsung 980 pro.

Share this post


Link to post
Share on other sites

A few tests... I seem to have lost 3-4 FPS in my 787 test setting. However it does seem smoother.

Was the 787 updated? My auto throttle seems to be broken now.


13900K@5.8GHz - ROG Strix Z790-E - 2X16Gb G.Skill Trident DDR5 6400 CL32 - MSI RTX 4090 Suprim X - WD SN850X 2 TB M.2 - XPG S70 Blade 2 TB M.2 - MSI A1000G PCIE5 1000 W 80+ Gold PSU - Liam Li 011 Dynamic Razer case - 58" Panasonic TC-58AX800U 4K - Pico 4 VR  HMD - WinWing HOTAS Orion2 MAX - ProFlight Pedals - TrackIR 5 - W11 Pro (Passmark:12574, CPU:63110-Single:4785, GPU:50688)

Share this post


Link to post
Share on other sites
1 minute ago, odourboy said:

A few tests... I seem to have lost 3-4 FPS in my 787 test setting. However it does seem smoother.

Was the 787 updated? My auto throttle seems to be broken now.

Out of interest do you see the same issue as before with neither CPU or GPU at 100%?

Share this post


Link to post
Share on other sites

Definitely smoother for me with higher FPS.  When monitoring in Dev Mode I am now limited by GPU when prior to the patch I was always limited by main thread.  It would stutter as the main thread bogged down.  No other changes made on my end.

  • Like 1

Ryan

 

 

 

Share this post


Link to post
Share on other sites
20 minutes ago, SteveFx said:

 

I really don't quite know why you were so irritated by the original quoted post but it really was completely valid.

In c/c++ the following statements will both compile.

if (a=5) {

  // assigns  5 to the variable  a and then will always execute this clause as the result  is not 0  - zero being  false in  c/c++ any non zero value being true.

}

if (a==5) {

   // will execute this clause if a holds the value 5 

}

Its an easy mistake to make especially if you have been using other languages and can be a pain to find exactly as the quoted post suggested.

The other classic error is a semi colon after the if like this.  This is rarer but I have found in code I was  debugging in the past.

if (a==5);
{

      // this code always gets executed even if a is not 5.

}

Exactly.  As someone who developed computer games in C/C++ (as a job, not a "hobby") from the 1980s through the 2000s, I can say I've seen such errors more times than I can count.  (One of them, from a self-proclaimed "hotshot" programmer on our staff, was a function that involved dozens of lines of source code, and spit out the same result every time, no matter the input arguments.)  Unless you have BigDee's Magical Mind-Reading Compiler, those won't generate any sort of compile error.

jiFfM.jpg

Edited by JDWalley
  • Like 3

James David Walley

Ryzen 7 7700X, 32 GB, RTX 3080

Share this post


Link to post
Share on other sites

peaking at a 10 12 frames smoother now .

can someone PLEASE CONFIRM if you see the live weather working now ????

looks to me like it is or at least better than before .

  • Upvote 1

Image removed as image is no longer available.

Share this post


Link to post
Share on other sites

After doing two flights of nearly 2 hours total, It seems as though I'm getting about 5-6 more FPS.

  • Like 2

AMD Ryzen 5800X3D, GIGABYTE X570 Aorus Ultra, 32GB DDR4 3600 MHz RAM, 2* 1 TB SSD, 3 * 1 TB M.2, (4TB) HDD,RADEON RX 6800XT NITRO+ OC SE 16GB GDDR6, NZXT Kraken X73, NZXT 710 Case, X55 JOYSTICK/THROTTLES, LG 4K monitor, Dell 1080 monitor. Honeycomb Alpha Yoke, Bravo Throttle. Thrustmaster TPR Pedals. Tobii Eye tracker.

Share this post


Link to post
Share on other sites

No FPS increase here, but I'm not using multiplayer, AI aircraft, or Simconnect where the patch may have caused a slight boost for others.

Still getting a nicely flyable 35-42 fps with the system specs below, and Task Manager showing that I'm GPU maxed and not CPU limited (no surprise).

No stutters in level flight, a few when I'm banked or otherwise maneuvering hard. Plenty of texture and object pop-in near the plane, but that's not something I'm expecting any of the early patches to address. Probably a long-term optimization project.

Edited by Paraffin

X-Plane and Microsoft Flight Simulator on Windows 10 
i7 6700 4.0 GHz, 32 GB RAM, GTX 1660 ti, 1920x1200 monitor

Share this post


Link to post
Share on other sites
7 minutes ago, rtodepart said:

peaking at a 10 12 frames smoother now .

can someone PLEASE CONFIRM if you see the live weather working now ????

looks to me like it is or at least better than before .

Flew around Iowa and Nebraska this morning. Still 3 knot winds the whole way. 

  • Like 1

Share this post


Link to post
Share on other sites
41 minutes ago, SteveFx said:

Out of interest do you see the same issue as before with neither CPU or GPU at 100%?

I didn't check that.  I'll take a look. I did notice that my caches were disabled. May account for the smoothness.

Edited by odourboy

13900K@5.8GHz - ROG Strix Z790-E - 2X16Gb G.Skill Trident DDR5 6400 CL32 - MSI RTX 4090 Suprim X - WD SN850X 2 TB M.2 - XPG S70 Blade 2 TB M.2 - MSI A1000G PCIE5 1000 W 80+ Gold PSU - Liam Li 011 Dynamic Razer case - 58" Panasonic TC-58AX800U 4K - Pico 4 VR  HMD - WinWing HOTAS Orion2 MAX - ProFlight Pedals - TrackIR 5 - W11 Pro (Passmark:12574, CPU:63110-Single:4785, GPU:50688)

Share this post


Link to post
Share on other sites
50 minutes ago, MBS Flyer said:

Long time lurker, first time poster. Came home today to try and patch this via the MS Store app, and all I get is "downloading" or "downloading microsoft flight simulator" and nothing happening. I can pause and try to reinstall it, but nothing happens. If I try to cancel the install, it says If I stop it the game will be completely removed. I'm on an internet capped plan and would hate to have to burn through another 100 or whatever GBs to redownload this.


Anyone else have this happening to them? Maybe the servers are just overwhelmed ATM? 

I just cancelled it, it does not remove the Sim and from the main ms update screen I was able to update the Sim in ms store


Wayne such

Asus Hero Z690, Galax 3080 TI, I712700K, Kraken x72 CPU Cooled, 64 GIGS Corsair DDR5, 32 Inch 4K 

Share this post


Link to post
Share on other sites
25 minutes ago, rtodepart said:

can someone PLEASE CONFIRM if you see the live weather working now ????

Nope. Still the same. Currently flying in the Australian outback. 225/3...

In Europe everything is fine, just like before.

 

And why would it? It was not even on their acknowledged bugs list until today.

Edited by Farlis

Share this post


Link to post
Share on other sites

Anti-virus deleted the .exe when I ran it first time after the Steam patch but sorted that, created an exclusion.  The C172 is transformed!!!  It was unflyable before and all over the place no matter what control sensitivity i used.  Now far smoother, more predictable behaviour and I am finally able to manually trim for level flight.  Great work!!!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...