Sign in to follow this  
Ianrivaldosmith

Once and for all

Recommended Posts

Can anyone help me get rid of these micro stutters using p3dv2.2?! I've had them with all 3 versions now.

I'm going insane.

 

My PC is fresh install of windows 7, with all drivers up to date.

 

It's on a 256GB SSD drive along with prepared and x-plane 10.25.

 

I have a nvidia GeForce GTX 770, 4GB.

 

27" monitor @ 1920x1080 and it does 60hz. 1080p HD, and it's brand new. I use a HDMI cable.

 

I have a i5 4670k @4GHZ.

 

I have 16GB RAM.

 

I have nothing else installed on the system expect avast internet security. It's in gaming mode, and I disable it during sim sessions.

 

I am literally crying out here for help now.... What am I doing wrong?!

 

Thank you

Ian

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi, Your probably using clouds as we all do. There had been mention of this in another thread. Try turning the clouds off, no matter if using default, rex or asn whatever and see if the stutters are still there. I am using a system similar to your and I get pretty good results with V2.2and this is with setting to the max. You have to play around as each persons system is different. Third party addons can also play havoc with stutters

 

CHEERS

 

Nelson

Share this post


Link to post

I have a very similar system as yours and do use the clouds and cloud shadows and am getting very good performance.  Did you install correctly by following the procedures below?  Make sure you remove your shader file as well.  Some people have not done that and it results in problems.  Good luck.

 

 

This is from Wes at LM and is also posted here: 

http://forum.avsim.net/topic/439035-read-me-first-if-you-are-having-v22-issues-follow-these-steps/

 

Be sure you follow the patch instructions, these next steps are critical:

While the uninstaller removes all files that are created by the installer, it does not
completely remove content that was generated during program execution. New versions of Prepar3D use new config file options, etc.

You need to delete these 4 folders. You might want to back up your old scenery.cfg or the contents of these folders so you can restore pieces manually if desired.

%PROGRAMDATA%\Lockheed Martin\Prepar3D v2

%LOCALAPPDATA%\Lockheed Martin\Prepar3D v2

%APPDATA%\Lockheed Martin\Prepar3D v2

%USERPROFILE%\Documents\Prepar3D v2 Files

Now you should restart your computer. After your computer has restarted, run the patched Prepar3D v2.2 again and let the system regeneration and recompile those files.

You will need to go back in one by one and re-add your add-ons to the dll.xml and exe.xml to see which one is causing problems, perhaps they have not updated their addons to work with v2.2 yet.

Wes Bard
Software Manager - Prepar3D® Team

Share this post


Link to post

strange how some people get stutters and others don't.  are you using 4096 cloud textures?  I'm using default clouds with OpusFSX/P3D, most settings maxed out, NO Nvidia Inspector and no SSD.  I don't even get stutters in FSX.   by the way, I defrag like a madman :lol:   ssd's don't need defragging.

Share this post


Link to post

In another thread it was said that some people don't see these micro stutters.

Spirit

Share this post


Link to post

I was involved in the v2.2 beta from the start and can say it without a doubt does not cause, nor remove "stutters".

 

Let me begin by saying what no one seems comfortable with saying or accepting;

  • There is NO magic bullet to make the sim perform at 60 FPS with all display options maxed out and no stuttering.
  • Using external AA via Nvidia Inspector to remove every last blocky line will kill performance, period. This is not inherent to just Prepar3d, but is the fact across all simulations and games.
  • Stutters are a product of unreasonable display settings and unoptimized frame limit setting, period.

 

The "stutters" are being cause by your system trying to keep up with what Prepar3d is trying to put on the screen, and is likely cause by either too high a settings in your display options, unreasonable demands in the form of AA using Nvidia Inspector, unreasonable frame limiter or unlimited frame limiter settings, or more likely a combination of all the above.

 

My advice to reduce/minimize or get rid of the "stutters" is the following:

  1. Save your current display settings and then revert them to default (if using Nvidia Inspector or any external display settings tool, set them to default as well), then open the display settings and set the frame limit to unlimited.
  2. Set up a flight where you want the stutters to never occur (dense urban or otherwise)
  3. Get into the air either by flying or slewing with whatever dense scenery you prefer in the scene, then put the sim into slew, not pause.
  4. Note your FPS and write it down if you want to
  5. Begin changing display settings, making sure to accept and go back to your flight to note the changes in FPS with the new settings. Do this until you have an FPS that is +10 over what you consider acceptable (i.e. if you want at least 30, increase settings until you see the "unlimited" FPS counter start bouncing around 40)
  6. If you didn't get the display settings to where you wanted them, consider turning something down or off in order to turn something else on. Remember, you cannot run full settings and expect full performance.
  7. Once you have the +10 FPS above your target, and the display settings where you want them, open your display settings and set the frame limiter to your target (i.e. 30 if you are following the previous example).
  8. Turn off slew and fly around noting if you encounter any "stutters".
  9. If you still encounter "stutters" that are unacceptable, raise the frame limit (yes... raise) by two and then try again. Continue raising the frame limit by two until you reach that +10 above your target. If you reach the +10, consider dialing down a display setting or two and trying again starting back at the target frame rate. Repeat until you find your preferred display setting VS performance target.
  10. Stop tweaking and FLY.

I hope this helps, as it is the product of hours trying to find the best settings on my computer throughout the v2.2 beta.

  • Upvote 1

Share this post


Link to post

On top of Phil's logical and well written note, you could also try a lower FFTF (somewhere between 0.1 and 0.2). It helped with overall FPS and smoothed things out without creating blurries.

Share this post


Link to post

I have to chime in and say thanks, but I have the lowest settings going for testing, and STILL I see the stutters, so they can't be cause by high settings!?

Share this post


Link to post

Did you try setting the frame limiter and enabling or disabling vsync?

 

Drivers all up to date (motherboard/CPU, sound, video, etc.)?

 

Your system should be perfectly capable of high settings.

Share this post


Link to post

Yeah all up to date and I have tried with those options both enabled and disabled.

 

I'm gonna run some testing, has anyone got any recommendations on what settings I should be choosing?

Share this post


Link to post

To be sure...

Delete any custom Prepar3d profile in Nvidia Inspector, delete those four P3d system folders listed above so you start with an absolutely clean Cfg file.

Run P3d as is and check for stutters.

If you're operating system and hardware are set up properly you should get no discernable stuttering at all.

Share this post


Link to post

Doesn't Windows Aero need to be active?  I deleted nVidia Inspector's P3D profile and it seemed to improve things.  I have noted that I get 30 FPS solid but the stutters that I see are from small terrain changes.

Share this post


Link to post

I believe the stutters he is referring too are not due to high settings or fps issues. I see them in all the v2 releases no matter what I do. It is more of a microstutter that u can see in the terrain as u pass by looking out the vc. I believe it is vsync related. I had the exact same issues with fsx before the 1/2 refresh rate setting in NI came about. But this setting does not work in V2.

Share this post


Link to post

I believe the stutters he is referring too are not due to high settings or fps issues. I see them in all the v2 releases no matter what I do. It is more of a microstutter that u can see in the terrain as u pass by looking out the vc. I believe it is vsync related. I had the exact same issues with fsx before the 1/2 refresh rate setting in NI came about. But this setting does not work in V2.

I very much agree with you, I have the exact same problem. In both V1.4, 2.0, 2.1 and 2.2 i see  non performance related microstutters. FSX however runs like a charm...

 

This could definitely be vsync related

Share this post


Link to post

The sooner we get an actual Prepar3d V2 profile from Nvidia the better, here's hoping it's included in the next set of WHQL drivers.

 

Until then, I've stayed away from using Nvidia Inspector and am just using 8xAA and 16xAF via Prepar3d's display settings.

 

If it helps, I'm running with vsync off.

Share this post


Link to post

If it helps, I'm running with vsync off.

Cannot do it with vsync off, I get screen tearing.  It appears the flashing comes mostly from the building autogen.  Too bad nVidia Inspector doesn't help.

Share this post


Link to post

I believe the stutters he is referring too are not due to high settings or fps issues. I see them in all the v2 releases no matter what I do. It is more of a microstutter that u can see in the terrain as u pass by looking out the vc. I believe it is vsync related. I had the exact same issues with fsx before the 1/2 refresh rate setting in NI came about. But this setting does not work in V2.

This is exactly it!! Ahhh you put it in to words I could not.

 

It's so frustrating.

 

Until someone comes out with a fix, I'm gonna have to stick with using x-plane 10.25.

 

P.S I tried with vsync off, no change.

It's especially worse as I use track IR, so I am always looking outa the VC windows ;)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this