Sign in to follow this  
Michael Moe

Performance:look at your Water settings PR3DV3.1

Recommended Posts

Well ,

 

might be a little overdramatic but i was trying to stay above 30fps in Canberra from ORBX with Cityscape and found out that it was not without penalty how my water settings was used. So just for the record - dont ignore this when you balance your system

 

Thanks

 

Michael Moe

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi Michael,

 

Yes, it is about balance ... adding re-shade just complicates the issue as do external NI settings ... if you run into performance issues those would be the first two items to disable/remove before looking at other P3D settings/add-ons to get "the balance".

 

I'm not a fan of re-shade, most adjustments can be accomplished via P3D HDR settings and/or monitor calibration without any FPS hit or texture loading issues.

 

But yes it's all about balance and that balance changes by location and add-ons and external influences.

 

Cheers, Rob.

Share this post


Link to post

Er... isn't that a bit too obvious to start a topic about...? Are you also going to start a topic about not ignoring (amongst others) autogen settings? :P And btw your topic title makes it look like this is some sort of v3.1 specific er... problem, but it isn't...? Hm, sorry, I am just trying to understand the use of what you posted: I expected a post about a specific problem but you are only stating the obvious... :rolleyes:

Share this post


Link to post

Here I am using Reshade only when nightflying to get a dark environment with a good bloom for my Night Environment scenery.

HDR in P3D is disabled then...

 

When daytime flying I have a Reshade profile with everything disabled...

Share this post


Link to post

What do water settings have to do with Reshade? Seems like an unnecessary attack on Reshade.

 

I use high water settings with both NI and Reshade and don't have any issues. As long as you know what you're doing and don't go overboard with the shaders/tweaks in Reshade there's nothing to worry about.

 

Besides all these boil down to GPU performance and capability.

Share this post


Link to post

@Rob:

 

Is there ever any talk about the night time "look" with the P3D team?

 

Like GSalden - The nighttime issues are when I find Re-Shade to be essential to actually make the simulator realistic.

It'd be great to have that either fixed or get some internal Display settings to tweak it a bit or something to allow us to not need ReShade

Share this post


Link to post

@Rob:

 

Is there ever any talk about the night time "look" with the P3D team?

 

Like GSalden - The nighttime issues are when I find Re-Shade to be essential to actually make the simulator realistic.

It'd be great to have that either fixed or get some internal Display settings to tweak it a bit or something to allow us to not need ReShade

 

I think this might actually do something.

 

[GRAPHICS]

TONEMAP_NIGHT_EXPOSURE_KEY=0.140000

 

Default value is 0.130000.

 

But don't quote me on it.

Share this post


Link to post

I think this might actually do something.

 

[GRAPHICS]

TONEMAP_NIGHT_EXPOSURE_KEY=0.140000

 

Default value is 0.130000.

 

But don't quote me on it.

Quote :

These settings allow you to adjust the brightness for day and night individually. If you feel that nights are too bright, but you don't want to change the brightness of the day at the same time, you can reduce the value of the night tonemap exposure setting.

 

I will test it to see if I can achieve the same darkness as with Reshade.

But even if it does I need Reshade for bloom when using Night Environment.

In v3.2 bloom with NE should work according to LM...

Share this post


Link to post

I little harsh guys! (yes I know I can be blunt also  :rolleyes: )

 

Am sure Michael intend was good. Even if most of us already know.

 

​Night time looks fine for me, just different HDR settings.

Share this post


Link to post

It is a known fact that when you have this combination :

 

- Nvidia GPU (at least GTX 9xx)

 

- Water on ultra

 

Then your GPU is probably working in P2 mode. P modes are performance states, and P0 should be the the usual 3D Game mode.

 

While in P2 mode, GPU and Memory clocks are lowered. Hence the FPS impact.

 

You can check this with Nvinspector for example.

 

Solutions :

 

- switch your water setting back to high

 

OR, if you want to keep the ultra Water :

 

- set up P2 mode to use the same clocks as P0

 

On my rig, with P2 state set up to use P0 clocks, Water high or ultra are performing the same.

  • Upvote 1

Share this post


Link to post

Then your GPU is probably working in P2 mode. P modes are performance states, and P0 should be the the usual 3D Game mode.

 

That might explain why I have been noting recently that my GPUs are always in the 'P0' P-State while Prepar3D is running. The following rules have been applied to Prepar3D.exe in Process Lasso:

 

1. Excluded from ProBalance Restraint

2. Classified as a Game

3. Application Power Profile: High Performance

 

My CPU ramps up to 4.399GHz as soon as Prepar3D.exe. is executed and a short while later both GPUs achieve 'P0' and remain at 'P0' until a few seconds after P3D exits when they quickly revert back in steps to 'P8'.

 

Mike

Share this post


Link to post

 

 


While in P2 mode, GPU and Memory clocks are lowered. Hence the FPS impact.

 

In my testing there is NO difference in performance between P0 and P2 mode with water at Ultra (or any water setting) ... compare same water settings.

 

With that said, P3D stays in P0 state for my setup.  For TrackIR users you may also want to note the following:https://www.naturalpoint.com/trackir/downloads/ ... look at the 5.4.0 changelog section 

 

 

 

Fixed an issue where certain NVIDIA GPUs might step down to a lower power state while the TrackIR software was active.

 

 

 


What do water settings have to do with Reshade? Seems like an unnecessary attack on Reshade.

 

Dial back your "attack meter", water settings have performance implications as does Reshade.  My suggestion IF one is experiencing "issues" is to remove variables that could potentially cause those "issues" ... start with NI (disable) and Reshade (disable) and proceed with diagnostics.

 

Cloud light reflection is based on moon, season, time, and location ... obviously some locations at specific times of the year are not going to be as dark as other locations at specific times of the year.  I do tend to agree the clouds are a little too reflective of light during early evening hours, but as the evening progresses they get darker.

 

At Water = Ultra, CUDA will help with rendering performance ... so how well one's GPU works with CUDA will have an impact.  Also, LM recently updated P3D to use more recent CUDA libraries from nVidia ... and finally for multi-GPU users there are some settings in the Triton.cfg that can be set to enabled multi-GPU.

 

Cheers, Rob.

Share this post


Link to post

Sorry if it was a we know this already but in Canberra there is not that much water and it just seems to hurt alot. Its not the first water slider i am talking about but the sub categories like reflections of simobject for instance.

 

Autogen slider is not giving a fps hit on my system like water.

 

Reshade is a whole other debate.

 

But sorry if i have taking your time

 

Michael Moe

Share this post


Link to post

Nothing to be sorry about Michael. Your post prompted a short but interesting discussion.

 

Vic

Share this post


Link to post

 

 


At Water = Ultra, CUDA will help with rendering performance ... so how well one's GPU works with CUDA will have an impact.  Also, LM recently updated P3D to use more recent CUDA libraries from nVidia ... and finally for multi-GPU users there are some settings in the Triton.cfg that can be set to enabled multi-GPU.

 

Hi Rob -

 

I follow a lot with Prepar3d threads and this triton.config file thing is a new one to me...

 

I am running 3.1 with SLI 980GTXs. Are you referring to the "disable-cuda= yes"  for the water? You mention other setting to enable multi GPU. Is this a new option for 3.1 and SLI? 

 

Thanks,

Daniel

Share this post


Link to post

Sorry if it was a we know this already but in Canberra there is not that much water and it just seems to hurt alot. Its not the first water slider i am talking about but the sub categories like reflections of simobject for instance.

 

Yes, I had noticed that also and did bring this to LM's attention ... have patience and I think you'll find a solution soon ;)

 

Agree with Vic, nothing wrong with your post, Jeroen probably just crashed his 777 into a lake that day ;)

 

Cheers, Rob.

Hi Daniel,

 

This is the setting in the Triton.cfg (must be running on an x64 OS) ... I noticed a few less long frames when at Water=Ultra, but as you can see from the notes it's not a magic setting, but try it and see.

 

# If multiple GPU's are present, attempt to run FFT calculations in parallel across them
# when using CUDA. Only enable this if you are on x64. Bandwidth seems to be the bottleneck
# with the FFT's, so this doesn't actually help much today.
fft-enable-multi-gpu = yes
 
default is "no"
 
Cheers, Rob.

Share this post


Link to post

 

 

Dial back your "attack meter", water settings have performance implications as does Reshade.  My suggestion IF one is experiencing "issues" is to remove variables that could potentially cause those "issues" ... start with NI (disable) and Reshade (disable) and proceed with diagnostics.

 

Didn't mean to attack you was simply wondering how its related lol. Yeah its true that Reshade can cause some issues with some systems/configs. But the latest versions seem to work quite well with 3.1 and at a negligible performance cost.

 

Problems start when you go overboard with the shaders and settings, just as you would with settings in P3D itself.

 

Water at ultra did not lower my clocks. The biggest hit is still SGSS for me.

Share this post


Link to post

 

 


With that said, P3D stays in P0 state for my setup.

 

Hi Rob

 

How did you manage that? Whenever I set the Water-Settings to Ultra, the P-State of my GTX 980 Ti goes to 2, while otherwise it stays 0, as it should be. While the GPU-usage stays around the same, the Ultra-Water-Setting does have a fps-impact for me (3930k-cpu oc to 4,3 GHz) which it didn't have with my old GTX 680.

 

Cheers

Share this post


Link to post

Hi Daniel,

 

This is the setting in the Triton.cfg (must be running on an x64 OS) ... I noticed a few less long frames when at Water=Ultra, but as you can see from the notes it's not a magic setting, but try it and see.

 

# If multiple GPU's are present, attempt to run FFT calculations in parallel across them

# when using CUDA. Only enable this if you are on x64. Bandwidth seems to be the bottleneck

# with the FFT's, so this doesn't actually help much today.

fft-enable-multi-gpu = yes

 

default is "no"

 

Cheers, Rob.

Thanks Rob, I'lll change it today and give it a try.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this