Sign in to follow this  
asanal

OOM nightmare

Recommended Posts

IT took me three month to  upgrading my pc to HIGH END  with GPU Titanx CPU i7-5960X and installed P3d v3.2 with out any problem. Finally I said to my self I have everything, now I can fly with PMDG 77X .

 

Wow how was I wrong .

 

First flight:  I loaded P3D 3.2 with 2.8 GB available  VAS.  When  777X was ready to leave gate my VAS reduced to 600MB. At cruise I got OOM.   

 

Second flight t reduced the settings ,I got another OOM

 

Third flight: I selected small air port with less scenery, it didn't make any difference  OOM

 

Forth Flight : chanced to PMDG 737 OOM.

 

fifth flight: MJC800Q400 : OOM

:help:

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I don't think better pc components will help with VAS

Share this post


Link to post
Share on other sites

I have the same exact problem. See my sig.

I recently purchased a really expensive PC and I cant believe I have OOM all the time. :-(  I tried every tweak and the conclusion is that flying big planes and complex airports is frustrating.

I think the only solution is to wait to Prepar3D 64bit version.

Share this post


Link to post
Share on other sites

Are you guys sure you have the latest PMDG T7 installed, updated early January this year? It cuts the VAS usage by about 250MB.

Share this post


Link to post
Share on other sites

Also someone stated  (Rob ? )that using HyperThreading could increase VAS by 3-600MB on some CPU/systems?

 

Check with HT=off as well

 

And remember latest PMDG777 version as well as stated by Tom

 

Michael Moe

Share this post


Link to post
Share on other sites

P3D is still 32 bit software, which implies it can only access 4GB of RAM, regardless of how good your system is. However,

 

 

 


fifth flight: MJC800Q400 : OOM

 

This indicates that you probably have to adjust your scenery settings. While PMDG planes are known for OOM problems, the Q400 is one of the most efficient planes in this regard. 

 

Peter

Share this post


Link to post
Share on other sites

It does seem a bit strange that you have OOM'd so frequently.

 

Apart from the suggestions from Michael and Tom, keep in mind that V3 is still not totally OOM proof. If you start the 777 at a highly detailed airport in a high detailed scenery area (FTX Northern Cali or FTX England) with other addons running, you will more than likely OOM.

 

Don't run the 777 or 737 in an Orbx region other than FTX Global if you are using an addon airport.

Share this post


Link to post
Share on other sites

Also, be sure it's a OOM and not a general crash.  I've seen plenty of posts where they think it's an OOM as that's the craze these days. :)  Check drivers, stress test your system, etc may help.

 

Cheers,

Matt.

Share this post


Link to post
Share on other sites

Sounds more like a memory leak from scenery, because its not specific to 1 aircraft.

Share this post


Link to post
Share on other sites

I would suggest a plain vanilla install, no add-on scenery, just the PMDG planes (one at a time, starting with the latest version of the 777) perform your flight and see if the OOM reoccur.  If it does not, start adding the add-on slowly, check, repeat. 

Share this post


Link to post
Share on other sites

The pictures of your P3D settings will help. Even now 4096 textures with LOD6.5 still generates OOM 

Share this post


Link to post
Share on other sites

 

 


the Q400 is one of the most efficient planes in this regard.

Could not have stated better. I have done nearly a 100 flights with the PRO version, with nowhere near the OP's GPU specs, and have yet to experience a single OOM.

Share this post


Link to post
Share on other sites

It's funny because better pcs or pc components mean more processing power which means more processing which ultimately leads to higher vas usage and likelihood of ooms.

 

You need to find a balance in the settings. 4096 textures and shadows at ultra will definitely cause ooms.

Share this post


Link to post
Share on other sites

 I have to disagree...

 

 79jBBIe.png

 

FTX OpenLC, Australia, AYPY airport, VECTOR, 4096 textures, ASN, quite a lot of other stuff running, PMDG737 and as you can see i still have 1875MB of free memory.

 

Something is causing those OOMs and it's not coming from the T7.

Share this post


Link to post
Share on other sites

Thanks for yours responses. :smile:

 

 

Zoran, yes now I know it.

 

Michael,  where is HT located ?

 

Peter, That is the fist time I had a  OOM with Q400

 

Tom, I just recently downloaded from PMDG my account.

 

Peter, MY settings are as follow:

 

Settings-Graphic

FXAA On

MSAA 8 Samples

Texture Filtering  Anisotropic 16x

Texture Resolution 2048x2048

Frame Rate Controls: Vsync On Triple Buffering OF

Target frame rate 24

Hardware Tessellation OFF

Mipmap VC panes ON

 

SCENERY

Terrain Level of details MAX

Mesh Complexity Ultra

Mesh resolution 5cm

Texture resolution 7 cm

 

WATER

 

Water Detail: 0

 

REFLECTION

 

User Vehicle On

Sim Objects On

Terrain, Vegetation, Buildings On

 

SECENERY OBJECTS

 

Scenery complexity :Normal

Autegen Vegetation :Density Normal

Autegen  building density: Extremely Dense

Special effects detail :Off

Special Distance: Off

 

WEATHER

Visual Settings

Cloud  Draw Distance : 90 mi

Volumetric Fog ON

Detailed Clouds ON

 

LIGHTING

HDR ON

Brightness 0.8

Bloom 0.7

Saturation 0.8

Landing Lights illuminate ground ON

Lens Flare ON

 

SHADOWS

 

Quality ULTRA

Treain Distance 0

Cloud Shadow Cast Distance 0

Object Shadow Cast Distance 12000

 

TRAFFIC

Airline 10

GAT  5

Airport Vehicle 0

 

Road Vehicles 10

Ship 0

Boats 0

 

 

Serge, Bitsum is running

 

Erich,  I don't have Orbx region and add-on Airports I have Only FTX Global+Vector

 

Matt, I will check.

Rick, How can I check memory leak

 

Vu, I have to uninstall FSX Global+Vector, Rex, ASN, PMDG 737, Fs2Crew, PMDG 77x,then I reinstall 777X . Is it correct?

I recently downloaded 77x from my PMDG account

 

 

Rick, I love Q400, OOM happened first time.

 

Luke: 64bit I hope so

 

G-YMML1,  I have 2048, LOD6,5 will reduce 4.5

Share this post


Link to post
Share on other sites

I have to disagree...

 

79jBBIe.png

 

FTX OpenLC, Australia, AYPY airport, VECTOR, 4096 textures, ASN, quite a lot of other stuff running, PMDG737 and as you can see i still have 1875MB of free memory.

 

Something is causing those OOMs and it's not coming from the T7.

Shadow quality? CPU and core speed?

 

 

 

 

Ahmet reduce shadows to high. Or go into the config file and reduce shadow cascades to a maximum of 6 for every value.

 

Also check that your ground shadow texture is no higher than 2048 in the config file. Setting it lower will probably help also.

Share this post


Link to post
Share on other sites

Shadows:

In my Config File:

 

SHADOW_CASCADES_LOW=4

SHADOW_CASCADES_MID=5

SHADOW_CASCADES_HIGH=7

SHADOW_CASCADES_ULTRA=12

 

What will be the proper number ?

Thanks

Share this post


Link to post
Share on other sites

Do not turn off Hyperthreading to reduce VAS footprint, instead, in your Prepar3D.cfg put this:

 

[JOBSCHEDULER]

AffinityMask=21760

 

With 16 logical processors the sim will create 16 jobs and use up a lot of VAS. 21760 is recommended for the 8 core HT Enabled. If that doesn't stop it, you've got something chewing up your VAS.

Share this post


Link to post
Share on other sites

Shadow quality? CPU and core speed?

 

 

 

 

Ahmet reduce shadows to high. Or go into the config file and reduce shadow cascades to a maximum of 6 for every value.

 

Also check that your ground shadow texture is no higher than 2048 in the config file. Setting it lower will probably help also.

 

It's a 4970K at 4.6GHz. Speed makes no difference at all. Shadows max, autogen one notch below max, all the rest is maxed except mesh which is set at 5m. GTX980.

 

Hyperthreading is enabled.

Share this post


Link to post
Share on other sites

asanal, on 15 Mar 2016 - 5:06 PM, said:

SCENERY

Terrain Level of details MAX

Mesh Complexity Ultra

 

SECENERY OBJECTS

Autegen building density: Extremely Dense

That may be your problem. Autogen buildings are a killer, especially in

urban areas. I have a much more modest system than you and therefore avoid

flying to/over the NYC area altogether because it kills P3D if I do that.

 

I have read somewhere that P3D settings are more dense than FSX settings

to begin with (normal P3D = extreme FSX). P3D is built for future PCs,

just like FSX was in its time. I guess moderation is the way to go.

 

Peter

Share this post


Link to post
Share on other sites

Peter, I will cumulate all above information, and implement to my PC.

Thanks

Share this post


Link to post
Share on other sites

Reduce a bit the Autogen!!!!! OOM are the hell!

Throw the TEXTUREMAXLOAD back a bit, set it to 2048 that will reduce the memory-load to the g.c (graphic card)

even in p3d.cfg add HIGHMEMFIX=1 this will use all your graphic card memory and use the RAM. Even try to get ORBX trees those reduce the memory load and improve frame rates. 

Any questions ASK me dude! I'm for help i know the nightmare of FSX and P3D :D 

Share this post


Link to post
Share on other sites

 

 


IT took me three month to upgrading my pc to HIGH END with GPU Titanx CPU i7-5960X and installed P3d v3.2 with out any problem. Finally I said to my self I have everything, now I can fly with PMDG 77X .

 

Just to help you or anyone else understand.... As has been alluded to, theres a 4 gb limit that can only be accessed. In theory , If NASAs super computers were able to run FSX or P3D they would still have the potential to OOM. Powerful PC has nothing to do with it.

 

And no one addon is responsible for OOMs. Not PMDG, Not Q400, REX, or any other addon. Not sure why people keep saying, I only OOM with  PMDG. Unless theres a memory leak, PMDG cannot cause the OOM. Its the culmination of all addons running and settings which are using the Virtual Address Space (VAS). Case in point, you can run a PMDG aircraft all day every day and never ever OOM if you had no other addons, and lowered settings to minimum. The memory footprint used is far less from the 4gb limit. Now if you put the settings up to max, and install a high end airport, and you OOM, whos responsible for it? Still no one. Its just the combination of all addons using the 4gb memory space. So you have to compromise so things use less memory. Obviously we are not going to give up a PMDG aircraft, so we turn down settings, and use low texture clouds, and install a lesser textured size airport install if it provides etc.

 

Hope that helps to understand it better.

  • Upvote 1

Share this post


Link to post
Share on other sites

Shadows:

In my Config File:

 

SHADOW_CASCADES_LOW=4

SHADOW_CASCADES_MID=5

SHADOW_CASCADES_HIGH=7

SHADOW_CASCADES_ULTRA=12

 

What will be the proper number ?

Thanks

High and ultra should be reduced to 6.

 

It's a 4970K at 4.6GHz. Speed makes no difference at all. Shadows max, autogen one notch below max, all the rest is maxed except mesh which is set at 5m. GTX980.

 

Hyperthreading is enabled.

Speed does make a difference. Your autogen settings is probably what prevents your sim from ooms.

 

Go back a few pages there was a thread discussing processing power and what it does for VAS usage. Of course it's not a huge jump in VAS for every additional 100 MHz but it does still affect it. What has a higher impact is using a wrong AM or too many cores.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this