penta_a

Prepar3D v4.0 Hotfix 1 released

Recommended Posts

Prepar3D v4 Hotfix 1 has been Released   (4.0.28.21686)  Please see the link below 

http://www.prepar3d.com/news/2017/06/114375/

 

----------------------------

 

Moderators Note 

Only the Client Installer is required to update with the Hotfix 1,   Follow the steps to update with the Client  (In this order) 

 

Note: You need to Uninstall the existing Client First.   I have Included Images in the links 

1)  Navigate to your Control Panel,  Right Click on  Prepar3D v4 Academic \ Professional Client  Click Uninstall 

      You will now be prompted an Option  "Are you sure you want to Uninstall the Client"  Click Yes

     You will then be given an option to  "deactivate Prepar3D v4 or not",  Click No,  By doing this you will not be required to reactive your License after the Client update    

 

2) Sign into your Prepar3D Purchased Downloads fill out the Customer Account Information with your Email address and Account Password

    Click the little + to expand the Component Installers,  The Client is a stand alone Installer, Click on  Install_Client.msi to download 

 

3)  Navigate to your PC Downloads, Right click on the new Install_Client.msi click Install 

 

4)  Confirm the update was successful,  Launch Prepar3D  Click Help >  About Lockheed Martin, Here you can confirm you have the most recent version of Prepar3D v4

 

For a Complete guide Including Recommended steps to take after a client Update please see Here 

 

Edited by Poppet
Client update Information

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

What is important in the list?

 

Thanks,

Share this post


Link to post

for addon developers, mostly texture things and a memory leak.

Share this post


Link to post
Quote

Added Show Only Favorites button back to Vehicle Select Screen

Many will be happy with that alone:happy:

  • Upvote 4

Share this post


Link to post

Making the ICAO selection the default and moving it to the top of the Select Airport screen is a nice-to-have improvement to the customer experience.

  • Upvote 5

Share this post


Link to post
10 minutes ago, stephenbgs said:

Many will be happy with that alone:happy:

Thought I had lost a few more marbles when I couldn't find that.

Share this post


Link to post

Do you smell that? That's the NGX getting closer to release...

Share this post


Link to post

Uh-oh...

"Please be aware that some third party developers might have to update their add-ons to be compatible with the hotfix. Please contact the third party developers directly for any compatibility questions."

Any idea whose add-ons may have troubles?

Share this post


Link to post

I don't have access to my P3D account right now.  Did LM push it as a small download, or does it still involve uninstalling the old client and installing the new client?  I think most of us prefer just to download a small update.

Share this post


Link to post
2 minutes ago, captain_adf said:

Uh-oh...

"Please be aware that some third party developers might have to update their add-ons to be compatible with the hotfix. Please contact the third party developers directly for any compatibility questions."

Any idea whose add-ons may have troubles?

Could be anybody or everybody

Quote

Updated various XML configuration file encodings

 

Share this post


Link to post
9 minutes ago, FrankSalo said:

Do you smell that? That's the NGX getting closer to release...

Exactly my thoughts!

Share this post


Link to post
5 minutes ago, Luis_KMIA said:

I don't have access to my P3D account right now.  Did LM push it as a small download, or does it still involve uninstalling the old client and installing the new client?  I think most of us prefer just to download a small update.

you have to update the client but it only weights 199 Mo

  • Upvote 1

Share this post


Link to post
13 minutes ago, captain_adf said:

Uh-oh...

"Please be aware that some third party developers might have to update their add-ons to be compatible with the hotfix. Please contact the third party developers directly for any compatibility questions."

Any idea whose add-ons may have troubles?

The normal ones. The same thing happened in v3.

Namely Active Sky and Orbx objectflow always need updates.

Share this post


Link to post
10 minutes ago, 238932 said:

you have to update the client but it only weights 199 Mo

Thanks!

Share this post


Link to post
5 minutes ago, bonchie said:

The normal ones. The same thing happened in v3.

Namely Active Sky and Orbx objectflow always need updates.

Well ORBX hasn't produced a 64bit objectflow as yet, hence the airports not available for V4 yet. So we skip that one for now. Activesky we'll have to see since they released an update a few days ago for the V4 version.

Share this post


Link to post
17 minutes ago, 238932 said:

you have to update the client but it only weights 199 Mo

Be nice if I could find where on earth I download just that bit from, not very obvious to me on the website.

Share this post


Link to post

Must I reinstall or is there a hotfix patch?  I dont see any patch, just the full new installer.

Share this post


Link to post
43 minutes ago, FrankSalo said:

Do you smell that? That's the NGX getting closer to release...

Believe I read that a P3D v4 hotfix was required for the 773-not the NGX.

Share this post


Link to post

My P3D v4 is crashing (CTD) when starting after updating the client. Is anyone else having the same problem? I tried to uninstall and reinstall the client 2 times with the same result (crash).

Share this post


Link to post

Yeah,

Time to rejoice. PMDG -300ER and the NGX are nearer.

Share this post


Link to post

I haven't seen any issues with FSUIPCV5 or ORBX. A.S. is definitely compatibility broken.

 

Share this post


Link to post
3 minutes ago, Boomer said:

Must I reinstall or is there a hotfix patch?  I dont see any patch, just the full new installer.

"For those that are interested in updating, only the Client installer is required for Prepar3D v4.0 Hotfix 1. The Content, Scenery, and SDK installers are optional. You must first have Prepar3D v4 installed to utilize the Client only installer."

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now