Sign in to follow this  
wideloadwhit

No autogen, a lot of blurries on decent.

Recommended Posts

Hello team

I seem to be running into a bit of a situation with blurriness on decent. I checked out this thread here to no avail. http://www.prepar3d.com/forum/viewtopic.php?f=6312&t=125808

This only happens when on the decent no matter what aircraft I have installed. The autogen fails to load and all the textures are blurry and unreadable.

i7 7700k 4.8ghz
1080ti 1950mhz boost clock
480GB PNY M.2 3GB/s

ORBX Global, Vector, LC

My Prepar3D Settings

FPS are on unlimited and VSYNC/Triple buffering on. 60hz monitor 60FPS.

The only tweak I use in the Prepar3d.CFG is Affinity Mask of 84. Without this my sim would stutter.


Any thoughts?
Ryan

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Unlimited framerate can cause these kinds of problems.  The sim can't keep up.

Share this post


Link to post
28 minutes ago, Gregg_Seipp said:

Unlimited framerate can cause these kinds of problems.  The sim can't keep up.

I have no choice. I only have a 60HZ monitor and to be able to get a stutter free experience I have to use VSYNC which puts it at 60FPS on unlimited. Is there a way around this?

 

Share this post


Link to post

Try setting it to 30 fps in the sim.. if that does not solve it, 20.

Share this post


Link to post
3 minutes ago, Bert Pieke said:

Try setting it to 30 fps in the sim.. if that does not solve it, 20.

I used to be able to run 30FPS fine in V3.4 but on V4 its extremely laggy with screen tearing. Will a monitor that supports 30Hz fix this issue?

Share this post


Link to post

Looks to be a wide spread problem.  I have the same problem but not as bad as some it seems.  I have it regardless if I'm locked at 33 or unlimited (the two settings I use).

Share this post


Link to post
1 minute ago, JetFueler said:

Looks to be a wide spread problem.  I have the same problem but not as bad as some it seems.  I have it regardless if I'm locked at 33 or unlimited (the two settings I use).

The only thing that I can do is force the sim to refresh the scenery, but there is a risk of it crashing. Do you have a 30HZ screen?

Share this post


Link to post
6 minutes ago, wideloadwhit said:

I used to be able to run 30FPS fine in V3.4 but on V4 its extremely laggy with screen tearing. Will a monitor that supports 30Hz fix this issue?

You should not need a special monitor for this to work.. I have a 60Hz monitor, fps locked at 30, vsync and triple buffering on.

Share this post


Link to post
5 minutes ago, Bert Pieke said:

You should not need a special monitor for this to work.. I have a 60Hz monitor, fps locked at 30, vsync and triple buffering on.

Thanks for your help. I guess for the decent portion of the leg I will limit my FPS to 30 until final approach. That might seem to help. I will report back.

 

Ryan

Share this post


Link to post

I have a 4K TV thats capable of 60/30Hz...

I currently am running with unlimited frames, vsync off, triple buffering off...

Should I set my sim to 60fps locked and turn on vsync and triple buffering or even set it to 30fps locked with vsync on and triple buffering on?

Which would give me a smoother experience?

Share this post


Link to post
24 minutes ago, captain420 said:

Should I set my sim to 60fps locked and turn on vsync and triple buffering or even set it to 30fps locked with vsync on and triple buffering on?

Which would give me a smoother experience?

You can't get a definite answer on that by asking on a discussion forum. It depends on what frame rate your sim can keep up with, which depends on your hardware and your graphics settings and what kind of flying you do. And it depends on what you would personally consider smooth. You will have to test and try it yourself.

It is just a few settings. It doesn't take long to test a bit and see what happens.

  • Upvote 1

Share this post


Link to post
5 hours ago, wideloadwhit said:

Hello team

I seem to be running into a bit of a situation with blurriness on decent. I checked out this thread here to no avail. http://www.prepar3d.com/forum/viewtopic.php?f=6312&t=125808

This only happens when on the decent no matter what aircraft I have installed. The autogen fails to load and all the textures are blurry and unreadable.

i7 7700k 4.8ghz
1080ti 1950mhz boost clock
480GB PNY M.2 3GB/s

ORBX Global, Vector, LC

My Prepar3D Settings

FPS are on unlimited and VSYNC/Triple buffering on. 60hz monitor 60FPS.

The only tweak I use in the Prepar3d.CFG is Affinity Mask of 84. Without this my sim would stutter.


Any thoughts?
Ryan

My PC has the same CPU and graphics card. You don't mention whether you have hyperthreading enabled? I discovered the AffinityMask tweak was causing blurries by restricting the cores available for scenery generation. Try removing the tweak. My scenery loading was greatly improved without an AffinityMask in my CFG. I had major blurries especially at the end of a flight. All was improved when I removed the AffinityMask.

Edited by Peter Webber
Additional comments added.

Share this post


Link to post

Here's a memo with some advice for p3d v4 users:

STOP TWEAKING YOUR CFG!

:biggrin:

Jose

  • Upvote 1

Share this post


Link to post

I also find that using an affinity mask makes the issue worse on my rig, I was running with a mask which essentially made my i7 an i5 (deliberately), taking the job scheduler out and allowing P3d to do what it wants with all available cores/threads greatly improved the situation for me.....but

The reason I masked the secondary threads was because my CPU cores 1 and 3 (skylane I76700K) were occasionally hitting 96c at stock speed with a  water cooler (seidon) at VCPU 1.3v, normally its sat at 30c and when running as an i5 never exceeds 60C. P3d4 really seems to be very aggressive when using hyperthreading

The compromise I have made now is to set a minimum fiber time of .25 to force the sim to do something with the wasted CPU cyles of running unlimited but capped in nvidia inspector at 25, this has improved the situation immensely.

My next session will look at masking hyperthreading on the cores that were overheating to see what effect it has on rendering and scenery loading.  

Share this post


Link to post

I think in a way it's the same as asking if crunchy or creamy peanut butter is better.  Everyone has their own opinion on it and everyone gets different results. For me, I read some where that if you are going to lock your frame rate, to lock it 10% over your target.  It had something to do with the length of time a single frame is rendered and sometimes you get 'long' frames.  I'm not doing the explanation justice here, but I tried it and I liked it.

I've also been experimenting with unlimited frames but I don't like the fluctuations while flying airliners so I'm using 33 for tube flying.  I can tell you this much though- I have the autogen problem regardless of that setting.  For me the Autogen starts to pop back in as I come down through 4-5000ft, usually very near my location at first and then outward. It's always fully loaded by the time I'm setting up for my final approach so my issues aren't nearly as bad as what some people are describing.

Share this post


Link to post
21 hours ago, DJJose said:

Here's a memo with some advice for p3d v4 users:

STOP TWEAKING YOUR CFG!

:biggrin:

Jose

I agree. Just adjust the sliders within P3D until you achieve the desired results. Limiting P3D with an AffinityMask setting can lead to adverse outcomes. Never heard of using this tweak to reduce stuttering...

Share this post


Link to post
2 hours ago, Peter Webber said:

I agree. Just adjust the sliders within P3D until you achieve the desired results. Limiting P3D with an AffinityMask setting can lead to adverse outcomes. Never heard of using this tweak to reduce stuttering...

Incorrect : using a wrong AM setting for your system will lead to adverse outcomes...

Using the correct AM setting for P3D and assigning your addons to the other cores , as SteveW has explained lots ot times will lead to more stability and more smoothness.  

Only when using a 5960X or 7900X processor you might be better of without AM and without HT. 

Share this post


Link to post
5 hours ago, GSalden said:

Incorrect : using a wrong AM setting for your system will lead to adverse outcomes...

Using the correct AM setting for P3D and assigning your addons to the other cores , as SteveW has explained lots ot times will lead to more stability and more smoothness.  

Only when using a 5960X or 7900X processor you might be better of without AM and without HT. 

That is basically what I am trying to say. This is very hardware and system dependent. Steve's suggestions with AM worked great on my laptop. Since moving to my new system with the same settings, blurries galore. So there is no "correct or incorrect" with a post. If I apply any AM to my new system, I get blurries. So in your words, "incorrect" may apply to your setup. Without any cfg tweaking, my system works great. We have to be careful about labeling a post "incorrect" based on own user and system experience.

Share this post


Link to post
9 hours ago, GSalden said:

Incorrect : using a wrong AM setting for your system will lead to adverse outcomes...

Using the correct AM setting for P3D and assigning your addons to the other cores , as SteveW has explained lots ot times will lead to more stability and more smoothness.  

Only when using a 5960X or 7900X processor you might be better of without AM and without HT. 

and what happens when you do not use an AM setting?

Does SteveW explanation pertain to p3d v4?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this