ryanbatcund

F1 to RXP GTN Gauge ready

Recommended Posts

How this works in a nutshell:  If you own an addon with a F1 GTN native VC integration (3d bezel/gauge etc) and want your clickspots to work with RXP, this is the gauge you need.

It's been verified to work in these addons (and it should work in nearly all): Carenado, Realair, A2A, Milviz.  There is a little user editing required, but it's not hard - read the readme (use Notepad++ for best results)

Also there is a small issue that I can't figure out - some users are reporting the need for double click on the HOME and DTO buttons.  Doesn't happen on my machine but a few have reported it.

If you have any ideas as to why it may be happening put it in this thread, maybe we can figure out why.

The File: https://www.dropbox.com/s/uzcdlpobpzlmh5t/rxpGTN_f1vc_final.zip?dl=0

24040258717_b361149bdb_o.jpgall by ryan b, on Flickr

 

 

  • Upvote 2

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Nicely done Ryan!  Just put the 750 in my first plane last night (Turbine Duke), and your posting popped up just in time to add your gauge.  Seemed to work well.

Thanks for your efforts and for sharing them with the community.

Scott

Share this post


Link to post
Share on other sites

Thank you for having conducted beta tests on this gauge Ryan!

It was fun to put my hands on XML code for the first time, and to come up with a solution which works with any aircraft. I would have like to find a way to make panel.cfg gauges detection automatic so as to eliminate the hand editing of the xml gauge, but I've not been able to give more thought about this.

Ideally, this gauge should go in the assistant managed process, so that upon analysis of the replaced gauges, it would put an automatically edited version of the XML gauge in the panel folder, matching the modified panel.cfg gauges.

Otherwise, I don't know yet if XML gauges support the 5th param, which in this case, would help make this gauge parametrizable in the panel.cfg without editing the XML file at all!

Share this post


Link to post
Share on other sites

Hi Folks,

This just keeps getting better and better... Thanks for the hard work ! I'll try and test it this weekend...

Regards,
Scott

 

Share this post


Link to post
Share on other sites
1 hour ago, scottb613 said:

Hi Folks,

This just keeps getting better and better... Thanks for the hard work ! I'll try and test it this weekend...

Regards,
Scott

 

Hehe...this post dovetails perfectly with our discussion here Scott: https://www.avsim.com/forums/topic/525961-ups-majestic-dash-8-repaint/?do=findComment&comment=3764529

Found it when I was on your profile page just about to PM you.  Looks like I have some answers I've been looking for. :)

@ryanbatcund - Thanks for this file and I'll test it as well and report back when I decide which light jet to buy on the Carenado sale.

As I've been shopping, I've been playing the with GTN and added it to the F22 (yeah I know right) and it works beautifully (as an undocked gauge) with the F22's AP that I also learned to use while testing this great piece of nav software.  Links great with the lateral nav and steers the mutli-million dollar fighter around like a Cessna...even leading the turns on waypoints properly (read: really early) when your busting every speed restriction known to aviation (who doesn't yearn to push 500kts at 2000ft...because you can!) :biggrin:

Very impressed with the product even with my limited time with it so far.

Share this post


Link to post
Share on other sites
17 minutes ago, ryanbatcund said:

@ttocs007 @scottb613 @steve

thanks hope it helps your simming addiction lol!

Uhhh...."helps" is a relative word Ryan depending on who you ask....ask a non-simmer who doesn't understand our nutty addiction, and they'd say it's hurting my chances to cure this silly addiction...but ask anyone of the rest of us, and we'll understand your meaning is to only perpetuate our deep, spiraling dive into this crazy hobby. 

So in other words...THANKS!:biggrin:

Share this post


Link to post
Share on other sites
1 hour ago, ryanbatcund said:

thanks hope it helps your simming addiction lol!

LOL. Ever since the RXP's were released my tubeliners have been collecting dust.

Share this post


Link to post
Share on other sites
1 hour ago, bills511 said:

LOL. Ever since the RXP's were released my tubeliners have been collecting dust.

Thank you! I do hope they'll collect even more once we release the Reality XP G600/500!

Share this post


Link to post
Share on other sites
7 minutes ago, RXP said:

Thank you! I do hope they'll collect even more once we release the Reality XP G600/500!

They may end up in the boneyard then. LOL

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Ryan - I'm getting a 429 error from the Dropbox link - is the file hosted elsewhere now?  

Many thanks

Cheers

Paul

Share this post


Link to post
Share on other sites
4 hours ago, bills511 said:

For some users (myself included) have to double click on the buttons to work.

I for one am having great success with this with RXP GTN 750_1, but in the RealAir TDv2, the only aircraft where I have both a 750_1 and 750_2 in the VC, I cannot get this to work on 750_2.  I have tried both possible settings for the four separated parameters in the xml file, 8 or 0.  Clicking twice does not work either.  for 750_1 it works fine.

Edited by fppilot

Share this post


Link to post
Share on other sites

Here's a new link.  Sorry about the link being down.  Some people or person told dropbox I was hosting a copyrighted file and that is simply not the case.  The files were created from scratch.  EDIT:  Grrrr, this link doesn't seem to work either... just PM me with your email for now until this stupid debacle is sorted out. 

https://www.dropbox.com/s/z9bj63eg2ygw5cj/rxpGTN_forVC.zip?dl=0

@fppilot - I've got the gauge working the T Duke and Legacy both have dual GTN 750's.  You've double and triple checked that the "use simulator commands" is active for both GTN's?

Edited by ryanbatcund
  • Upvote 1

Share this post


Link to post
Share on other sites
16 hours ago, ryanbatcund said:

You've double and triple checked that the "use simulator commands" is active for both GTN's?

Whoops!  Likely not for the 750_2.  Will check and advise.

That was it!  Thanks Ryan. Working great now!

Edited by fppilot
  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now