Jump to content

Sign in to follow this  
ryanbatcund

P3D v4.5 - in VC screen flashes briefly

Recommended Posts

Posted (edited)

Having a weird issue only happens in VC.  I'm also using windowed mode.

I get a brief but somewhat frequent black flash of the screen.

Here's a short video to illustrate this.  (Not the best video....the flash happens early on and then once or twice later)

https://s.amsu.ng/nkSrTYWyCflN

Oh I'm also using Windows 10 now with all patches.

Edited by ryanbatcund

|Ryan Butterworth|

| i7 4790K@4.4GHz | 32GB RAM | EVGA GTX 1080Ti | ASUS Z97-Pro | 1TB 860 Evo | 500GB 840 Evo Win10 Pro | 1TB Samsung 7200rpm | Seasonic X750W |

 

 

Share this post


Link to post

I was getting the same thing,In my case,caused by Asus AI Suite.

  • Like 2

Jim Driscoll


 

Share this post


Link to post

Try right clicking on the Prepar3d icon, click on Compatibility and uncheck Full Screen Optimization and see if that fixes it.

  • Upvote 1

Alan

Share this post


Link to post
31 minutes ago, exeodus said:

Try right clicking on the Prepar3d icon, click on Compatibility and uncheck Full Screen Optimization and see if that fixes it.

I tried that from a google search.  No luck.  Some people have reported that the latest Win10 update "1903" is causing it....rolling back helped.  I haven't tried that yet.


|Ryan Butterworth|

| i7 4790K@4.4GHz | 32GB RAM | EVGA GTX 1080Ti | ASUS Z97-Pro | 1TB 860 Evo | 500GB 840 Evo Win10 Pro | 1TB Samsung 7200rpm | Seasonic X750W |

 

 

Share this post


Link to post
1 hour ago, ryanbatcund said:

I tried that from a google search.  No luck.  Some people have reported that the latest Win10 update "1903" is causing it....rolling back helped.  I haven't tried that yet.

Since I did a new install from 4.3 to 4.5 my screen is flashing too. I did not updated Win 10 to 1903 yet, I'm still on 1809.

 

Share this post


Link to post
Posted (edited)
2 hours ago, exeodus said:

Try right clicking on the Prepar3d icon, click on Compatibility and uncheck Full Screen Optimization and see if that fixes it.

Hi..just a slight correction. You must "check" Diasble Fullscreen Optimization..Regards.

Edited by Peter Webber
  • Like 1
  • Upvote 1

Peter Webber

Prepar3D v4 / Windows 10 Home Edition / CPU i7-7700K / MSI Z270 XPower Gaming Titanium / Samsung 960 EVO M.2 500GB / Corsair Vengeance DDR4 32GB 3000MHz / MSI Geforce GTX 1080Ti Gaming X

Share this post


Link to post
2 hours ago, ryanbatcund said:

I tried that from a google search.  No luck.  Some people have reported that the latest Win10 update "1903" is causing it....rolling back helped.  I haven't tried that yet.

Hi..just a slight correction. You must "check" Diasble Fullscreen Optimization..Regards.


Peter Webber

Prepar3D v4 / Windows 10 Home Edition / CPU i7-7700K / MSI Z270 XPower Gaming Titanium / Samsung 960 EVO M.2 500GB / Corsair Vengeance DDR4 32GB 3000MHz / MSI Geforce GTX 1080Ti Gaming X

Share this post


Link to post

Also, under your Windows settings, ensure "Game Mode" is off. I noticed this setting is sometimes enabled by default and in my setup, it caused issues with performance.


Peter Webber

Prepar3D v4 / Windows 10 Home Edition / CPU i7-7700K / MSI Z270 XPower Gaming Titanium / Samsung 960 EVO M.2 500GB / Corsair Vengeance DDR4 32GB 3000MHz / MSI Geforce GTX 1080Ti Gaming X

Share this post


Link to post

Same issue here.  I'll try these suggestions tonight, but ties in with 1903 update it appears.... 

Share this post


Link to post

This is caused because you are using P3D in windowed mode, two posible solutions:

A)you can switch to full screen instead.

or

B) Enable tipple buffering with Vsync enabled which will also remove the issue.

 

Regards,

S. 

Share this post


Link to post
1 hour ago, simbol said:

This is caused because you are using P3D in windowed mode, two posible solutions:

A)you can switch to full screen instead.

or

B) Enable tipple buffering with Vsync enabled which will also remove the issue.

 

Regards,

S. 

Do you mean running in windowed mode AND using Windows10?  Because I've never had this before in win7.


|Ryan Butterworth|

| i7 4790K@4.4GHz | 32GB RAM | EVGA GTX 1080Ti | ASUS Z97-Pro | 1TB 860 Evo | 500GB 840 Evo Win10 Pro | 1TB Samsung 7200rpm | Seasonic X750W |

 

 

Share this post


Link to post

I’ve got the same issue in full screen mode. Win 10 issue. 


Best regards,
David Roch


Intel 9900K@5.1, Asus Maximus XI Formula, 32Gb G.Skill TridentZ 4133 CL17, EVGA RTX 2080 Ti XC ULTRA GAMING, 3x SSD Samsung 970 Pro M.2, Corsair 1600W PSU & 49" 4K TV monitor@30fps.

Share this post


Link to post

The specific feature causing this for me was having cockpit tool-tips "enabled" in the VC.  Disabling cockpit tool tips stopped the black flashes.  As was mentioned above, checking [enabling the check-mark] next to "Disable fullscreen optimizations" in the Prepar3D.exe properties also did the trick.



Doug Miannay

M1mhPJG.png 1BV5Kt7.jpg

PC Specs: i7-8700K (OC 5.0GHz - HT Off) | ASUS Maximus X Hero Z370 | Corsair Hydro H150i Pro Cooler | ASUS STRIX-RTX2080TI-11G | 32GB G.Skill DDR4 TridentZ RGB 4000Hz  | Samsung 960 Pro 512GB M.2 (OS/Apps) | Samsung 960 Pro 1TB M.2 (Sim/Games) | Corsair H1000i PSU | Fractal Design Define R6 Blackout Case | Win10 Pro x64

Addons: Many Orbx Products | Many FSD/FB/FT/PacS/LatinV/Aerosoft Airports | ASP4/ASCA | UTL at 35% | ChasePlane | PMDG/FSL/A2A Aircraft

Share this post


Link to post

Ditto - tool tips was the culprit for me.

 

Vic


 

P3D#1 - 7700K 5.0g ROG X270F 3600 15-15-15 - EVGA RTX 2080ti 1000W PSU 1- 850G EVO SSD, 2-256G OCZ SSD, 1TB,HAF942-H100 Water W1064Pro
40" 4K Monitor 3840x2160 - AS16, ASCA, GEP3D, UTX, Toposim, ORBX Regions, TrackIR
P3D#2 - 3770K 4.7g Asus Z77 1600 7-8-7 GTX1080ti DH14 850W 2-1TB WD HDD,1tb VRap, Armor+ W10 Pro 2 - HannsG 28" Monitors
 

Share this post


Link to post

Something must have changed people's settings then as this didn't happen before 1903 came out. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
×
×
  • Create New...