Jump to content
Sign in to follow this  
MrFuzzy

Frame generation for all RTX cards

Recommended Posts

Okay. I've done a couple more flights. Currently flying KORD-KMSP.

I have finally seen the "shimmering" overlay windows that y'all have been talking about. I had a vehicle drive behind a menu while it was up and I saw it. It only happens if you have a menu open and pan, or if something moves behind the menu. I can live with it. I guess I don't use the menus often enough during the course of a flight for me to notice it. I use the AI ATC assistant, so I never use the ATC menu, and I'm generally looking down in the cockpit at the EFB when I use the GSX menu during the approach to set up my gate prior to arrival.

I'm definitely keeping this mod.

  • Like 1

 i9-10850K, ASUS TUF GAMING Z490-PLUS (WI-FI), 32GB G.SKILL DDR4-3603 / PC4-28800, EVGA GeForce RTX 2080 Ti BLACK EDITION 11GB running 3440x1440 

GONE BOATING - It's like fishing, but with a clean deck.

Share this post


Link to post
Share on other sites
8 hours ago, V1ROTA7E said:

You must have not done something correctly. You need to set a FPS cap in the NVCP MSFS profile of 60. Assuming you’re not using Gsync or similar, this would be your monitor’s refresh rate (60Hz). Do not use Afterburner for this or it will cause flickering and stuttering. Secondly, you need to enable Vsync in the NVCP. Not “fast,” not “adaptive,” just select “on.”

I followed the guidance to set NVCP Max Rate to 60 and that yielded the bad ghosting artifact, and as mentioned the flickering.  No stuttering per se, just modest flickering.  We were advised to disable Vsync which I did, and I do use a Gsync display, and the default refresh is 100Hz here.   Are you saying by disabling Gsync, enabling Vsync in NVCP, setting my display to 60hz, and max rate in NVCP to 60 this will get rid of all of the visual artifacts?  If you're sure of that I'll try it again.  To be clear--RTSS sync method had no impact on these artifacts, off or on.

Cheers


Noel

System:  7800x3D, Thermal Grizzly Kryonaut, Noctua NH-U12A, MSI Pro 650-P WiFi, G.SKILL Ripjaws S5 Series 32GB (2 x 16GB) 288-Pin PC RAM DDR5 6000, WD NVMe 2Tb x 1, Sabrent NVMe 2Tb x 1, RTX 4090 FE, Corsair RM1000W PSU, Win11 Home, LG Ultra Curved Gsync Ultimate 3440x1440, Phanteks Enthoo Pro Case, TCA Boeing Edition Yoke & TQ, Cessna Trim Wheel, RTSS Framerate Limiter w/ Edge Sync for near zero Frame Time Variance achieving ultra-fluid animation at lower frame rates.

Aircraft used in A Pilot's Life V2:  PMDG 738, Aerosoft CRJ700, FBW A320nx, WT 787X

 

Share this post


Link to post
Share on other sites
7 minutes ago, Noel said:

I followed the guidance to set NVCP Max Rate to 60 and that yielded the bad ghosting artifact, and as mentioned the flickering.  No stuttering per se, just modest flickering.  We were advised to disable Vsync which I did, and I do use a Gsync display, and the default refresh is 100Hz here.   Are you saying by disabling Gsync, enabling Vsync in NVCP, setting my display to 60hz, and max rate in NVCP to 60 this will get rid of all of the visual artifacts?  If you're sure of that I'll try it again.  To be clear--RTSS sync method had no impact on these artifacts, off or on.

Cheers

You should use same refresh rate for your monitor as set in game/nvcp. Meaning that, if you set 60 fps in game, you should set the same for your monitor. If gsync is used, game v-sync should be disabled, and in nvcp you should set variable refresh rate, so that you montors g-sync would support any fps game is producing, thus removing any issues that would be visible without v-sync.

 

Natively, nvidia frame generation does not support v-sync. Only way to enable it is to use g-sync or free-sync comapatible monitors and set them up accordingly.

Share this post


Link to post
Share on other sites
3 minutes ago, MindeK said:

You should use same refresh rate for your monitor as set in game/nvcp. Meaning that, if you set 60 fps in game, you should set the same for your monitor. If gsync is used, game v-sync should be disabled, and in nvcp you should set variable refresh rate, so that you montors g-sync would support any fps game is producing, thus removing any issues that would be visible without v-sync.

 

Natively, nvidia frame generation does not support v-sync. Only way to enable it is to use g-sync or free-sync comapatible monitors and set them up accordingly.

Do you believe this, in my case setting refresh to 60hz, retaining Gsync, setting NVCP refresh to variable, eliminates all the ghosting or other graphic artifacts?


Noel

System:  7800x3D, Thermal Grizzly Kryonaut, Noctua NH-U12A, MSI Pro 650-P WiFi, G.SKILL Ripjaws S5 Series 32GB (2 x 16GB) 288-Pin PC RAM DDR5 6000, WD NVMe 2Tb x 1, Sabrent NVMe 2Tb x 1, RTX 4090 FE, Corsair RM1000W PSU, Win11 Home, LG Ultra Curved Gsync Ultimate 3440x1440, Phanteks Enthoo Pro Case, TCA Boeing Edition Yoke & TQ, Cessna Trim Wheel, RTSS Framerate Limiter w/ Edge Sync for near zero Frame Time Variance achieving ultra-fluid animation at lower frame rates.

Aircraft used in A Pilot's Life V2:  PMDG 738, Aerosoft CRJ700, FBW A320nx, WT 787X

 

Share this post


Link to post
Share on other sites

Anyone notice any noticeable changes with 0.70?


Discord | YouTube | Facebook

34" Odyssey OLED G8 175Hz | 3440X1440 | AMD Ryzen 7 7800X3D | PNY VERTO OC GeForce RTX 4070 Ti SUPER 16 GB | G.Skill Flare X5 32 GB (2 x 16 GB) DDR5-6000 CL30 | Asus ROG STRIX B650E-F GAMING WIFI ATX AM5 | Samsung 990 Pro 2 TB M.2-2280 PCIe 4.0 X4 | ARCTIC Liquid Freezer III 56.3 CFM Liquid CPU Cooler | Fractal Design North XL ATX Full Tower Case

Share this post


Link to post
Share on other sites

From NVIDIA....

Why does it seem like DLSS Frame Generation works on RTX 20 and 30 series GPUs in Portal Prelude RTX?

A: We’ve noticed that some members of the PC gaming community, like Discord Communities before it, have encountered a bug in an old v1.0.1.0 DLSS DLL that falsely appears to generate frames on 20/30-series hardware. There is no DLSS Frame Generation occurring—just raw duplication of existing frames. Frame counters show a higher FPS, but there is no improvement in smoothness or experience. This can be verified by evaluating the duplicated frames using tools like NVIDIA ICAT, or viewing the error message in the Remix logs indicating an error with frame generation.

DLSS frame generation DLLs have since fixed this bug, and NVIDIA will be issuing an update to RTX Remix in the future to prevent further confusion when frame generation is behaving incorrectly.

https://www.nvidia.com/en-us/geforce/forums/geforce-graphics-cards/5/528723/portal-prelude-rtx-dlss-frame-generation-question/

  • Like 1

Discord | YouTube | Facebook

34" Odyssey OLED G8 175Hz | 3440X1440 | AMD Ryzen 7 7800X3D | PNY VERTO OC GeForce RTX 4070 Ti SUPER 16 GB | G.Skill Flare X5 32 GB (2 x 16 GB) DDR5-6000 CL30 | Asus ROG STRIX B650E-F GAMING WIFI ATX AM5 | Samsung 990 Pro 2 TB M.2-2280 PCIe 4.0 X4 | ARCTIC Liquid Freezer III 56.3 CFM Liquid CPU Cooler | Fractal Design North XL ATX Full Tower Case

Share this post


Link to post
Share on other sites
24 minutes ago, Noel said:

I followed the guidance to set NVCP Max Rate to 60 and that yielded the bad ghosting artifact, and as mentioned the flickering.  No stuttering per se, just modest flickering.  We were advised to disable Vsync which I did, and I do use a Gsync display, and the default refresh is 100Hz here.   Are you saying by disabling Gsync, enabling Vsync in NVCP, setting my display to 60hz, and max rate in NVCP to 60 this will get rid of all of the visual artifacts?  If you're sure of that I'll try it again.  To be clear--RTSS sync method had no impact on these artifacts, off or on.

Cheers

In this case, because it's a "hack," yes, I'd disable Gsync and set a hard refresh rate of 60Hz. It should get rid of the flickering. Apparently, the slight ghosting is normal for the first few seconds in external view when panning around fast. But like I said, do not use Riva Tuner to set a max framerate, it's gotta be done in the NVCP.


AMD 7950X3D | 64 GB RAM | RTX 4090

B737 Pilot

 

Share this post


Link to post
Share on other sites
Just now, iFlySimX said:

From NVIDIA....

Why does it seem like DLSS Frame Generation works on RTX 20 and 30 series GPUs in Portal Prelude RTX?

A: We’ve noticed that some members of the PC gaming community, like Discord Communities before it, have encountered a bug in an old v1.0.1.0 DLSS DLL that falsely appears to generate frames on 20/30-series hardware. There is no DLSS Frame Generation occurring—just raw duplication of existing frames. Frame counters show a higher FPS, but there is no improvement in smoothness or experience. This can be verified by evaluating the duplicated frames using tools like NVIDIA ICAT, or viewing the error message in the Remix logs indicating an error with frame generation.

DLSS frame generation DLLs have since fixed this bug, and NVIDIA will be issuing an update to RTX Remix in the future to prevent further confusion when frame generation is behaving incorrectly.

https://www.nvidia.com/en-us/geforce/forums/geforce-graphics-cards/5/528723/portal-prelude-rtx-dlss-frame-generation-question/

This is completely unrelated to our situation. We are using NOT Nvidia Frame Generation but AMD, which is freeware software based solution. Only thing that MSFS does not support that (probably will be implemented some time latter), thus additional hack is used to trick MSFS to think that Nvidia Frame generation is used, instead of AMD.

  • Like 3
  • Upvote 2

Share this post


Link to post
Share on other sites
6 minutes ago, V1ROTA7E said:

In this case, because it's a "hack," yes, I'd disable Gsync and set a hard refresh rate of 60Hz. It should get rid of the flickering. Apparently, the slight ghosting is normal for the first few seconds in external view when panning around fast. But like I said, do not use Riva Tuner to set a max framerate, it's gotta be done in the NVCP.

I'll try it now which I'm doing.  The "slight" ghosting was not slight, at all, but I had not disabled Gsync and had refresh at 100 so we'll see in a few seconds if this makes the significant difference needed to continue trying this hack.

 

  • Like 1

Noel

System:  7800x3D, Thermal Grizzly Kryonaut, Noctua NH-U12A, MSI Pro 650-P WiFi, G.SKILL Ripjaws S5 Series 32GB (2 x 16GB) 288-Pin PC RAM DDR5 6000, WD NVMe 2Tb x 1, Sabrent NVMe 2Tb x 1, RTX 4090 FE, Corsair RM1000W PSU, Win11 Home, LG Ultra Curved Gsync Ultimate 3440x1440, Phanteks Enthoo Pro Case, TCA Boeing Edition Yoke & TQ, Cessna Trim Wheel, RTSS Framerate Limiter w/ Edge Sync for near zero Frame Time Variance achieving ultra-fluid animation at lower frame rates.

Aircraft used in A Pilot's Life V2:  PMDG 738, Aerosoft CRJ700, FBW A320nx, WT 787X

 

Share this post


Link to post
Share on other sites

One thing I would like to note, maybe it would be helpful for someone.

Following instructions I've enabled fg in msfs and disabled v-sync. In nvcp set v-sync for msfs. My monitor refresh rate is 60hz. By doing that I've got fg but it was somewhat lagy, althought steam fps counter was showing 60fps. Later just trying various settings I've set in nvcp max frame rates to 60 and wow it changed a lot. Msfs feel became so smooth and it feels that this is how real fg should work and feel.

 

tldr : set in nvcp max frame rates to your monitor current hz rate.

Share this post


Link to post
Share on other sites
1 minute ago, Noel said:

I'll try it now which I'm doing.  The "slight" ghosting was not slight, at all, but I had not disabled Gsync and had refresh at 100 so we'll see in a few seconds if this makes the significant difference needed to continue trying this hack.

 

also, how many frames do you get in this particular situation without fg? it might be just that you initial frame rates are too low, so you get like 50% real frames and %50 generated, which might have that ghosting effect. Try maybe setting everything to 60 if you monitor support that.

Share this post


Link to post
Share on other sites
3 minutes ago, MindeK said:

also, how many frames do you get in this particular situation without fg? it might be just that you initial frame rates are too low, so you get like 50% real frames and %50 generated, which might have that ghosting effect. Try maybe setting everything to 60 if you monitor support that.

i believe he gets around 35+, so he shouldn't have any issues.


AMD 7950X3D | 64 GB RAM | RTX 4090

B737 Pilot

 

Share this post


Link to post
Share on other sites

Just so people understand and avoid any confusion.

DLSS3 is Frame Generation using AI. These in turn are powered by the Tensor cores that reside on a 4000 series die. These tensor cores do not exist on previous generation Nvidia devices. This is why previous generations can't use DLSS3 Frame Generation.

FSR3 on the other hand is an AMD solution that uses algorithmic based frame generation. Theoretically any DX12 card can process this algorithim thus allowing previous generation Nvidia cards to achieve frame generation and in some games, all cards.

It's also important to note that frame generation is, fake frames. It provides, visually, more frames, but your game itself is still running at it's regular amount of frames. This means things like peripherals response and panning will all react at the non-FG fps. To avoid this difference in latency you can use things like Nvidia Reflex or in the case of FSR3 there's Anti-Lag.

  • Like 2
  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...