Jump to content
Sign in to follow this  
Guest

The perfect HDR ...

Recommended Posts

Thanks for sharing your hard work Rob.

As i fly in night quite often i wonder if there is a "compromise" setting for both, day and night, cause with your changes the night is much to brigth :-(

 

Appreciate your help Rob!

 

Carsten


Carsten U

Share this post


Link to post
Guest

 

 


cause with your changes the night is much to brigth :-(

 

You can certainly experiment with the values to find a balance ... but I haven't noticed night being too bright?  

 

Here is a sample video I made for HDR testing (KLAS look about right for night to me):

 

 

Cheers, Rob.

Share this post


Link to post

You can certainly experiment with the values to find a balance ... but I haven't noticed night being too bright?

 

Here is a sample video I made for HDR testing (KLAS look about right for night to me):

 

 

 

Cheers, Rob.

Thanks Rob for coming back to ma that fast.

 

The first part with the 747 at KLAX looks pretty good for me. The last part with the airbus is what i experience too. I first thought it is because of full moon that lights the scenery during night and looks awesome but i also tried a time without full moon and i feel it is still a too bright... But its only my feeling...

 

Thanks again, Carsten


Carsten U

Share this post


Link to post

Hi Rob,

it gives me the best and most realistic looking scenery ever (ORBX). It looks even more threedimensional than bevore. My monitor: Dell U3011, 2560x1600

Thank you for sharing this.

Bruno


Bruno

Share this post


Link to post

I really liked these edits. Like I said before, I can compare it to when you adjust your TV with something like DVE and now you have better shadow detail. Everything looks clearer and you get to see things you didn't see before, because it was too dark, as when you are crushing blacks.

 

Only thing I wish we could do is keep the brightness the way it is with the tweak, BUT have the shadows, especially cloud shadows, appear darker. They look too light.


Regards,

Efrain Ruiz
LiveDISPATCH @ http://www.livedispatch.org (CLOSED) ☹️

Share this post


Link to post

Tried these settings as well and like them.  Thanks, Rob!


Regards,

 

Kevin LaMal

"Facts Don't Care About Your Feelings" - Shapiro2024

Share this post


Link to post
Guest

The last part with the airbus is what i experience too.

 

The last part is landing at Oslo (yes I know I need some practice here on manual landings ... the flight was just for testing HDR) ... it's actually still "dusk" and not night yet.  When at night Oslo is similar to KLAS.

 

I have made some adjustments as I've test out more areas, 3rd party, and various times of day/night and think I found a good balance for my setup.

 

GPUTerrain.fx

line 881:  BaseColor *= lerp( .36f, 1.0f, fAlpha );

 

HDR.hlsl

line 166: avgLuminance *= 0.75f;

 

But these values are here to experiment with as everyone will have a different preference ... the screen resolution (pixel count) will influence HDR's processing.

 

Cheers, Rob.

 

EDIT: listen to real world ATC from 0:10-0:22 ... got a little emotional there (this was live KLAS ground)

Share this post


Link to post

Yeah I found I can't use those settings at night. It doesn't look too bad with panel lights (or dome lights, etc) off, but when they're turned on, everything gets "blown out" (i.e. highly over-exposed.) No doubt it does this because the HDR shader samples the overall brightness of the image, and as it's nighttime it reads a lot of darkness and boosts the overall gamma a lot. During the day it's fine because the daytime light helps balance out the cockpit, but at night the contrast creates the over-exposed look.

 

For a good example of this, load up the RealAir Duke or Legacy at night, and turn the panel lights on. You'll see how blown-out the textures look. Then toggle HDR off and see how it's supposed to look.

 

I don't do that much night flying anyway so it doesn't really bother me as it takes about 5 seconds to turn HDR off, but it would be cool to find a better middle ground.

Share this post


Link to post
Guest

It doesn't look too bad with panel lights (or dome lights, etc) off, but when they're turned on, everything gets "blown out" (i.e. highly over-exposed.)

 

Have you tried changing the value below to reduce bloom blur (glow) = I'm currently at 1.5 ... increasing reduces.  It worked well for the CS 777 as in my video ... without that value those green backlights on the 777 panel would have a significant bright glow ... setting of 1.5 reduces that significantly.

 

\ShadersHLSL\PostProcess\HDR.HLSL

 

Line 12:

static const float BloomBlurSigma = 1.5;

 

Cheers, Rob.

Share this post


Link to post

Went back to the original settings because it looks best on my rig. Anyway, thanks for sharing your findings.

Spirit

Share this post


Link to post

Rob thanks for the tweak!  I applied them last night to my system and they really made a remarkable difference!

Share this post


Link to post

Hi Rob,

 

Followed your tweaks (and updates) and I must say the change was quite remarkable - that's on my Alienware M18x Notebook 18.4" monitor screen.

 

Coupled with a recent recalibration of the monitor, along with a discovery which ensured that the icm profile LUT settings stayed put, Prepar3D is now transformed in appearance and is gorgeous to look at.

 

My only reservation is the appearance of snow - I think I'm suffering from snow blindness as the white is clipped and in places so intense that there is no visible discernible surface detail. Any thoughts?

 

Otherwise, it is safe to say I am more than happy with your HDR tweaks!

 

Many thanks!

 

Mike


My rig: ASUS ROG Rampage V Extreme, i7-5960X (Dynamic OC 4.6 GHz - all cores, HT=ON), Corsair H110i GT Cooler, G.SKILL Ripjaws 4 16GB (4 x 4GB) DDR4 3000, ASUS GTX 1080Ti ROG STRIX 11GB, (Drivers: 441.66 (Win7), 511.23 (Win10)), Samsung 850 EVO 1TB SSD x4, Samsung 970 EVO 2TB V-NAND M.2, EVGA 1200 P2 Watt PSU, Cooler Master HAF X, ASUS PG278Q (G-Sync) at 120Hz. Oculus Rift. Dual Boot: Windows 10 Pro 64bit (2004) / Prepar3D v5.3.17.28160, Windows 7 Pro 64bit / Prepar3D v4.5.12.30293.

Share this post


Link to post

Hi Rob,

Please excuse my ignorance, but just which file are you modifying and where can I find it? I thought you were working with the P3D cfg, but I went there and can't find anything like you are talking about.

Thanks.

Howard

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...