Sign in to follow this  
P3Dv4Pilot

FSDT Addon Manager telling me my .xml's are corrupt

Recommended Posts

after installing kjfkv2 near the end of the install I received a message that my dll.xml and exe.xml are corrupt and it asks to correct it?  why? is this a bug?  my fsx before the kjfk install ran great with no errors.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I've also had this when I re-installed it after I had lost the Add-on Manager from the drop-down menu in P3D. I corrected it and have had no issues whatsoever.

Share this post


Link to post
Share on other sites

Ya, I installed the BETA and its screwed up my XML, had install tons of addons. 

Share this post


Link to post
Share on other sites

I recently updated the Addon Manager and got the same messages. I told it to go ahead and fix both dll.xml and exe.xml, and it makes a back-up of the old xml files. Afterwards, I went and looked at what Coatl did, and it manages to make the Addon Manager the only entry in the new xml files. I also compared the new ones to what was in the old ones, and there was no difference. None.

 

SO...I just opened the back-ups, copied the new data from the Coatl files into them, and saved them as the old dll.xml and exe.xml. It seems to have fixed the proble. But I would like to know why it does this. Any feed-back from the Coatl developers?

Share this post


Link to post
Share on other sites

Any feed-back from the Coatl developers?

 

If you want  a answer  from  Virtuali  than your best bet is  to post it in the fsdst forum 

Share this post


Link to post
Share on other sites

According to FSDT the problem is one of the addons saved the file with a different encoding then is in the header of the file (ANSI), they suspect ASN. Sure enough I checked the dll and exe.xml files, and both were saved in UTF-8 format, but still had the Windows Ansi header on them. I then resaved them with ANSI encoding to match the header however, but I still get the same issue, so I'm not so sure that is the only problem. All I do is answer no to rebuild the files, and all is well, because the entries, are already in the file.

Share this post


Link to post
Share on other sites

Yep  just had  the same issues  as you guys  wipe  all my ddl.xml  data  out  only  left  the gsx  ones  in,  luckly I had  made  a back up copy of   of  it  and  just a matter of  copying/pasting  again 

 

I  posted this  in the  fdst forum linking  this thread hopefully  there will be  a fix  or  why its happening

Share this post


Link to post
Share on other sites

The ASN folks have changed their encoding so that this problem no longer is an issue - see the latest SP2C beta release.

 

DJ

Share this post


Link to post
Share on other sites

Same thing happened to me yesterday except it was ORBX KBZN {Yellowstone International APT}. The popup stated that it could make a new dll.XML but it would contain ONLY the one entry.

I just saved a copy of my current dll.XML, let it write a new one, and did a copy/paste same as pete_auau.

No problem after that.

 

Btw...I ALWAYS save a fresh copy of the dll.XML file before installing anything. A shortcut on the desktop to the user\....\roaming\...\FSX folder makes it a simple task.

Share this post


Link to post
Share on other sites

mmm ok this is getting  stranger  by the hour  in my case it  was  fdst  manager  and in your  case  Neal it wasn't  very strange :unsure: it always pays  to have  a back up up in my  case  got it  one my desktop  and got  a complete back up of  my pc  on a separate   drive :P


recently updated the Addon Manager and got the same messages. I told it to go ahead and fix both dll.xml and exe.xml, and it makes a back-up of the old xml files. Afterwards, I went and looked at what Coatl did, and it manages to make the Addon Manager the only entry in the new xml files. I also compared the new ones to what was in the old ones, and there was no difference. None.

 

Where does the back up copy  gets put  trying  to find it  so can put  the originals back in?

Share this post


Link to post
Share on other sites

With FSDT, the backup gets put in the same directory as the original - C:\users\your_name\appdata\roaming\microsoft\fsx. it's called  exe.xml_Before_Addon_Manager.xml or dll.xml_Before_Addon_Manager.xml.

Share this post


Link to post
Share on other sites

The problem is not obviously caused by our installers. It was an user on our forum which reported this happening after running ASN and guess what, ASN developers FIXED IT.

 

The problem was ASN changed the actual file encoding from ANSI (as installed by default in FSX) to UTF-8, without changing the XML file header which still reported to be ANSI/Windows 1252, so it resulted  in an illegal XML file, with an header not matching the real file content. While it might be legit to change the file encoding for some reason, it's surely NOT legit doing so without also changing the header.

 

 

What the FSDT installer is doing, is checking the legality of the XML fils (using the official MS XML parser that comes with IE) files before acting on them, and informing there's a problem with the file, but it will not dare to touch it without USER permission.

 

When any pre-existing error in XML is found, the user is offered a choice between:

 

1) Creating a new file, which obviously means the newly created file will be as if FSX was just installed with no addons, except the FSDT lines.

 

OR

 

2) Abort the installation, in case you'll prefer fixing the XML manually

 

And of course, since option #1 might be dangerous, BACKUPS will be made in same folder, named either exe.xml_Before_Addon_Manager.xml or dll.xml_Before_Addon_Manager.xml

Share this post


Link to post
Share on other sites

I had this problem, downloaded Notepad++ and changed the encoding from UTF-8 format to ANSI. I deleted the XML entries created by the FSDT installer. I then re installed GSX again with no warning of a corrupt XML file.

Share this post


Link to post
Share on other sites

AFAIK, ANSI <> Windows-1252, but for this purpose ANSI encoding probably works without problem.

 

scott s.

.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this