Sign in to follow this  
maukro_1990

Windows 10: Stuttering?

Recommended Posts

Hello! 

 

I updated my system to Windows 10 and this windows is just awesome. But unfortunately i´ve got some stuttering in fsx now. Do you see the same problems on your system? I have got a high end PC System and i use Nvidia Inspector. Maybe the vsync does not work anymore? 

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Did you make sure to put your performance profile to 'High Performance', plus use 'Single display performance mode' / 'Prefer maximum performance' in Nvidia Inspector?

Share this post


Link to post
Share on other sites

Did you make sure to put your performance profile to 'High Performance', plus use 'Single display performance mode' / 'Prefer maximum performance' in Nvidia Inspector?

Yes. You can see my NI settings at my pictures below. Maybe you have better NI options for me? is something wrong with my settings? 

 

1.jpg

2.jpg

Share this post


Link to post
Share on other sites

You should completely reinstall windows to have a fresh version. Only then you will have the completely new mainboard drivers and also nvidia drivers. My wife haven't had problems updating but I had to reinstall the nvidia drivers compoletely with ccleaner as normal reinstall haven't solved the problems (also with other games).

 

Dunno how microsoft handles upgrades, but in the linux world you always have old slag after an upgrade. So especially with the drivers and installed third party dll's I think there are problems.

 

Also as the cpu timer in windows 10 is new and pretty damn good, make sure not to tweak you'r fsx.cfg (no affinity mask, and no buffer tweaks) and set fps to let's say 40fps with an tuned high end cpu @4,3Ghz or above. I'm running FSX pretty good now without any problems. OC'ed my 3770k to 4,5GHz using a Corsair hybrid cooler. With this configuration no core is at 100% giving stable 40fps. If I increase the fps limiter I get more fps but cpu core 0 is at 100% giving fps spikes.

 

Also make sure to disable vsync as long as you have <60fps :)

Share this post


Link to post
Share on other sites

You have a very high AA...Try setting to 4Xs

 

 8xs really taxes your CPU, and has nothing to do with W10.

Share this post


Link to post
Share on other sites

You have a very high AA...Try setting to 4Xs

 

 8xs really taxes your CPU, and has nothing to do with W10.

Mitch, full names are required in the PMDG forums. Add it to your signature or type it at the end of your posts. Otherwise your posts might be deleted since its against the rules in the PMDG section of the forums.

Share this post


Link to post
Share on other sites

Unfortunately i had to roll back to windows 7. And now everything is smooth like a silk. I heard that vsync of NI does not work in windows 10 at this time. Maybe this caused my problem. 

Share this post


Link to post
Share on other sites

Stuttering probably caused by Windows Defender, you have to put all the fsx/p3d exe's and dll's for addons on the exception list. - David Lee

Share this post


Link to post
Share on other sites

I've had no issue with Windows 10 but also I did not upgrade I only made a clean install. Only the Windows 10 "anniversary update" did make an upgrade but it's more the previous service pack for me than a real system upgrade.

 

Not sure about the VSYNC of NI not working either I'm using it and have no specific issues. At least no stuttering, falling FPS on high quality scenery with big addons like PMDG sure I have, but not really stutterring.

Share this post


Link to post
Share on other sites

I've been having micro stutters but.. Windows 10 is so darn stable.i wouldn't want to switch back to Windows 7.

Share this post


Link to post
Share on other sites

I don't think it has a direct correlation to Win10, association is not causation. The main reason I don't think so is because most, myself included, do not have problems with Win10.

Share this post


Link to post
Share on other sites

full install or upgrade if so need do clean and full install, fsx sensitive to windows 10 happen to me clean install solved for me good luck..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this