Sign in to follow this  
prdant

X-plane is very jerky (Windows 10 and driver issues)

Recommended Posts

All or anyone, I am at a loggerhead with x-plane and its performance. Let me clear I am not bashing x-plane I believe that it is a great sim.

My PC is Windows 10, has an Intel i5-2500 quad core 3.30GHz processor. 16Gb RAM and a Nvidia GeFoece GTX 750 w/2Gb of RAM. I would think that with this setup that I could run x-plane.

Today after many days of watch youtube, practicing using cold and dark and loading the FMS on IXEG 737 I taxied out rwy 26 at KDEN for a short flight to KLAS. Taxi out was flawless and the takeoff right on the numbers using A/T. Got into the air and cleaned up the AC, kicked on the AP and boom. Frame rate fluctuated between 10 -24 and the sim froze every 40 ft as I attempted to climb to 16500. I lowered the the rendering to low with no change.

I would welcome the wisdom of x-plane users as to what I have missed here. Thanks in advance! :smile:

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

All or anyone, I am at a loggerhead with x-plane and its performance. Let me clear I am not bashing x-plane I believe that it is a great sim.

My PC is Windows 10, has an Intel i5-2500 quad core 3.30GHz processor. 16Gb RAM and a Nvidia GeFoece GTX 750 w/2Gb of RAM. I would think that with this setup that I could run x-plane.

Today after many days of watch youtube, practicing using cold and dark and loading the FMS on IXEG 737 I taxied out rwy 26 at KDEN for a short flight to KLAS. Taxi out was flawless and the takeoff right on the numbers using A/T. Got into the air and cleaned up the AC, kicked on the AP and boom. Frame rate fluctuated between 10 -24 and the sim froze every 40 ft as I attempted to climb to 16500. I lowered the the rendering to low with no change.

I would welcome the wisdom of x-plane users as to what I have missed here. Thanks in advance! :smile:

Phil,

 

If running Windows 10, you could have the problem with the "Anniversary Update". Windows 10 introduced a performance bug to Open GL applications. If you browse a webpage or open another application while using an OpenGL application such as XPlane, your frame rates will go down to single digits and there is nothing you can do then. Try not to change focus of XPlane as the primary application when using it and it is fine. Microsoft know about this bug and hopefully they will release a patch soon.

 

Other stuff that induces stutters in Nvidia's control panel settings, go to your XPlane profile and disable "Threaded Optimisation", and you sim will be smooth as glass. Good luck!

Share this post


Link to post
Share on other sites

Thank you for that advice I will test that out right after dinner. I am putting my x-plane folder on a thumb drive right now just in case I may want to roll back from windows 10.

Share this post


Link to post
Share on other sites

Thank you Will, that one change made the difference. It is nice to have a sim community.

Share this post


Link to post
Share on other sites

Thank you Will, that one change made the difference. It is nice to have a sim community.

 

Your video card doesn't have enough memory. I am almost using 6 gigs of video ram with my rendering settings.

Share this post


Link to post
Share on other sites

Pinning this thread for a while as it is cropping up a lot.

Share this post


Link to post
Share on other sites

My system is almost exactly like yours - only have a GTX 960 instead of a 750.

 

I am running the latest Win 10 version and appart from other strange problems, not directly related to XP10, I re-installed xp10 a couple of days ago and it is running just fine.

 

I was using nvidia inspector, but I reverted to Nvidia Control Panel only and just set threaded optimization to off, single display performance, power at max performance, and FXAA to On, as per an youtube advice I tested and liked.

 

I also have Vsync set in the NI CP to the closest I was used to set through NI - vsync 1/2 adaptive - while in NI I used "Clamp", but t's just fine and I get a more or less stable 30 fps, sometimes down to 22 with heavier clouds or scenery.

  • Upvote 1

Share this post


Link to post
Share on other sites

Phil,

 

If running Windows 10, you could have the problem with the "Anniversary Update". Windows 10 introduced a performance bug to Open GL applications. If you browse a webpage or open another application while using an OpenGL application such as XPlane, your frame rates will go down to single digits and there is nothing you can do then. Try not to change focus of XPlane as the primary application when using it and it is fine. Microsoft know about this bug and hopefully they will release a patch soon.

 

Other stuff that induces stutters in Nvidia's control panel settings, go to your XPlane profile and disable "Threaded Optimisation", and you sim will be smooth as glass. Good luck!

It doesn't only cause the performance to drop to single digits it worsen the overall performance of the sim and induces stutters. I've also talked with Microsoft support and the guy didn't exactly acknowledge this as their fault because apparently, they fixed many issues with Open GL in these updates, but still said they will look into this. Considering there was an update a few days ago which didn't fix the issue I'm getting a bit worried. 

Share this post


Link to post
Share on other sites

Just another data point here to indicate it's not affecting everyone. I'm running Win 10 with latest updates and seeing no problems at all.

 

I'm getting very high frame rates (consistent 40 fps, sometimes up to 50+). Running X-Plane in a window taking up most of my 1900x1200 desktop, frequently switching back and forth to Plan-G flight planner or Chrome for web browsing.

 

My system is an i7 6700 4.0 GHz, 32 Gig RAM, GTX 970 video.

Share this post


Link to post
Share on other sites

MS don't exactly have a history of admitting their failures. Look at the Windows 8 joystick debacle.

  • Upvote 2

Share this post


Link to post
Share on other sites

Just another data point here to indicate it's not affecting everyone. I'm running Win 10 with latest updates and seeing no problems at all.

 

I'm getting very high frame rates (consistent 40 fps, sometimes up to 50+). Running X-Plane in a window taking up most of my 1900x1200 desktop, frequently switching back and forth to Plan-G flight planner or Chrome for web browsing.

 

My system is an i7 6700 4.0 GHz, 32 Gig RAM, GTX 970 video.

Do you own windows 10 pro version?

Share this post


Link to post
Share on other sites

guys try updating your NVidia drivers to the latest non-beta version.

 

I did this yesterday and seems to have solved my frame drop to 5fps.....also, check your choices in Windows and other places, as it appears the Anniversary update changes a lot of stuff to default.

Share this post


Link to post
Share on other sites

I tried disabling the GameDVR in the X-Box app.

 

Tried updating to Nvidia's 372.90.

 

Also tried the compatibility settings of X-Plane.exe to Windows 8.

 

Nothing has helped at all. This has become a show stopper for me sadly :(

Share this post


Link to post
Share on other sites

Enrique,

 

can you try to disable win 10 firewall, shut it down totally through the Security Settings interface, and see if you notice better performance ?

 

LAST MINUTE:  Enrique, just came across this excellent NOTAM by Mitch here at AVSIM...

 

http://www.avsim.com/topic/495280-notam-two-very-important-w10-tips-you-will-thank-me-for/#entry3484851

 

Check the item in it, specially the USB part.

 

Hope you get it going!

Share this post


Link to post
Share on other sites

There is no better performance. Even after 3 windows updates the issue remains. The sim drops to 1 digit fps and overall worse performance. I'm seriously thinking of switching back to win 7 considering I got no response from the X plane developers and no word from Microsoft. This has been going on for good 3 weeks now.

Share this post


Link to post
Share on other sites

Hola Jose!

 

Thanks so much for the heads up. I will try these later and post back!!!

 

cheers

-E

Share this post


Link to post
Share on other sites

There is no better performance. Even after 3 windows updates the issue remains. The sim drops to 1 digit fps and overall worse performance. I'm seriously thinking of switching back to win 7 considering I got no response from the X plane developers and no word from Microsoft. This has been going on for good 3 weeks now.

The scan showed no errors. I would also like to advise people not to temper with power management of your USB external hard drives as this can shorten its life span quite a lot.

Share this post


Link to post
Share on other sites

Apparently, this could be the fault of Nvidia drivers which would also show why only some have issues. Here's a post I found

 

"Thank you all for the reports! Microsoft is, at this point pretty certain that the problem lies in the nVidia OpenGL driver, and they are talking with nVidia to resolve. So, if you are able to reproduce this issue on a different GPU please send me a trace. Otherwise, I've got all we needed, thank you!"  https://jira.secondlife.com/browse/BUG-37795

 

 

The trace he is still requesting for NON Nvidia Gpus was spelled out in a post titled IMPORTANT further up the page from Sept 18.

 

So keep one eye on this discussion , another on the SL JIRA and a third on the Firestorm JIRAhttp://jira.phoenixviewer.com/browse/FIRE-20034

 

Share this post


Link to post
Share on other sites

did you remember to turn off threaded optimization for x-plane in the nvidia control panel? that caused alot of people to have slight pauses in sim.

Share this post


Link to post
Share on other sites

did you remember to turn off threaded optimization for x-plane in the nvidia control panel? that caused alot of people to have slight pauses in sim.

We're not talking about slight pauses here, but yea that was the first thing I did 6 months ago when I switched from P3D.

Share this post


Link to post
Share on other sites

All, I started this thread and tried some of the fixes. The system is running well now. I did find a video on youtube that addressed the best settings for x-plane and the nvidia cards. Worth a look if interested.  

Share this post


Link to post
Share on other sites

Hello, I managed to get my FPS back by uninstalling this update KB3193494.

 

Then I used the group policy editor (run->gpedit.msc->computer configuration->administrative templates->all settings->configure automatic updates->enabled->2-Notify for download & install) and modified the settings for stopping Windows from installing updates automatically.

 

This will only work in Windows 10 PRO, although I'm sure Windows 10 Home must have an option somewhere.

 

Hope this helps.

 

Cheers

-E

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this