Sign in to follow this  
tonywob

X-Plane 11 Discussions

Recommended Posts

Just a reminder that X-Plane 11.0 is now a public beta. This means it is not yet ready for regular use and should not yet be considered a replacement for X-Plane 10. Before commenting and jumping in:

 

  1. Please do not uninstall or remove X-Plane 10. You can run both simulators separately. 
  2. Remember it is a beta. Beta means it is buggy, incomplete and not meant as a replacement yet for your main sim
  3. Laminar Research have mentioned the build will have FPS issues because it hasn't yet been optimised. Don't judge the sim based purely on an early beta copy (See http://www.x-plane.com/kb/x-plane-11-00-release-notes/)
  4. XP11 is not free for XP10 users or steam users. If you purchased XP10 after XP11 was announced from Laminar Research's website, your product key will work.
  5. If you would like to try the XP11 demo and are using XP10, make sure you remove the DVD from the drive before attempting to install. If you don't, the demo installer will ask for a product key.
  6. Please don't rant about bugs, it's a beta, they are to be expected. Instead, let Laminar Research know about the bugs here http://dev.x-plane.com/support/bugreport.html. 
  7. Remember this is an early beta. You do not need to install it and shouldn't yet unless you are willing to accept problems and report them.

 

 

 

  • Upvote 2

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

One nice "feature" I just noticed is that the prices wasn't raised after this release :-)

Share this post


Link to post
Share on other sites

One nice "feature" I just noticed is that the prices wasn't raised after this release :-)

Well that's true but we have yet to see which developers who will charge an 'upgrade' price to get all your payware running in XP 11 ;-)

Share this post


Link to post
Share on other sites

WOW!!!! Just tried the demo and ... I'm C-O-M-P-L-E-T-L-Y SOLD !!!!

 

IT IS BEAUTIFUL!!!!!

  • Upvote 2

Share this post


Link to post
Share on other sites

WOW!!!! Just tried the demo and ... I'm C-O-M-P-L-E-T-L-Y SOLD !!!!

 

IT IS BEAUTIFUL!!!!!

 

Way to go! Jcomm. Good call! :wink:

 

Cheers

Share this post


Link to post
Share on other sites

WOW!!!! Just tried the demo and ... I'm C-O-M-P-L-E-T-L-Y SOLD !!!!

 

IT IS BEAUTIFUL!!!!!

 

*Uninstalls within a month*  :dance:

  • Upvote 12

Share this post


Link to post
Share on other sites

Eheheh - no!  Will buy it today!  And keep it until.... I uninstall it !  Promissed!

 

Jokes appart, I really like the demo, it runs acceptably on my rig, with only drop in fps due to the clouds density which I used to place at not more than 20% in XP10 and now can't have control over, but playing with the remaining settings provides acceptable values.

 

Like everything about it, starting with the new interface.

 

Guy's those of you complaining about the left bank tendency, made me think Austin had used an old version of the FDM, pre troque fix, and just as Itook the C90, and then the C172 for my first ride in XP11, I experienced exactly the same exhagerated left bank, until I looked at the yoke while seating at the rw threshold and noticed it was tilted left... I callibrated my T16000 which I am using for rol and pitch and Voilá!  It is just as good as in XP10 post torque fix :-)

Share this post


Link to post
Share on other sites

Unimpressed. The first load couldn't identify or calibrate any of my devices (those obscure CH products - the yoke, throttle and pedals) and my second load has me calibrating everything manually, starting a flight and applying full throttle. Engines spool up, plane doesn't move (I guess the parking brake is set somewhere, but not obviously so).

 

Need to work on that OOBE, I think. :(

Share this post


Link to post
Share on other sites

Has anyone been able to get their Saitek yoke and throttle quadrant to work. XP11 sees them and calibrates them but they don't control anything. The buttons worked as assigned and my rudder pedals work fine. BTW, this is in the demo.

Share this post


Link to post
Share on other sites

This is pretty savvy of Laminar Research. When the final version is released for sale, no one will be able to say "How did that bug get by the beta testers?" as we all have the chance to be a beta tester! LOL  :Big Grin:  

Ted

Share this post


Link to post
Share on other sites

Has anyone been able to get their Saitek yoke and throttle quadrant to work. XP11 sees them and calibrates them but they don't control anything. The buttons worked as assigned and my rudder pedals work fine. BTW, this is in the demo.

 

You're not the only one. XP11 sees my Thrustmaster Warthog joystick, throttles, and Saitek pedals (with pretty pictures, no less) and calibrates them. Then nothing works when the sim launches. If I enable the Data Output for control input it shows nothing when I move the stick and pedals. At least your pedals work, mine don't. These controls work fine in v10.

 

Send a bug report (I did) from the Laminar web site, and maybe we'll get a fix soon.

Share this post


Link to post
Share on other sites

You're not the only one. XP11 sees my Thrustmaster Warthog joystick, throttles, and Saitek pedals (with pretty pictures, no less) and calibrates them. Then nothing works when the sim launches. If I enable the Data Output for control input it shows nothing when I move the stick and pedals. At least your pedals work, mine don't. These controls work fine in v10.

 

Send a bug report (I did) from the Laminar web site, and maybe we'll get a fix soon.

Thanks for the reply. Ok, I'm not crazy.

Share this post


Link to post
Share on other sites

Thanks for the reply. Ok, I'm not crazy.

 

I figured out how to fix it.

 

X-Plane 11 Beta is being very aggressive about assigning pitch and roll to the first USB controller it finds, and it was assigning it to my rudder pedals. Then it was also assigning pitch and roll to my joystick, causing a conflict. I didn't notice it because I think it changed the settings back after I left the menus.

 

On top of that, any setting I tried to save as default for those controllers was causing the program to hang, if I did it in Settings from the main menu. I was able to get everything to stick in the right place by setting joystick axis assignments inside the plane. Telling it to save any of the settings as a default for those controllers still causes a hang. Double check what every axis is set to, and do it from inside the plane, not the main menu Settings menu.

 

Laminar can avoid this if they just don't have the program aggressively grab USB analog inputs and assign pitch, roll, and yaw to just anything it finds, before the user has a chance to do it in the controller setup menus.

  • Upvote 1

Share this post


Link to post
Share on other sites

Unimpressed. The first load couldn't identify or calibrate any of my devices (those obscure CH products - the yoke, throttle and pedals) and my second load has me calibrating everything manually, starting a flight and applying full throttle. Engines spool up, plane doesn't move (I guess the parking brake is set somewhere, but not obviously so).

 

Need to work on that OOBE, I think. :sad:

 

Yeah, we need a blinking red line that says "parking brake" like in FSX. That is way more realistic! :wink:

 

There is usually a knob or lever that sets the parking brake, and sometimes (B737-800) even a big red light coming on, too. The real pilots don´t get more warning than that, either (and I think every GA pilot has seen someone trying to taxi while the brake was still set :smile: ).

 

Cheers, Jan

This is pretty savvy of Laminar Research. When the final version is released for sale, no one will be able to say "How did that bug get by the beta testers?" as we all have the chance to be a beta tester! LOL  :Big Grin:  

Ted

 

Correct - and they have been doing it like this for years. Even the intermediate updates follow that pattern: Beta1,2,3....RC1,2,3... until they are satisfied and declare something "final".

 

Make sure you give good bug reports here:

 

http://dev.x-plane.com/support/bugreport.html

 

Don´t assume that "someone else must have reported it" or "they certainly read this forum, I will just post it here". While Ben Supnik (lead designer) IS currently reading here, too - they haven´t for years and will likely disappear again when the initial release dust has settled. The bug reporter is THE way to get in contact and provide feedback.

 

Jan

  • Upvote 4

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this