MadDog

[Resolved] Running Prepar3D at 30 HZ Automatically

Recommended Posts

So I think most of us agree that running with V-sync/triple buffering enabled at a 30 Hz refresh rate is the best way to experience smooth frames with no stutters or long frames in Prepar3D (unless you have G-sync monitor).  Personally, I've found that this method gives even better results than the old 1/2 Vertical Sync trick that was unique to FSX.  If you have a monitor that supports a 30 Hz refresh rate and a Nvidia Card, enabling a 30 Hz refresh is simple:

  • Right-click the desktop and select the NVIDIA Control Panel.
  • Click on "Change resolution" (under the 'Display' heading in the left navigation window) and then select 30 Hz in the dropdown list under "Refresh rate:" (on the right panel).
  • Click 'Apply' and click 'Yes' to confirm.
  • Start up Prepar3D, make sure Vertical Sync and Triple buffering are enabled and enjoy the silky smooth performance.

If you don't have a monitor that supports 30 Hz, I recommend getting one.  If you're using an AMD graphics card, I'm sure the process is similar; but I've never owned one, so I don't know the exact method.

But we're not done!  While enabling 30 Hz is simple, it is a bit clunky to have to change your refresh rate every time you want to use P3D (and then change it back when you're done).  It's especially a hassle if you forget to manually change it before loading the program and not realizing it until after the stutters start appearing.  To automate this process every time you start P3D, follow these steps:

  • Go to http://12noon.com/ , click on Display Changer II under 'Products' and download the app for your particular version of Windows.  The app is very small and completely FREE!
  • Unzip the files into a convenient folder (I will use the path D:\DisplayChanger in my examples - replace it with your custom path as necessary)
  • Important.  Make sure that your preferred P3D resolution is currently active on the desktop and the refresh rate is set at 30 Hz (as explained above).
  • Open a Command Prompt and navigate to the Display Changer folder.  (In my case, I type D: -ENTER-, cd DisplayChanger -ENTER-).
  • Type the following command:  dc2.exe -create="P3D30HZ.xml" .  This creates a config file that records your current graphic settings.
  • Close the command prompt and restore your desktop back to normal (60 Hz in my case).
  • Now right click on your Prepar3D shortcut (or create a new shortcut) and select Properties.  In the Shortcut tab, type the following into the "Target:" field:

                 "D:\DisplayChanger\dc2.exe" -configure="D:\DisplayChanger\P3D30HZ.xml" "C:\P3D\Prepar3D.exe"

         Please make sure to replace D:\DisplayChanger and C:\P3D with your own personal paths as necessary!

  • Click 'OK' and you're done.  The next time you use the shortcut, the display will automatically change to 30Hz and Prepar3D will start.  When you close Prepar3D, the display will revert back to its original settings.

I know this process is a little complicated, so I hope I've explained it clearly.  Just remember, you only have to do it once to enjoy automatic refresh rate switching forever !

Edited by Poppet
[Resolved]
  • Upvote 7

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

And what settings do you set in P3D? Do you leave at unlimited?!

Share this post


Link to post

On my setup, I also

9 minutes ago, stripealipe said:

And what settings do you set in P3D? Do you leave at unlimited?!

I limit my frames to 30 in P3D... but unlimited will also work.  30 just seems to be a 'tiny' bit smoother in my case... ymmv.  Either way, Vsync will limit max frames to 30.

Share this post


Link to post
31 minutes ago, MadDog said:

So I think most of us agree that running with V-sync/triple buffering enabled at a 30 Hz refresh rate is the best way to experience smooth frames with no stutters or long frames in Prepar3D (unless you have G-sync monitor).  Personally, I've found that this method gives even better results than the old 1/2 Vertical Sync trick that was unique to FSX.  If you have a monitor that supports a 30 Hz refresh rate and a Nvidia Card, enabling a 30 Hz refresh is simple:

  • Right-click the desktop and select the NVIDIA Control Panel.
  • Click on "Change resolution" (under the 'Display' heading in the left navigation window) and then select 30 Hz in the dropdown list under "Refresh rate:" (on the right panel).
  • Click 'Apply' and click 'Yes' to confirm.
  • Start up Prepar3D, make sure Vertical Sync and Triple buffering are enabled and enjoy the silky smooth performance.

If you don't have a monitor that supports 30 Hz, I recommend getting one.  If you're using an AMD graphics card, I'm sure the process is similar; but I've never owned one, so I don't know the exact method.

But we're not done!  While enabling 30 Hz is simple, it is a bit clunky to have to change your refresh rate every time you want to use P3D (and then change it back when you're done).  It's especially a hassle if you forget to manually change it before loading the program and not realizing it until after the stutters start appearing.  To automate this process every time you start P3D, follow these steps:

  • Go to http://12noon.com/ , click on Display Changer II under 'Products' and download the app for your particular version of Windows.  The app is very small and completely FREE!
  • Unzip the files into a convenient folder (I will use the path D:\DisplayChanger in my examples - replace it with your custom path as necessary)
  • Important.  Make sure that your preferred P3D resolution is currently active on the desktop and the refresh rate is set at 30 Hz (as explained above).
  • Open a Command Prompt and navigate to the Display Changer folder.  (In my case, I type D: -ENTER-, cd DisplayChanger -ENTER-).
  • Type the following command:  dc2.exe -create="P3D30HZ.xml" .  This creates a config file that records your current graphic settings.
  • Close the command prompt and restore your desktop back to normal (60 Hz in my case).
  • Now right click on your Prepar3D shortcut (or create a new shortcut) and select Properties.  In the Shortcut tab, type the following into the "Target:" field:

                 "D:\DisplayChanger\dc2.exe" -configure="D:\DisplayChanger\P3D30HZ.xml" "C:\P3D\Prepar3D.exe"

         Please make sure to replace D:\DisplayChanger and C:\P3D with your own personal paths as necessary!

  • Click 'OK' and you're done.  The next time you use the shortcut, the display will automatically change to 30Hz and Prepar3D will start.  When you close Prepar3D, the display will revert back to its original settings.

I know this process is a little complicated, so I hope I've explained it clearly.  Just remember, you only have to do it once to enjoy automatic refresh rate switching forever !

Wow! Thanks for this!

Share this post


Link to post

Great idea, seems to work for me. 

Share this post


Link to post

Awesome post Maddog. Thank you.

I have been a long time 30Hz user and always changed the refresh rate manually. Great to see it can be automated.

Share this post


Link to post
3 hours ago, stripealipe said:

And what settings do you set in P3D? Do you leave at unlimited?!

As MadDog said this is very much a YMMV setting. After reading many posts on this subject it appears people get different results from either setting.

Mine is a touch smoother on unlimited. You should set up a test scenario over some difficult scenery and re-fly it a few times on both settings to see which gives the best result. Once decided this is a setting you won't have to touch again.

Share this post


Link to post

Spot on MadDog

It's undeniable on my system.

I have a 60hz 4k TV with a GTX 1080. I was pretty happy with my performance at 60hz with vsync, then I tried the 30hz and it's never been so fluid.

One important thing (at least on my system) is that, if I set the frame limiter to 30 I get stutters. If I keep the limiter to unlimited, Its the smoothest I've ever experienced.

Share this post


Link to post

I agree 30Hz is great I happen to run a native 30 Hz 40 inch monitor (see my sig below) and couldn't be more satisfied. It worked well with P3Dv3 and even better now. I do notice with my setup if I don't run unlimited I get poorer performance. I find running unlimited and letting Vsync cap to my native monitor frequency of 30 Hz works best with triple buffering.

Good times!

Joe

Share this post


Link to post

Perhaps someone can enlighten me here. 

I thought more Hz is preferable for the eyes? Going below 60 which is still a far cry below the 120 you'll get on a TV seems counterproductive to me.

Share this post


Link to post
On 6/2/2017 at 4:41 PM, Farlis said:

Perhaps someone can enlighten me here. 

I thought more Hz is preferable for the eyes? Going below 60 which is still a far cry below the 120 you'll get on a TV seems counterproductive to me.

You'll hear many opinions but most will agree 30 Hz is of no issue, many run as low as 20 Hz but some people have issues with that. I believe movie theaters run at 24 Hz but it's not quite apples to apples. Bottom line I seriously doubt you would ever notice the difference but if you can maintain a steady 30 fps then you can sync using vsync to a 30 Hz refresh rate (assuming you have a monitor or tv that has a 30 Hz refresh capability) for a very smooth experience and not have to waist processing power on frames that don't get used.

 

Joe

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now