Seat*

How install Aerosoft Twin Otter with xml system

Recommended Posts

Hi
I want to install Aerosoft Twin Otter with the .xml system. I´m using Lorby Addon Organizer. Now I need som advise.
There are five folders in the Twinn installation. Three of these, effects, fonts and simobjects, are quite clear what category it belongs to in teh add component. But there are two more folders. One called Aerosoft with a subfolder with the aircraft.xml. What category belongs that to?
In the Ecosystem one of two subfolders is called Aerosoft with two folders. Flightrecorder with AS-Flightrecorder.dll and AS-FlightRecorderMangare.exe. Should these two files go in a category for each. One for dll and one for exe?

The other subfolder called Twin Otter Extended have one Aerosoft.TwinOtterX.Fuelplanner.exe file and two subfolder with most textfiles. How handle that in Addon Organizer? 

Could I have som advise please

 

/Thomas

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

3 hours ago, Seat* said:

I want to install Aerosoft Twin Otter with the .xml system. I´m using Lorby Addon Organizer

Are you aware that the Twin Otter has a P3D4 installer?

  • Upvote 1

Share this post


Link to post

Your right it has a P3D installer, and it does just that, installs it right into the P3D folder system. OP wants to put it outside of the main folder.

Share this post


Link to post

Hi Thomas,
first I dont have the Twin Otter. But i use the xml system.
I would let the folder and subfolder system as it is and place them outsim the sim. Then i would create the xml file with fonts, simobjects and effects as you describe. For the other files like aircraft.xml and so on i would do nothing. It can be that those files are for internal work with the twin otter and are independet from P3D. XML-file is not necessary for that kind of work. Important is that you do not touch the folder system of the twin otter.
I would try this.

Mike

Share this post


Link to post

Just had another go at installing the Twin Otter into the add-ons doc's folder.

set up files

Aerosoft

Effects

Fonts

Gauges

SimObjects

Sound

Ran the installer and browsed to the Prepar3D v4 folder.

it created a folder Ecosystem'

it didn't add to the 'Aerosoft' .. 'Gauges'.. 'Sound' folders.

I added the 'addon-on.xml' file

started up Prepar3d. got a pop-up to except the addon 'Aerosoft'

selected the Twin Otter airplane and continued.  then got a crash to desktop

Problem Event name... BEX' 64

Fault Module name... vertbase.dll  .. correction that should be ucrtbase.dll

any ideas

bob

 

edit ..it put the fuel planner in a sub folder of the 'Ecosystem' folder

 

 

 

 

Share this post


Link to post

Ok. Ihave tried to create, with Addon Manager, an Xml file with only fonts, effects and simobject. I did leave the Aerosoft and Ecosystem folder out. That did not work. P3DV4 started and the sceneario page came up. The Twin Otter was there but when the sim try to load it crached. I think I must get the aircraft.xml to be raed in any why but I don´t know how.

/Thomas 

Share this post


Link to post

Hi Thomas,

if it not works the only way is to install the twin otter like it is. After that you must discover how the installer change the core p3d. Then you can outsource the twin otter.
This is the only advice I can think of. Sorry for my bad english skills.

 

Mike

Share this post


Link to post

FYI, the .xml files for the P3D v4 version are in your Documents folder, but in a separate Aerosoft folder instead of inside the usual Prepar3D v4 Add-ons folder.

Share this post


Link to post
12 hours ago, Seat* said:

P3DV4 started and the sceneario page came up. The Twin Otter was there but when the sim try to load it crached.

I had the same problem. It seems the issue is the Twin Otter's sound system, which expects to find its sound files in the default install location inside the P3D folder. I solved it by editing the asc.cfg file for each of the Twin Otter variants, and changing the "wavdir" setting so it uses my addon folder structure outside the P3D folder 

For example:

In the file Aerosoft_DHC6_300_WHEEL\Panel\asc.cfg you will find a [General] section right at the top, containing the line "wavdir=..\SimObjects\Airplanes\Aerosoft_DHC6_300_WHEEL\Sound\ASC_Twotter" - I think. I can't remember the exact original value, because I changed it a while ago. But it starts with "wavdir=..\" which is the problem, because it is a relative path and it only points in the right relative direction if everything is located where the Aerosoft installer puts everything.

You need to change the "wavdir" value so it contains the new install location, with the drive and the full path to the "Aerosoft_DHC6_300_WHEEL\Sound\ASC_Twotter" folder. For example, my install location for addon aircraft is "F:\Prepar3D Addons\Airplanes" and in there I put the Twin Otter in a folder called "Aerosoft Twin Otter", so my "wavdir" value is "wavdir=F:\Prepar3D Addons\Airplanes\Aerosoft Twin Otter\SimObjects\Airplanes\Aerosoft_DHC6_300_WHEEL\Sound\ASC_Twotter"

You need to do the same and insert the same "wavdir" value in all of the asc.cfg files for the other Twin Otter variants. They all use the same path to "Aerosoft_DHC6_300_WHEEL\Sound\ASC_Twotter" because that's where the shared sound files for all variants are located.

That solved the crash on load for me.

Share this post


Link to post

Oh yeah and another thing, I remember having some problems with gauges in a few of the variants than the Aerosoft_DHC6_300_WHEEL. Again because the panel.cfg files for other variants contain relative paths to the gauges for the 300_wheel variant, for example  "../SimObjects/Airplanes/Aerosoft_DHC6_300_WHEEL/Panel" in the Aerosoft_DHC6_300_SKIWHEEL\Panel\panel.cfg file.

The gauges are located in four subolders in "Aerosoft_DHC6_300_WHEEL/Panel", and the simplest solution for me was to just make symlinks to those four folders from the Panel folders for the other variants that use the same gauges, and then do a search and replace in the panel.cfg file for each variant, where I simply replaced each occurrence of "../SimObjects/Airplanes/Aerosoft_DHC6_300_WHEEL/Panel/" with a blank string (eg. changing "gauge00=../SimObjects/Airplanes/Aerosoft_DHC6_300_WHEEL/Panel/TW_system!TW_Sys1, 0, 0, 1, 1" to just "gauge00=TW_system!TW_Sys1, 0, 0, 1, 1" and so on.

I don't know if there's a better solution, but that was the first thing I tried and that just worked for me, so I left it at that.

Share this post


Link to post

I have tried different solutions from both Mike and JacquesBrel buth I can´t get it to work. Thank you both of you. I have asked over att Arerosft forum and got the following answer from Mathijis Kok

" our installer does not support that as we have seen several issues with that. Lockheed is aware and we expect those to be sorted out soon"

For the moment I would have to accept that.

 

/Thomas

Share this post


Link to post

I'm having another issue and this airplane and it is with the font in the radios.  It (quartz) has to be re-installed every day and sometimes that doesn't work.  They just say on the forum that it is a Windows 10 issue.  But, it doesn't happen to any other aircraft.  Anyone else running into that issue?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now