Jump to content

Sign in to follow this  
Gabe777

Why is Active Sky Such a Hit on Framerates ????? - SOLVED !!

Recommended Posts

Posted (edited)

 

EDIT - Now Solved - see bottom post

 

Unless I all but take off ALL Anti Aliasing, my FPS drops to 10 or 15 FPS from 200  (!!!) ..... when in or going towards cloud.

I have an i7 7700 and a 1080 GTX. No slouch.

Pan away from the cloud - 200 fps in the Twotter….. pan towards he cloud or in the VC - less than 25 fps.....

I have cloud textures at lowest possible size and only 3 layers.

 

This program is a joke, and you need to start from scratch.

 

Simply unusable..... I hate to think what it's like with all the settings jazzed up.

 

Immediate uninstall for me.

Edited by Gabe777

Share this post


Link to post

Works just fine here.  What are you using for cloud textures?

Greg


i7-8086K @ 5.4GHz, ASUS Maximus XI Hero, MSI GTX 1080 Gaming X driving a 27" 2K LCD, G.Skill 16GB 3600 Trident Z 15-15-15, Samsung 512GB 970 Pro NVMe (OS and P3D) and Sabrent 1TB Rocket NVMe, Malware 10 Pro 64.  P3Dv4.5

Share this post


Link to post
Posted (edited)

Immediate uninstall for me.

Have at it...

Edited by newtie
sp

Share this post


Link to post

Have you contacted AS tech support? You are in a minority, many have no problem with performance. It is one of the best selling add-ons and if there were issues as you portray, it wouldn't be.


Gigabyte Z97X-UD5H-BK, Blk Ed MB; Intel I7-4790K CPU (@4.5 Ghz); 16 Gb G.Skill RAM (F3-2400); Win7 Pro; 2 Samsung 1Tb SSDs;Toshiba 3Tb hard drive; Gigabyte Aorus Extreme 1080ti 11Gb VRAM; Toshiba 43" LED TV @ 4k; P3D v4.5 HF2

 

Share this post


Link to post

I've got a very modest i7700 / GTX 1070 system and AS hardly makes a dent in my FPS. Might want to broaden your investigation a little before you delete. Just my 2c...

Brian

 

  • Upvote 1

Share this post


Link to post

I used to get very poor frame rates with active sky and Rex force. I have an I7-7700K with GTX1070 and over Europe with Overcast conditions my system will grind to a halt.

1. I noticed if i tun down texture filtering all the way down to 2X or Trilinear it help a bit.

2. maybe also linked to option 1 above was my cloud textures where usually at 4096 HD. so i now use 512 or 1024 and it seems to help alot.

3. i reset all the mods i made on Nvidia Inspector.

4. i recently turn HT off as suggested by another forum and my system runs very well.

 

The only thing am battling with is slow loading of autogen at the destination airport. but i dont get any more low FPS in overcast conditions near EHAM or anywhere else. my current settings are

fxaa=off

AA=4XSSAA

Texture filtering= 8x

texture res = ultra 4096 [ cloud resolution 512 or 1024 from rexSF]

cloud draw distance = 80

cloud layers on Active sky= 5

all locked and smooth at 30FPS.

  • Upvote 1

Onela Pivra

ATPL (A/H) CFII (A/H)

Share this post


Link to post
1 hour ago, Gabe777 said:

Unless I all but take off ALL Anti Aliasing, my FPS drops to 10 or 15 FPS from 200  (!!!) ..... when in or going towards cloud.

I have an i7 7700 and a 1080 GTX. No slouch.

Pan away from the cloud - 200 fps in the Twotter….. pan towards he cloud or in the VC - less than 25 fps.....

I have cloud textures at lowest possible size and only 3 layers.

 

This program is a joke, and you need to start from scratch.

 

Simply unusable..... I hate to think what it's like with all the settings jazzed up.

 

Immediate uninstall for me.

In the mechanical world we call this operator error.

  • Like 1

Matt Wilson

Share this post


Link to post

Guys - I have minimum ASCA settings 256k / but if overcast conditions prevail, it is literally reducing my FPS to 20 to 25 from as high as 200.

 

Just sat in PMDG VC and getting 60 fps smooth - with cirrus and stratus layer x2. Add in Cumulous and load an overcast weather condition scenario, and drops to 20.

 

Even reducing AA to 2xMSAA makes little effect - about 10% better, tops.

 

Even the Twotter at 200 fps, drops to 20.

 

Don't get it.

 

Perfect if I don't use Cumulous or skies are quite clear. Beautiful skies at dawn and dusk, but using real weather is just a non starter.

Share this post


Link to post
2 minutes ago, mpw8679 said:

In the mechanical world we call this operator error.

Yes well, I'm guessing your one of the 23 fps people - Locked !!!

 

Whatevs.

Share this post


Link to post
1 minute ago, Gabe777 said:

Guys - I have minimum ASCA settings 256k / but if overcast conditions prevail, it is literally reducing my FPS to 20 to 25 from as high as 200.

 

Just sat in PMDG VC and getting 60 fps smooth - with cirrus and stratus layer x2. Add in Cumulous and load an overcast weather condition scenario, and drops to 20.

 

Even reducing AA to 2xMSAA makes little effect - about 10% better, tops.

 

Even the Twotter at 200 fps, drops to 20.

 

Don't get it.

 

Perfect if I don't use Cumulous or skies are quite clear. Beautiful skies at dawn and dusk, but using real weather is just a non starter.

What is your GPU usage % when u have the frame rate issues?


Matt Wilson

Share this post


Link to post
Just now, Gabe777 said:

Yes well, I'm guessing your one of the 23 fps people - Locked !!!

 

Whatevs.

30 FPS


Matt Wilson

Share this post


Link to post

I can also confirm no real issues with it on my end, And I have a SLOOOOWWWW computer.

Im as far as you can get to understanding any coding etc that goes into making these programs but have you tried an uninstall re-install perhaps?


Gerry
Prepar3D V4 - PMDG 747/400- PMDG 737 - Majestic Dash 8 - Activesky 16 - ASCA - ORBX FTX Global base pack - ORBX NA LC - ORBX HD Trees - Precipitfx - Chaseplane - Carenado PC-12, QW 787, FT(CYYZ, KBOS, CYUL), FB (KIAD,KPDX,KSFO), FSDT (CYVR)

System: Intel I7 7700 / 12 GB Ram / Windows 10 - 64 bit / NVIDIA GeForce GTX 1060 6GB / 32" Acer Monitor

 

Share this post


Link to post

I had issues similar to yours and my fix was to reduce the cloud draw distance in AS to about 90 miles for some reason it was set to 180 miles and when ever I got into heavy stuff it would slow to a crawl.  Josh

Share this post


Link to post
12 minutes ago, Gabe777 said:

Even switching off AA completely is not affecting it.

Well maybe that's a sign of the problem being elsewhere? Obviously adding clouds and cloud layers is going to hit performance but it shouldn't be as bad as you describe. I run with REX cloud textures (conservative ones, so I think 1024 for the low-level clouds and 512 for the cirrus).  Oh yes, and I have the Soft Clouds textures for low-level clouds. I have a target of 40fps and my performance is generally okay, which broadly speaking means varying between 20 and 40fps according to the weather specifics. That's with a three-screen viewgroup display on a GTX1070, flying the Twin Otter with an out-the-window view only. And I didn't do anything special to get that.

I don't know how ASCA works, but i my setup I can save the situation and then load up the same weather without AS running. If you can do this and the performance is better it might suggest AS is doing a whole bunch of something else behind the scenes.


MarkH

gGzCVFp.jpg
Core i7-7700K / 32Gb DDR4 / Gigabyte GTX1070 / 1080p x 3 x weird / Win7 64 Pro

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
×
×
  • Create New...