Jump to content

Archived

This topic is now archived and is closed to further replies.

spokes2112

FSUIPC TO STOP WORKING TODAY!

Recommended Posts

Interesting...

 

So, everyone needs to reinstall FSUIPC?

 

It seems so.. 

 

 

Coolio - it was put on the front "news" page. Hate to see a bunch of simmers try to fly tomorrow wondering what was going on. :-) 

Share this post


Link to post
Share on other sites

Thanks for posting this , FSUIPC is the linch pin of many installations and included in a fair number of Payware Aircraft , errors will be widespread and having this information on the Front Page the best means of forwarning Avsims Members with the least possible delay.

 

Best Regards C Jodry

Managing Editor Avsim

Share this post


Link to post
Share on other sites

I just went to Peter Dawson's page and I see only v4.88 posted on April 29th. Where to find v4.9?

 

*******************************************************************************************************

EDIT:

Please disregard the above. After downloading the version shown as 4.88, the documentation shows that it is actually 4.9.

Share this post


Link to post
Share on other sites

I just went to Peter Dawson's page and I see only v4.88 posted on April 29th. Where to find v4.9?

Just downloaded and installed. The new DLL for FSX is 4.90 dated 5/5/2013. Evidently the description on the page hasn't changed yet.

Share this post


Link to post
Share on other sites

So how do we know if our computer has been infected with this malicious software (in the form of Java updates). Also, any idea of what the symptoms would be on our machines?

Share this post


Link to post
Share on other sites

Also, SimMarket is sending out emails with the update info and DropBox download links to the 4.90 and 3.999z2 packages. This update will get into the hands of all registered FSUIPC users quite quickly.



So how do we know if our computer has been infected with this malicious software (in the form of Java updates). Also, any idea of what the symptoms would be on our machines?

 

Just to be clear: FSUIPC isn't infecting anyone's machine.

 

Apparently some third party (hacker) has stolen the GlobalSign Code Keys identifying FSUIPC as safe software and is using those keys on other, non-safe software advertising itself as Java updates.

 

To ensure your own machine is clean and safe, use your standard anti-virus and/or anti-malware program and scan regularly with updated definition files.

Share this post


Link to post
Share on other sites

 

 


Also, SimMarket is sending out emails with the update info and DropBox download links to the 4.90 and 3.999z2 packages.

 

Just got the e-mail.. Truly a "class act" on simMarket's side for doing that. Dropbox and simMarket's bandwidth usage is going to quadruple today LOL -JK

 

Roman  

Share this post


Link to post
Share on other sites

I had an email from Simmarket when I got home from the footie today.  All things considered, I think Pete Dawson, as always, has provided the best possible service under the circumstances.  Thanks Pete if you are reading this.  Much appreciated. :Applause:

Share this post


Link to post
Share on other sites

Just to be clear: FSUIPC isn't infecting anyone's machine.

 

 

 

Apparently some third party (hacker) has stolen the GlobalSign Code Keys identifying FSUIPC as safe software and is using those keys on other, non-safe software advertising itself as Java updates.

 

 

 

To ensure your own machine is clean and safe, use your standard anti-virus and/or anti-malware program and scan regularly with updated definition files.

Thanks for clarifying this.

Share this post


Link to post
Share on other sites

Oh man, I am 2 hours into a 10 hour flight...  I hope the cutover is at midnight so I can get this last flight in... (So selfish) :)  Will it just stop working mid-flight?  Need to D/L the updates now.

Share this post


Link to post
Share on other sites

Oh man, I am 2 hours into a 10 hour flight...  I hope the cutover is at midnight so I can get this last flight in... (So selfish) :)  Will it just stop working mid-flight?  Need to D/L the updates now.

I just quit a 7 hour flight to download, just in-case it isn't downloadable later one.

Share this post


Link to post
Share on other sites

I just quit a 7 hour flight to download, just in-case it isn't downloadable later one.

 

 

Your flight will be fine. :) 

 

It is only when you restart the sim that the license will become invalid.

Thank you very much guys, I am passing Moncton now just consulted my co-pilot (me in the bathroom mirror) and we are going to continue based on Graham's feedback...  :Praying:  :Nail Biting:

Share this post


Link to post
Share on other sites

When it becomes invalid depends on exactly when GlobalSign invalidate the certificate and when your PC updates its certificate lists - it may be hours, it may be days - no-one exactly knows. What will happen when it does though is that existing copies of FSUIPC will only be capable of logging, nothing else, according to Pete, so it's definitely worth updating before it happens.

 

Cheers,

 

Ian P.

Share this post


Link to post
Share on other sites

Can I use my old FSUIPC.DLL after re registering?

 

The new fsuipc.DLL does not work for me..I can't load fsx

Share this post


Link to post
Share on other sites

This may be a really dumb question, but does this only affect registered copies of FSUIPC ?

Share this post


Link to post
Share on other sites

This could only be the tip of the iceberg! How many other developers addons use this service, and are they affected/vulnerable  too?

Share this post


Link to post
Share on other sites

Will they be affected: Yes. They should (but probably won't) update their installers. They all use the same dll files, though, so if you install the new versions using the 3.999z2 or 4.90 installers, you have fixed the problem for everything at the same time.

 

When you use an FSUIPC installer, that checks and will only overwrite the dll if the installed version is older than the one being installed - for instance, if you install 4.90 today and then install the Blackbox Airbus Prologue packs, the version of FSUIPC in the current versions of the BBS packs are older, so will not overwrite 4.90. If the package just copies the dll file in, however (which they shouldn't!) then that could be an issue. That's always been the case, though, unfortunately.

 

Cheers,

 

ian P.

Share this post


Link to post
Share on other sites

 

 


Will they be affected: Yes. They should (but probably won't) update their installers. They all use the same dll files, though, so if you install the new versions using the 3.999z2 or 4.90 installers, you have fixed the problem for everything at the same time.

 

I'm not talking about FSUIPC, I'm talking about other developers that use the same signing service for their own applications and DLL's.

Share this post


Link to post
Share on other sites

What's the proper way to reinstall? Just install the new one over top of old? Uninstall and reinstall? How do I backup all my settings and profiles?

Share this post


Link to post
Share on other sites

×
×
  • Create New...