Sign in to follow this  
Rob Ainscough

Ultimate Traffic 2 in P3D V2.3 ?

Recommended Posts

As far as I know there are no AI Traffic products that "officially" support P3D V2.x ... I think I have all the FSX AI Traffic products, but I thought I'd try to get UT2 working in P3D V2.3 (it's the last missing link).  I realize UT2 is EOL with no future development and does NOT support P3D V2.x, but I like some of the aspects of this AI Traffic product so I'm working thru trying to make it work in P3D V2.3.

 

I don't use EMT ... nothing against EMT - it's a great tool and has helped many get compatibility with various FSX only products -- it's just a matter of I need to know exactly how to get products to work in P3D V2.x (for obvious reasons) and EMT masks that from me (understandable as it's purpose is to make life easier for end users).

 

So far I've had success doing this manually (I see the UT2 aircraft, flight plans seems to work but I need to confirm) but there are some lingering issues.  

 

The process so far:

 

1.  Copy Prepar3d.exe and rename to FSX.exe
 
2.  Add registry key for FSX location that points to P3D - HKEY_CURRENT_USER\Software\Microsoft\Microsoft Games\Flight Simulator\10.0 – value = V:\Lockheed Martin\Prepar3d v2
 
3.  Edit the Prepar3D.cfg and add under:
        [Main]
        SimObjectPaths.9=SimObjects\UT2 Aircraft
 
4.  Edit the EXE.XML and add:
 
  <!-- Unlimited Traffic 2 -->
  <Launch.Addon>
     <Disabled>False</Disabled>
     <ManualLoad>False</ManualLoad>
     <Name>UT2</Name>
     <Path>V:\Lockheed Martin\Prepar3D v2\Flight One Software\Ultimate Traffic 2\UT2Services.exe</Path>
     <NewConsole>True</NewConsole>
  </Launch.Addon>
 

I've researched what others have done to get this to work, but this comment didn't make much sense to me:

 

 

...must also change the dll.xml to point to P3D versions of traffictoolbox.dll and visualfxtool.dll (leave object_placement.dll pointing to fsx version)...

 

DLL.XML doesn't typically reference DLLs that are part of the product (P3D) ... is it suggesting I add something like this to my DLL.XML?

 

<Launch.Addon>
<Name>Traffic ToolBox</Name>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Path>V:\Lockheed Martin\Prepar3D v2\TrafficToolbox.dll</Path>
</Launch.Addon>
 
<Launch.Addon>
<Name>Visual FX Tool</Name>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Path>V:\Lockheed Martin\Prepar3D v2\Visualfxtool.dll</Path>
</Launch.Addon>
 

Is this correct?

 

Here are the errors I get when I start Ultimate Traffic 2 stand alone app:

 

619e608ad217a5f58152bcfb480a5af1.jpg

 

c4320b68a90347143b669e0e32dfaa66.jpg

 

And when I go to Database Management this is all I see GA ... I assume I should be seeing more than this?

 

972f8dfb1aeeadd26a5fda040c1d6e2c.jpg

 

Since I know folks have got this working in P3D V2.x, thought I'd ask.

 

Cheers, Rob.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi Rob,

 

I have UT2 running under P3D2.2. I installed it using the EMT, I think there was a little editing required afterwards for the exe.xml entry as given above, but that was it. I don't have any UT2 related dll.xml entry. Maybe I am missing something, but the basic functions I use (including in-game settings for fps limiting etc.) are working fine. 

 

Kind regards, Michael

Share this post


Link to post

Sorry no. MyTraffic Pro 5.4 runs fine with P3d 2.3 so I haven't bothered to look at trying any of other AI traffic add ons. Installation of MyT is a bit tricky also in P3d 2.x and some of the utilities don't work because they can't find the proper folders. Although it isn't officially supported yet for P3d 2.x, Burkhard (the author) has updated over 600 of the enhanced MyT airports to comply with P3d's more strict adherence to BGL code checking.

 

As an aside, the freeware AIController app:

 

http://forum.avsim.net/topic/447974-ai-controller-sid-jet-route-star-and-final-approach-beta/

 

does a great job of making AI traffic comply with SIDs and STARs. It runs fine with P3d 2.3. I was impressed, when I ran it for KJFK and watched all the commercial flights follow the proper takeoff and landing patterns. Enough "hijacking" of your thread by me and I hope someone can help you out with UT.

Share this post


Link to post
Rob

 

"must also change the dll.xml to point to P3D versions of traffictoolbox.dll and visualfxtool.dll (leave object_placement.dll pointing to fsx version)..."

 

This quote looks to me that they are giving some direction with FSX also installed which does not help you as you dont - just a thought

Share this post


Link to post

You dont need to edit the dll file, I dont know what that post is talking about (I found it too when I was searching how to do this) I learned the hard way with 2.2. I used the migration tool also with 2.2 and had it running fine with only the .cfg and .exe entry. You guys are way more knowledgeable than I am at this stuff so I cant offer much help. I do know id get that same error if I didnt have the "virtual fsx" enabled with EMT while trying to access UT2 menus.


 

 
4.  Edit the EXE.XML and add:
 
  <!-- Unlimited Traffic 2 -->
  

I dont think that should be in the exe.

Share this post


Link to post

You dont need to edit the dll file, I dont know what that post is talking about (I found it too when I was searching how to do this) I learned the hard way with 2.2. I used the migration tool also with 2.2 and had it running fine with only the .cfg and .exe entry. You guys are way more knowledgeable than I am at this stuff so I cant offer much help. I do know id get that same error if I didnt have the "virtual fsx" enabled with EMT while trying to access UT2 menus.

I dont think that should be in the exe.

 

We all know the tool works great - but Rob wants to get it running without the help of a tool

Share this post


Link to post

I dont bother with the two toolbox dll entries just the .exe  and it works fine as long as UT2 was installed into the P3DV23 folder and an fsx.exe is there (fsx.exe can just be copied from fsx folder)

Share this post


Link to post

I don't have FSX installed any longer. However, I had UT2 working (in P3D2 only) when I had FSX installed some time ago.

 

After de-installing FSX, I ran into error messages with UT2 (dfferent from yours, though). I de-installed and re-installed UT2 then. If memory serves me right, I had to create a fake FSX config directory under

 

C:\Users\(my profile)\AppData\Roaming\Microsoft\FSX

 

I just copied over all the contents from the corresponding Prepar3d2 directory and copied the prepar3d.cfg to fsx.cfg. Somehow UT2 seems to look for this directory, even if (maybe) not actively using it.

 

If you don't have FSX installed this might be worth trying.

 

Kind regards, Michael

  • Upvote 1

Share this post


Link to post

UT2 works fine for me in 2.3, however I did originally install it by using the EMT (the crucial point is to have the fsx.exe in your Prepar3d folder, I think).

As far as I can see, the only required entries are the ones in the exe.xml to launch the UT2services.exe, and the SimObjectPaths entry in the Prepar3d.cfg. I have deleted all my config files prior to updating to 2.3 (thanks for your instructions Rob!) and after inserting these two it's working like a charm. No changes required in the DLL.xml.

 

Cheers!

Steve

Share this post


Link to post

As an aside, the freeware AIController app:

 

Thank you, will check that out.

 

 

 

If memory serves me right, I had to create a fake FSX config directory under

 

C:\Users\(my profile)\AppData\Roaming\Microsoft\FSX

 

I just copied over all the contents from the corresponding Prepar3d2 directory and copied the prepar3d.cfg to fsx.cfg. Somehow UT2 seems to look for this directory, even if (maybe) not actively using it.

 

Thank you!  This was the fix ... noted in my "getting very long" P3D V2.x Notes and Procedure document.

 

Just to be clear, I got the UT2 AI aircraft (even the jetways) are all working in P3D V2.3 ... it was just those errors above in the stand alone app.  All good now, no need for EMT.

 

Like I said, I'm not against EMT at all -- it's a great tool.  It's just that I need to know exactly what's going on so in the future when I'm testing v2.4 I'll be aware of any possible issues and figure out how to resolve.

 

No DLL.XML entries needed.  Thanks for everyone's help input.

 

Cheers, Rob.

Share this post


Link to post

Great that you've solved it Rob.

Do you mind running over my precis of the procedure gleaned from this thread, and advising if I've misunderstood anything?

 

From your original post:

 

  1.  Copy Prepar3d.exe and rename to FSX.exe

 

2.  Add registry key for FSX location that points to P3D - HKEY_CURRENT_USER\Software\Microsoft\Microsoft Games\Flight Simulator\10.0 – value = V:\Lockheed Martin\Prepar3d v2

 

3.  Edit the Prepar3D.cfg and add under:

        [Main]

        SimObjectPaths.9=SimObjects\UT2 Aircraft

 

4.  Edit the EXE.XML and add:

 

  <!-- Unlimited Traffic 2 -->

  <Launch.Addon>

     <Disabled>False</Disabled>

     <ManualLoad>False</ManualLoad>

     <Name>UT2</Name>

     <Path>V:\Lockheed Martin\Prepar3D v2\Flight One Software\Ultimate Traffic 2\UT2Services.exe</Path>

     <NewConsole>True</NewConsole>

  </Launch.Addon>

 

From subsequent posts (thanks Michael)

 

Create a fake FSX config directory under:

C:\Users\(my profile)\AppData\Roaming\Microsoft\FSX

Copy over all the contents from the corresponding Prepar3d2 directory and copy the prepar3d.cfg to fsx.cfg

 

Does that sound right?

Thanks to all

Eugene

 

 

 

Share this post


Link to post

Yes, that's correct.  Once P3D v2.3 fires up, it may take a few seconds for the AI to appear.  Also, if your at an airport and do any changes to your display setting the AI will do the gate shuffle when you return.

 

Cheers, Rob.

Share this post


Link to post

Did they patch the Lod problem with the older 2002 ai models ?? the js31 and js41 for example ?

Share this post


Link to post

This is fine BUT there still remains a problem! UT2 doesn´t work with Win 8!!!!!

Share this post


Link to post

 

 


Did they patch the Lod problem with the older 2002 ai models ?? the js31 and js41 for example ?

 

Don't know what you mean ... what "Lod" problem?  UT2 has FS8 AI models ... I thought they were all updated?

 

 


This is fine BUT there still remains a problem! UT2 doesn´t work with Win 8!

 

You lost me?  UT2 doesn't support Windows 8?  

 

UT2 actually doesn't support P3D V2.x either, hence my thread and now solution.  This thread is not about solving Windows 8 issues.  There is not going to be any future work done on UT2 ... so armed with that information, you'll need to decide if you really NEED Windows 8.  I don't have Windows 8 so I can't verify any UT2 issues with it.

 

Unless there is actually something you MUST have that is in Windows 8 that is NOT in Windows 7, I would wipe Windows 8 and go with Windows 7 for any type desktop computing.  Windows 8.x is really aimed at the Mobile market and the "desktop" aspect of it doesn't really work well as a desktop computer -- there are tools to get Win8 back to being more like a desktop computer but that begs the question why do all that work and just use Windows 7 and avoid the headache?

 

As I understand it, the next version of Windows will have a variant more focused on desktop computing ... but no idea when that will be out.

 

Cheers, Rob.

Share this post


Link to post

Yes, that's correct.  Once P3D v2.3 fires up, it may take a few seconds for the AI to appear.  Also, if your at an airport and do any changes to your display setting the AI will do the gate shuffle when you return.

 

 

Brilliant Rob,

Many Thanks

Eugene

Share this post


Link to post

This is fine BUT there still remains a problem! UT2 doesn´t work with Win 8!!!!!

 

Hi

No problem at all between UT2 and Windows 8 or Windows 8.1 since the beginning.

The only issue with Windows 8 and 8.1 remains the joystick deconnection but it is resolved with FSUIPC.

 

Denis

Share this post


Link to post

Hello if you grab the last schedules update, summer/fall 2013 this also updates UT2 to version 2.10 and then add Audio Enviroment and Audio enviroment GA for more immersion. The models I think, look and sound fabulous. This is my setup, as UT usually first after initial fsx/pd3 2.3 install, very important ut2 works.

 

Cheers

Steve

Share this post


Link to post

How is UT2's performance impact?  I've been using Traffic360 in 2.2, and it will run with no problems, but the performance is horrible (70% fps loss at heavy airports).  It's my understanding that this is because the models are killing performance, and that no traffic addon has models that will not kill P3D performance.  Can anybody comment on this?

Share this post


Link to post

All AI traffic (internal as well as add-on programs) takes a toll. I own the three main AI traffic add-ons, i.e. Traffic360, MyTraffic5.6, and Ultimate Traffic 2. I tried all of them under Prepar3d. Keep in mind, none of them has been officially adapted to Prepar3d2 so far and, as Rob says, UT2 supposedly will never be. I found that MyTraffic was the worst performing, closely followed by Traffic 360. UT2 was the best perfoming among the three, but still produces a framerate hit of, say, ~4 frames from 25. You can see this, as UT2 only kicks in after the simulator is running for a few seconds. All of this tested with unlimited framerate, of course, and on KSFO. On on a small pure GA airfield with only a couple od Pipers around values are better, of course. 

 

However, UT2 has a nice feature wich may be not generally known. If you call the main application (without running the simulator) there are several "In Game Settings" under "Utilities". The Traffic Generation Options are quite high by default. You can considerably lower them, at least if you are flying low and slow as me most of the time. Moreover, there is a "Target FSX frame rate slider". I set this slightly below my (usually externally limited) target framerate. If UT2 detects your framerate drops considerably below this value it adjusts AI traffic automatically, up to deleting it completely, if framrate drops drastically. I found this a very cool feature.

 

Hope this helps.

 

Kind regards, Michael

Share this post


Link to post

Glad this thread was started because I want to get UT2 working with P3Dv2.3.  I used the EMT but still no luck.  I have added the simobjects line to the cfg file but cant figure out how to modify the exe.xml file?  How do you all modify the xml file??

Share this post


Link to post

Please check Rob's Messages in this thread, it's all there.

 

Kind regards, Michael

Share this post


Link to post

I realize its all there but having difficulties adding entries to the EXE.xml file.  I am using notepad to modify the xml file with no success in adding the UT2 entries per Point 4 in the OP.

Share this post


Link to post

I realize its all there but having difficulties adding entries to the EXE.xml file.  I am using notepad to modify the xml file with no success in adding the UT2 entries per Point 4 in the OP.

I right click and open with word pad.

Hello if you grab the last schedules update, summer/fall 2013 this also updates UT2 to version 2.10 and then add Audio Enviroment and Audio enviroment GA for more immersion. The models I think, look and sound fabulous. This is my setup, as UT usually first after initial fsx/pd3 2.3 install, very important ut2 works.

 

Cheers

Steve

So audio environment works in p3dv2?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this