Jump to content

Sign in to follow this  
Richard Sennett

How to install UT2 into P3D 2.5

Recommended Posts

I actually have both UT2 and P3D set to 0 now. Since I purchased VoxATC it makes enough traffic from the UT2 Aircraft.

 

I haven't upgraded to 2.5 yet, but I hope voxatc can still find the UT2 AI in the new cfg..


Dan.W

20.jpg

 

Share this post


Link to post

So, am I to understand that UT2 does not work perfectly with P3D v2.5? If that is the case, then it is yet another reason (for me) not to upgrade from 2.4.

 

On a side note, can anyone confirm that the new payware version of EditVoicePack works fine (or more correctly....updates fine) in P3D? The old version seems to have problems with compatibility of some sound files.


Christopher Low

UK2000 Beta Tester

FSBetaTesters3.png

Share this post


Link to post

UT2 works just fine in v2.5, as long as you follow the instructions.  The AI sliders in P3D have NO effect.  Setting UT2 traffic levels from the UT2 GUI, to around 30%, gives me ample traffic on my modest rig.


- Dean

P3Dv4 & XP11

space

Share this post


Link to post

 

UT2 works just fine in v2.5, as long as you follow the instructions

 

Does that include the repaint management utility?


Christopher Low

UK2000 Beta Tester

FSBetaTesters3.png

Share this post


Link to post

 

 


Does that include the repaint management utility?

 

Now that I can't say Christopher as I've never used it.


- Dean

P3Dv4 & XP11

space

Share this post


Link to post

I add plenty of new airline schedules and repaints on my PC, so I really need that to be working properly.


Christopher Low

UK2000 Beta Tester

FSBetaTesters3.png

Share this post


Link to post

I have everything in UT2 working properly with P3D 2.5. This includes all database management, Power Pack, and repaint tools. I installed using the Migration Tool and initially I was getting an error opening the UT2 interface. The fix was to make sure the ordering of SimObjects in the Prepar3D.cfg file was correct. When UT2 installs is puts an entry in the config that starts with number 7 I believe. Since all the SimObjects moved in 2.5 to a seperate config file this was out of order and causing the interface to show an error. Changing that in the config to the number 0 fixed the problem.

 

The basic thing to remember is UT2 doesn't know the SimObjects moved to the ProgramData folder so you have to still have the correct entry in Prepar3D.cfg - If you add in other SimObjects folders for other aircraft and use UT2 to control them you'll have to add those folders into the cfg file as well. There will also need to be entries in the SimObjects.cfg file in the ProgramData folder as well. Hope this makes sense!

 

Brandon

Share this post


Link to post

Does that include the repaint management utility?

Yes! Here is how I installed UT2 v2.9 into P3D v2.5 using EMT.

 

1. enable EMT

2. install UT2 pointing to the P3D directory

3. UT2 installer will put this line into the "prepar3d.cfg":

     [Main]

     SimObjectPaths.1=SimObjects\UT2 Aircraft

4. leave it there

5. open %programdata%\Lockheed Martin\Prepar3D v2\simobjects.cfg

6. add this line:

     [Entry.9]

     Path=SimObjects\UT2 Aircraft

7.open up %appdata%\roaming\Flight One Software\Ultimate Traffic 2\UT2settings.cfg

8. you should see something like this"

     [Main]

     FSX cfg File Location =C:\Users\<your name>\AppData\Roaming\Microsoft\FSX\FSX.cfg

     FSX Location=E:\P3D\

     hideDisclaimer=1

9.make sure FSX Location= your P3D directory. Don't change anything else. Trust me.

10.open up "exe.dll" to see if this is in there:

<Launch.Addon>

    <Disabled>False</Disabled>

    <ManualLoad>False</ManualLoad>

    <Name>UT2</Name>

    <Path>E:\P3D\\Flight One Software\Ultimate Traffic 2\UT2Services.exe</Path>

    <NewConsole>True</NewConsole>

  </Launch.Addon>

11.You should have a Ultimate Traffic 2 shortcut on your desktop. Don't run it yet

12. DISABLE EMT

13.Reboot, then run the UT2 shortcut.

 

Of course you'll have to change the paths to reflect your setup. My UT2 Aircraft folder is inside the SimObjects directory (Airplanes, Animals, Boats, etc)

 

Everything works as it should as long as EMT is disabled. I was able to add the CamSim 787 to UT2 using PowerPack and adding repaints to existing airplanes doesn't throw out any error messages.

 

It works, but alas, UT2 seems to be orphaned.


-Jay

9700K | RTX 2080Ti @ 4K | 48GB DDR4 | 2 x 1TB SSDs | RC Cola

Share this post


Link to post

Its working for me now . Thank you Richard an everyone that help


Mr Leny

CPU I7 8700K @ 5.0GHz , MOBO -Asus Maximus X Hero (WiFi AC),GPU - GTX1080 TI , RAM - CORSAIR Vengeance RGB 16GB DDR4 3600MHz
SSD -Crucial MX500 1TB (P3D Install Only)
OS- Samsung 960 EVO 500GB (Window 10 Pro 64)

 

 

Share this post


Link to post

Its working for me now . Thank you Richard an everyone that help

 

Welcome Buddy - still fighting the flu - no fun - thanks guys


Rich Sennett

               

Share this post


Link to post

does not work for me using the EMt tool, some of those entries that are supposed to be in the config files are not being put in by the UT2 installer

 

Wayne


Wayne such

Share this post


Link to post

You need to do manual entries - try work thru directions


Rich Sennett

               

Share this post


Link to post

So, I have it installed and working somewhat - I see traffic in P3D.  However, the only thing that doesn't work is the Traffic Options->Aircraft Repaints.  It pops up an error message stating an "Unhandled exception has occurred in your application...InvalidArgument=Value of '0' is not valid for SelectedIndex".  When I launch UT2, it gives an error stating "Error loading aircraft assignments.  InvalidArgument=Value of '0' is not valid for SelectedIndex'. Parameter name: SelectedIndex"

 

Any ideas?  I installed per instructions a few posts back with Migration Tool.  Only thing different is that my UTSettings.cfg points to Prepar3D.cfg for it's config file rather than FSX.cfg like in the instructions above.  I do not have FSX installed any more.  This is a P3D only system now.


Regards,

 

Kevin LaMal

"Facts Don't Care About Your Feelings" - Shapiro2024

Share this post


Link to post

Kevin,

 

Have you tried to run addon schedules and repaints in P3D that you added in FSX? I seem to remember seeing one or two messages like that after installing UT2 into P3D v2.4, and it was because I didn't transfer all of the necessary files (specifically the UT2Interface.db file) required to let UT2 "know" that modifications had been made.


Christopher Low

UK2000 Beta Tester

FSBetaTesters3.png

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    31%
    $7,770.00 of $25,000.00 Donate Now
×
×
  • Create New...