Jump to content

Sign in to follow this  
Richard Sennett

How to install UT2 into P3D 2.5

Recommended Posts

 
 
 
 

If you're still having trouble, try this method, which is slightly different than OP and doesn't require EMT. This requires you to have FSX with UT2 already installed. This doesn't touch your existing UT2 installation at all. This simply tells P3D where to look for your existing install of UT2.

Change C:\FSX\ path to match your own.

1. open %programdata%\Lockheed Martin\Prepar3D v2\simobjects.cfg
2. add this line:

     [Entry.9]
     Path=C:\FSX\SimObjects\UT2 Aircraft
    
3.open \AppData\Roaming\Lockheed Martin\Prepar3D v2\exe.xml Add the following.

<Launch.Addon>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Name>UT2</Name>
    <Path>C:\FSX\Flight One Software\Ultimate Traffic 2\UT2Services.exe</Path>
    <NewConsole>True</NewConsole>
  </Launch.Addon>
 

That's it

Share this post


Link to post

With the above method does this mean that I can use UT2  in both FSX and P3D without them interfering with each other? I have them installed on seperate drives.


My youtube channel

http://www.youtube.com/c/Dkentflyer

 

Share this post


Link to post

Has anyone gotten this 100% working in windows 10? I had it running flawless in 7 but now I cant get airline traffic to show up regardless of slider settings. I have plenty of ga aircraft and no errors when I launch the ut2 user menus. Im out of ideas, really hate to go to mytraffic. :(

Share this post


Link to post

Hi guys, sorry to bump this one.

 

Has anyone got it working yet in Version 3 with windows 10 ??

 

any help would be greatly appreciated thanks 


 
 
 
 
v63vq9-5.png

Share this post


Link to post

I have it working in v3/ W7... used the same install procedure as for v2.5 but needed to add these lines in the C:\ProgramData\Lockheed Martin\Prepar3D v3\SimObjects\cfg

 

 

[Entry.10]
Path=SimObjects\UT2 Aircraft
Required=True
Active=True

 

I just altered everything to reflect v3... easy as, although all of the AI has rather big nav and strobes now which was not like this in v2.5, nonetheless its working great for me.


Banner_FS2Crew_Supporter.jpg

 

Rick Wilson

 

 

Share this post


Link to post

I have UT2 working in Prepar3d V3, Windows 10. UT2 is installed in Prepar3d V2.5 and all I did was to add in simobjects.cfg (P3D v3) the path of the UT2 and to edit the exe.xml as explained above

 

Share this post


Link to post

Hi Richard !

 

GREAT explanation and I have had success with installing UT2 into P3D3 now.    :smile:  :smile:  :smile:

Many thanks.

 

Best,

Bjorn

Share this post


Link to post

I have UT2 running in P3D v3 with Windows 7 64bit. I have installed PowerPack, but I haven't used it yet. I will give it a go this afternoon.


Christopher Low

UK2000 Beta Tester

FSBetaTesters3.png

Share this post


Link to post

Unfortunately not working for me. After having followed the instructions carefully, the entries in ProgramData's simobjects.cfg file ([entry.10]) have been deleted after P3Dv3 was started. I am running on Windows 10 x64. Any ideas how to resolve this anomaly?

 

Thanks,

Hans

 

Later: The method in topic 476366 method worked fine for me


Kind regards,
Hans van WIjhe

Share this post


Link to post

You guys have power pack running also with v3?

 

yes Ive got powerpack working.  with all my updates


 
 
 
 
v63vq9-5.png

Share this post


Link to post

As soon as i start the UT2.exe i get this error message:

 

Program Error

Error loading default UT2 or FSX settings

 

Data at the root level is invalid. Line 1, position1.

 

Here is my exe.xml file:

 

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
  <Descr>Launch</Descr>
  <Filename>dll.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
  <Launch.Addon>
    <Name>EZdok camera addon</Name>
    <Disabled>false</Disabled>
    <Path>C:\Program Files (x86)\EZCA\EZCA.exe</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>as_btstrp_config_manager</Name>
    <Disabled>False</Disabled>
    <Path>as_srv\as_btstrp_config_manager.exe</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Name>UT2</Name>
    <Path>C:\P3D\Flight One Software\Ultimate Traffic 2\UT2Services.exe</Path>
    <NewConsole>True</NewConsole>
  </Launch.Addon>
</SimBase.Document>
 
And here my simobjects entry:
 
[Entry.10]
Active=True
Path=SimObjects\UT2 Aircraft
Required=True
Title=UT2 Aircraft
 
Also the aircrafts disapear as soon as they Land. Is this related?
 
Many thanks for your help.
 
Manuel

 

Share this post


Link to post

Yep i do now . Had 0% inside P3D as i normally would have in FSX.

 

I also have disabled the traffic.bgl in the scenery\world/ location

 

Still no airliners . Strange

 

Michael 

 

I realize this is an old thread, however, i'm having the same issue with p3d 3.4.9 + ut2 + 2016 schedules.. i'm not seeing any airliners in the sim.. just ga.. how did you sort your issue?

 

Thanks


P3D Settings (GEX, UTX, Vector, FTX, REX)

P3D v3.3 VR thread; XP11 SMP vs Default vs XE(video)

Asus Maximus X Hero Z370; 850watt Seasonic psu; SL Delid 8700k 5.1 at 1.39 and avx-1; F4-3200C15D-32GTZ @1.41 and 3400; TT 3.0 Riing Ultimate Water-64C Prime95B(24c ambient)-70c normally; Thermaltake v51 Case; Evga 1080FTW Hybrid Water; VR-Rift/Vive;

Flight-Stew | Tech-Stew

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    31%
    $7,775.00 of $25,000.00 Donate Now
×
×
  • Create New...