Sign in to follow this  
markmco

P3D v3, Smooth Takeoff then Stutters, Beeps and Requires Power Down

Recommended Posts

Finally took the 2nd plunge with P3D v3 Pro the other day.  I realize how major of an update it is, so wanted to start off very slowly.

 

Saitek panels didn't work, but stock aircraft and overall performance = excellent.  No problems for a few days, so I took the plunge and installed SPAD.  The panels came alive and all was well.  Absolutely amazing.  Left it alone for several days of test flights.  Not a problem.

 

Today, I installed ASN w/ SP4 Beta.  Unfortunately, things went downhill very, very quickly.  Let me preface this with the fact that ASN (and 2012 before it) is such an amazing program, I really wanted it in P3D.  And yes, SP4 IS BETA, so I'm not trying to 'blame' anyone.  I am, however, trying to find an answer without re-installing the OS.

 

Has anyone else experienced this?  Once the stuttering starts, I hear repeating beeps, almost like an outer marker, but lower in pitch.  My mouse starts to drag across the screen.  Before I can pull up task manager, the system is unresponsive to clicks, but does keep beeping and flying slower.  Even control-alt-delete is not available.

 

This could be SPAD not liking something ASN installed?  I did a complete uninstall of ASN, rebooted, but the problem remains.  Interesting that ASN remains as an option in P3D even after it has been removed and system rebooted.

 

Anyone run into this?  I wouldn't think of using a migration tool, so besides ASN and SPAD, it's a completely stock install.  Any ideas are appreciated before doing a major re-install of the whole system.

 

Thanks!

 

 

Mark

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Do you have the Saitek Trim Wheel?

 

It's known to cause this issue with Prepar3D v3.

Share this post


Link to post

Yes, I have this too using saitek controls from time to time. It is related to the current Windows 8 drivers saitek have out. I have stopped using the trim wheel for now and can mostly fly without issues. Certainly not due to asn.

 

Chris

Share this post


Link to post

Ah... I am using the (Saitek/Cessna licensed) trim wheel. I could do without it and really hope that's all it is. Surprisingly, it worked without a hitch for two long days of flights. Anyway, will post back tonight with results.

 

PS: Used to use the Saitek autopilot panel trim in FSX. It works in P3D, but super slow. Must be a way to get it to 'normal' speed in P3D.

 

Thanks for the response.

 

 

Best,

Mark

Share this post


Link to post

I love ASN but I do find that it causes stutters when it updates. I have since toned down the settings a lot in ASN and seperated the update intervals much further apart. It helps!

Share this post


Link to post

I love ASN but I do find that it causes stutters when it updates. I have since toned down the settings a lot in ASN and seperated the update intervals much further apart. It helps!

 

Never had a problem with ASN and stutters. 

Share this post


Link to post

Me neither. I update every 5 min with no issues.

 

Vic

Share this post


Link to post

Every now and then on initiating a flight, if stutters set in, I jump out to the task manager to see what process is causing it, and I have found it to usually be ASN. Since i lessened some of the settings in ASN, it has been less frequent.

Share this post


Link to post

Mark, I get this with the Saitek trim wheel too but it is easy to 'fix'. Just spin the wheel a couple of times before starting the sim so that Windows recognises it (should hear a sound from Windows) and then you can use it without a hitch from then on. You just have to remember to always give it a spin before entering the sim.

 

Cheers

Stu

Share this post


Link to post

Another 'fix' for Saitek Trim Wheel is to have it disconnected while you are starting Windows. Only then connect it.

 

This always solves my problem.

Share this post


Link to post

Thanks for the tips!

 

I didn't get to try this out yet, but will tonight. Really hoping that's the fix, because P3D ran SO smooth up to that point.

 

 

Best,

Mark

Share this post


Link to post

Myself and others have reported the issue (Saitek Trim Wheel) to LM, they were able to replicate ... not sure who's going to be responsible for fix and/or coming up with some work around solution.

 

But in the meantime, the best thing to do is bring up your joystick configuration after starting your PC and BEFORE you run P3D.  Once you have the joystick configuration screen up, select the Trim Wheel and try to calibrate it.  It's very likely it will close the calibration window the first time you move the wheel ... not to worry, open the calibration window again and you should now have a functioning Trim wheel with registered readings.

 

IMHO, this is a driver issue given that there is a problem just trying to configure the device at the OS level without any interaction at all with P3D.  The problem was present in V2.x series but it's impact was less serious, in V3 it causes beeps and stutters and other issues.

 

I've actually moved onto a GoFlight LGTII for my rudder, elevator and aileron trim wheels ... no issues with P3D V3.

 

Cheers, Rob.

Share this post


Link to post

I've had a similar problem on 2 flights.  Do not have Saitek trim wheel but do have Saitek Pro pedals.  Starts with controls not responding (have PFC yoke and throttle console) then mouse jumping and tones.  Controls run through FSUIPC.  Have to shut down computer to correct.

Share this post


Link to post

for those resorting to toning down ASN, another way to really tone down ASN without lessing the settings too much is to get pawaare  processlasso

 

ASN - Set lower process priority

          Set lower IO priority

          Set lower Memory priority

          Set CPU cores used by ASN to what is free after your P3d affinity mask

 

That tames ASN quite well for me, plus I set the update interval to max (30mins), prefer smooth flight to up-to-date weather.

 

But  every simmer should have the swiss army knife called ProcessLasso.

My favourite hobby during cruise is checking lasso to see process using up CPU and taming them.

 

I don't get stutters, also using SSD in raid mode for System and P3d  drive, you need fast drivers for this not just cpu/gpu. Just make sure fastest drive is set as your OS drive. ASN can be quite disk intensive too during updates.

Share this post


Link to post

Finally had a chance to try this.  I just disconnected the trim wheel.  Tried a few hours of test flights and everything worked fine.

 

A big thank you to those that pointed me in the right direction.  I am now using the smaller Saitek trim wheel in the auto pilot module.  It works, but is very slow.  Adjustments in SPAD haven't made a difference.  Anyway, that's a minor issue until I try the dedicated trim wheel again.

 

 

Best,

Mark

Share this post


Link to post

I second Rob's advice. That worked for me. Also, consider not installing the driver.

Share this post


Link to post

Thought I had fixed the problem but to my dismay it reappeared today.  I suspect it may have something to do with GSX as it always seems to happen during the GSX pushback procedure....

Share this post


Link to post

Doubt it as I didn't have gsx installed when I had this problem.

 

Chris

Share this post


Link to post

Had this problem again last night on a flight from IAH to DEN.  Happened when puling into the gate without GSX.  Very annoying.  Never happened before Prepar3d 3.0..

Share this post


Link to post

Every now and then on initiating a flight, if stutters set in, I jump out to the task manager to see what process is causing it, and I have found it to usually be ASN. Since i lessened some of the settings in ASN, it has been less frequent.

Lee, can you PM me your ASN settings that you changed to help alleviate the stutters?  I too am having that very same issue, and it's maddening.

 

-Jim

Share this post


Link to post

There may be 2 issues.

 

We know the trim wheel works with FSX and creates a major problem in P3D v3. Although, that doesn't mean the driver is good.

 

The other problem is that, even when it works in FSX, the wheel needs a spin to wake up. I suspect that spin is needed to wake up a sleeping USB port? Will try setting my ports to not save energy or sleep. Hoping v3.1 will solve, or at least work around the main problem.

Share this post


Link to post

Lee, can you PM me your ASN settings that you changed to help alleviate the stutters?  I too am having that very same issue, and it's maddening.

 

-Jim

Jim, there's a lot of settings you can adjust in ASN. I don't know if I can list them all. The most important is to not have more than 2 or 3 layers of clouds and to reduce the visibility of clouds. I am using 70 miles at the moment. There are other tweaks as well. They even make suggestions on each page. Uncheck the stuff you don't think you need.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this