Sign in to follow this  
csquared4290

My FSX is nearly perfect---except for one graphic issue

Recommended Posts

Hi guys!

 

I'm not exactly new, mostly been a lurker here and there researching lots, but by no means a new Flight-Sim'er. Big time commercial/large jet enthusiast, but no professional at all. But I seek all of you for your assistance!

 

After lots of reading/research and trial and error, I have my FSX running beautifully, except for one minor issue.

 

I have recorded a quick video of what I am experiencing on my YouTube. Basically, only at a couple of airports so far, I get this texture flicking nonsense and have no idea how to cure it.

 

VID: https://youtu.be/lYbg1uro3sk (Direct Link to my youtube account)

 

Here's my stats run-down:

 

Version: FSX Deluxe Ed. SP2

 

DirectX10 P - Enabled - My PC runs FSX so much better in DX10 over DX9, so I am not really inclined to switch back. The issue isn't present to the same extent in DX10--Instead of flickering I get a huge framerate drop in DX9 in the same view position

 

Graphics - pretty much maxed

 

Add-ons relevant to issue:


  • Ground Environment X


  • FSX Modified Terrain CFG - via FlyAwaySimulation


  • FSX2xWater - via FlyAwaySimulation


  • FSX Ground Textures - via FlyAwaySimulation


  • Roads v1.1 - ^same as above


  • TreeX


  • USA Ground Textures Upgrade - via FAS too


  • Steve Parson's Shader Fix for DX10

 

 

 

Custom Built PC:

Intel Core i7 4790k Devil's Canyon

ASUS Maximus VII Motherboard

G.Skill 16GBx4 RAM DDR3

MSI NVIDIA GTX670 4GB x2 running in SLI on latest drivers, clean install

WD VelociRaptor HD 10k RPM

 

I know the issue here is not my PC in hardware--it is a beast and like I said I have FSX nearly running perfect. But I experience this graphic issue. In the same exact camera POV in DX9, I get a huge framerate drop so something's wrong on both ends. In DX10, I get this weird anomaly.

 

This is specifically at KEWR (Newark International Airport) and no matter where I am, at the gate or on the runway or in the region, I will get this.

 

I also noticed it happens at Japan's Haneda International in Tokyo.

 

Here's where it doesn't happen and all is well: I have been to KSLC Salt Lake City International, Seattle-Taco, KLAX, Heathrow, and Domodevovo in Moscow. It doesn't happen there.

 

Can anyone help me here? I'm on my freshest install of FSX yet with all the processes clean and tweaked using that famous FSX Bible by NickN.

 

And it still happened before all the tweaks and add-ons, and even on a previous install (that said, I tried reinstalling several times, clean and still get the issue).

 

Any thing else for me to add please let me know. Trying to be as specific and detailed as possible since I've discovered many threads about "flickering" and Texture and graphics issues. I've sorted through them all and they all say that Steve Parson's DX10 Shader Fix is the solution. It's been added and still get it.

 

Help! lol Thanks in advance!!!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Are you tweaking bufferpools in your fsx.cfg?

 

Hey! 

 

According to my Add-on Manager, I have UsePools at - and PoolSize at 0.

 

I also appended this to my FSX.cfg:

 

[bUFFERPOOLS]

Poolsize=0

UsePools=0

Share this post


Link to post
Share on other sites

You don't need both PoolSize=0 and UsePools=0. Only use one of them. They mean the same thing.

Share this post


Link to post
Share on other sites

When you approach a major addon airport, FSX will need to load the graphics and traffic.. that can lead to a stutter, framerate drop, or graphics anomaly.

 

If you get graphics white flashing, you should reverse your Bufferpools setting (just remove the Bufferpool lines).

 

You can also reduce traffic settings as a test..

Share this post


Link to post
Share on other sites

KEWR and Tokyo areas are heavy hitters in terms of 3D objects being sent to the graphics card. My guess is that your CPU is overpowering the GPU in terms of sending it objects. Having 2 video cards in SLI doesn't help a lot with FSX. When you disable bufferpools (using usepools=0 or poolsize=0), you force the GPU to allocate a dedicated buffer for each object coming from your CPU, and if the GPU cannot keep up you'll get these graphic spikes.

 

Try the following:

 

[bufferpools]

usepools=1

poolsize=10485760

rejectthreshold=262144

 

With the above config, objects larger than rejectthreshold will still get a dedicated buffer, but smaller objects will use shared buffers. This reduces the GPU workload in terms of buffer allocation. If you still see graphic spikes, try doubling the reject threshold, and if that doesn't work, then just remove the [bufferpools] section entirely.

 

The poolsize of 10M is OK since you have SP2 installed because that version FSX is very efficient at searching for free pool space (earlier versions of FSX was not as efficient so smaller pool sizes was necessary).

Share this post


Link to post
Share on other sites

OK! So I tried all of the BufferPools on all accounts, no go!

 

What ended up fixing it was Bert Pieke's suggestion to reduce road traffic!

 

I dropped it from 100% to 60% and all is well now it seems. Any more than 60% and I get the flickering.

 

Thanks everyone for the suggestions!

 

Does there happen to be a fix for this? I like seeing the busy scenery with lots of car traffic and I know my PC (for the most part lol) can handle it.

 

PS: I keep SLI on because it helps with my multitasking when I'm editing video or photography (and flying! lol)

Share this post


Link to post
Share on other sites

OK! So I tried all of the BufferPools on all accounts, no go!

 

What ended up fixing it was Bert Pieke's suggestion to reduce road traffic!

 

I dropped it from 100% to 60% and all is well now it seems. Any more than 60% and I get the flickering.

 

Thanks everyone for the suggestions!

 

Does there happen to be a fix for this? I like seeing the busy scenery with lots of car traffic and I know my PC (for the most part lol) can handle it.

 

PS: I keep SLI on because it helps with my multitasking when I'm editing video or photography (and flying! lol)

60% is still very heavy, try 10 - 15% if you must have road traffic.

Share this post


Link to post
Share on other sites

OK! So I tried all of the BufferPools on all accounts, no go!

 

What ended up fixing it was Bert Pieke's suggestion to reduce road traffic!

 

I dropped it from 100% to 60% and all is well now it seems. Any more than 60% and I get the flickering.

 

Thanks everyone for the suggestions!

 

Does there happen to be a fix for this? I like seeing the busy scenery with lots of car traffic and I know my PC (for the most part lol) can handle it.

 

PS: I keep SLI on because it helps with my multitasking when I'm editing video or photography (and flying! lol)

 

You dont need a fix as there is no real problem. From all the threads Ive seen on Traffic % across many forums a 30% is considered heavy ...  my understanding of how that % option works is 100% is like saying there will be enough traffic in the sky coming and going so as to keep an airport gates full 100% all the time which is not what usually happens. i.e. 100% does not equate to what would be a normal workload at the airport and hence 50% would reduce it by half.. The 50% setting would be increasing the workload at a quiet airport.

Welcome some-one confirming if my belief here is right as Im working off a dim memory.

Just realised the talk is about road traffic but I think the same concept applies

Share this post


Link to post
Share on other sites

I set road traffic at 5%.  I just don't like empty roads, without a few cars and trucks plying the roads, FSX starts to look too much like FS9.  I also set ships and ferries at 20%, leisure boats at 10%.

Share this post


Link to post
Share on other sites

With custom low-detail models, I can have road traffic at 80% without any slowdown at all.

 

Ran FSX without any road traffic for years, but found out that a few cars on the roads really add something when you're low.

Even though they clash with buildings and airport layouts in some sceneries with cars running through the terminal or across taxiways.

 

 

Did you know that FSX adapts road traffic density to the population density of a given area and the time of day?

Pretty cool if you ask me.

Share this post


Link to post
Share on other sites

Hi guys, just thought I get back to you all and say thank you for your input! I realized the artifacts are indeed a result of high autogen traffic.

 

Also read somewhere that Airport Ground Traffic also contributes to memory overloads and artifacts. So I ended up dropping that to around 30% (from like 75%) and I have my "normal" road traffic at 80% (up from 60%). Went through all the airports i've had drops in framerates or artifacts show up and I'm all good!

 

So I think the takeaway here is that it's about leveraging the ground traffic! It's also dependent on your system...I thought I had a beast of a system (still do) but even FSX can still over power it.

Share this post


Link to post
Share on other sites

  

 


   I thought I had a beast of a system (still do) but even FSX can still over power it.
  

Confirms my belief that it doesnt matter how much grunt you confront FSX with... it has the power to just chew it all up.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this