Sign in to follow this  
Pete Dowson

P3D3.2 looks really good, but hesitations are really bad!

Recommended Posts

I have successfully installed 3.2.2 plus Orbx FTX Base, OLC Europe, England and Vector, and I must admit it all looks superb. The performance isn't as good as FSX-SE (nowhere near in fact), but I thought P3D should make up for this in the ability to put sliders up for better visuals, and above all, in smoothness.

 

I changed from a 780 video card with 3Gb up to a 980Ti "Strix" overclocked card with 6Gb, on the understanding that P3D would make good use of the GPU, even though it may still be just as limited as FSX by my 4770K processor (running at 4.4GHz).

 

What I have found is that, yes, this allows me to turn sliders up without noticeable detriment to the frame rate -- which is pegged at 30fps in NVI, as per recommendations I've read, with VS and triple buffering enabled -- dropping to 20fps at really dense and busy airports. (Realistic levels of AI Traffic are a must for me).

 

Well, the performance, at 20 or 30 fps is adequate. But I simply cannot abide the hesitations. There are little microstutters which tend to go unnoticed unless you observe the edges of the display,  I'm not so much concerned with those. It is the longer, up to 1 second or so, hesitations now and then which I really cannot abide and which will certainly drive me back to FSX-SE unless I can find a solution.

 

I have tried many things:

 

1. Disabled all of the FTX Vector layers -- no change

2. Turned off Autogen completely -- no change

3. Turned scenery density to "sparse" -- no change

4. Turned down texture resolutions to 1024 (ie "medium) -- no change

5. Turned each of the upper scenery sliders don a few notches -- no change

6. Turned HDR off -- no change

7. Turned all reflections off -- no change

8. Turned water quality down to "low" -- no change

 

I'm starting to run out of things to turn down. The only things I can thing of doing now are to avoid all add-ins like DLLs for GSX, etc. (not running any of the programs I actually need to run) and trying a default scenery.cfg. I can appreciate that might get the frame rate up (to the lock), but smoothness? And what's the point of flying it then when I can have all those things in FSX-SE without the hesitations?

 

I've avoided doing any tweaks in the P3D CFG file as the general advice seems to be that it doesn't need any. I did try adding the AfflinityMask 14 and even Bufferpools=0, but those didn't make any different so I took them out again. I've not fiddled with any of the other things like TextureMaxLoad, and FFTF.

 

Do any of the experts out there have any advice for me, please?

 

Pete

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Are you talking about 3.1 or 3.2?   

Share this post


Link to post

Are you talking about 3.1 or 3.2?   

 

As stated at the beginning of my post, it is 3.2.2, the latest build.

 

Pete

Share this post


Link to post

I had the same problem.  The cure for me was to completely disable road traffics and use FFTF at 0.12.

Share this post


Link to post

Pete, I have the same observation as you, so I will be following this thread closely. Skip

Share this post


Link to post

I used to have the same symptoms with my relatively powerful machine (i7-6700k-4.7OC + 980Ti/6GB) and I found during one of the random tests that moving tessellation to the left (minimum) cures the stutters especially during approaches. Maybe it's me or my specific set-up, but that's my experience.

 

Also, if you use other external add-ones (PROATC, RC4, AFB, ASN (especially ASN)) I would suggest to move them exclusively to the core 0, leaving cores 1-2-3 for P3D alone (assuming that you use AF=14) 

Share this post


Link to post

I had the same problem.  The cure for me was to completely disable road traffics and use FFTF at 0.12.

 

Road traffic is only on 5, but I'll try these tips. Thanks.

I used to have the same symptoms with my relatively powerful machine (i7-6700k-4.7OC + 980Ti/6GB) and I found during one of the random tests that moving tessellation to the left (minimum) cures the stutters especially during approaches. Maybe it's me or my specific set-up, but that's my experience.

 

Is turning it down better than turning it off on the previous option page? I'll try that. Thanks.

 

 
Also, if you use other external add-ones (PROATC, RC4, AFB, ASN (especially ASN)) I would suggest to move them exclusively to the core 0, leaving cores 1-2-3 for P3D alone (assuming that you use AF=14) 

 

 

 

OK, so I should add AF=14 back. Of those you list I only have ASN running, but I have in addition (normally) UT2, OPusFSI (for camera views only weather disabled) and Aivlasoft's EFB data provider -- except for my tests reported earlier that wasn't running in any case. I'm just about to do another test with none of them running.

 

I used to know about these things but I forget (getting too old). What's the easiest / best way of restricting processes to a specific core?

 

Thanks,

Pete

Share this post


Link to post

As stated at the beginning of my post, it is 3.2.2, the latest build.

 

Pete

 

OK, the thread title had me confused. 

Share this post


Link to post

.1. Yes, turning Tessellation down (full left in the menu) should help. HOWEVER, do NOT turn it off completely.

 

2. There are many utilities that automatically assign individual cores to the individual programs, but I still assign cores manually. Perhaps other users could recommend specific software to automate the cores assignment.


And yes, ASN is badly famous for its stutters if utilizes the same cores as P3D does. Strongly recommend to allocate an individual core for it. I had very bad simming times until HiFi support helped me with that issue  

Share this post


Link to post

.1. Yes, turning Tessellation down (full left in the menu) should help. HOWEVER, do NOT turn it off completely.

 

2. There are many utilities that automatically assign individual cores to the individual programs, but I still assign cores manually. Perhaps other users could recommend specific software to automate the cores assignment.

And yes, ASN is badly famous for its stutters if utilizes the same cores as P3D does. Strongly recommend to allocate an individual core for it. I had very bad simming times until HiFi support helped me with that issue  

 

I use ASN with Version 3.1 and get no stutters, and didn't with V3 and V 2.5 either. I have no core assignments at all, I just let windows handle that. 

Share this post


Link to post

I use ASN with Version 3.1 and get no stutters, and didn't with V3 and V 2.5 either. I have no core assignments at all, I just let windows handle that. 

 

Depends on lot of things - a number of cloud layers, clouds' software (REX/FEX/OPUS), texture resolution, cloud draw distance, visibility, P3D in-game resolution, weather suppression radius, NI settings, use SGSAA or lack of thereof...that's just for the start. 

 

Yes, some folks don't have issues with ASN, others do. Also, some folks feel that they have stutters, others don't care at all. Fully subjective stuff we're talking here.

Share this post


Link to post

OK, the thread title had me confused. 

 

Ah, sorry, yes -- typo in title. Didn't notice. Fixed that now. Thanks.

 

.1. Yes, turning Tessellation down (full left in the menu) should help. HOWEVER, do NOT turn it off completely.  

 

Okay, wilco.

 

2. There are many utilities that automatically assign individual cores to the individual programs, but I still assign cores manually. Perhaps other users could recommend specific software to automate the cores assignment.
 
All my EXE's are started and stopped via FSUIPC, not the EXE.XML, so I might investigate how to program that and add it as an FSUIPC Run/RunIF option.
And yes, ASN is badly famous for its stutters if utilizes the same cores as P3D does. Strongly recommend to allocate an individual core for it. I had very bad simming times until HiFi support helped me with that issue
 
Hmm. Odd. Never had the problem with FSX or FSX-SE all these years.
 
Thanks
Pete

Share this post


Link to post

Process Lasso is a good utility for limiting which cores programmes run on. I use Hyper Threading on my CPU so this may not be suitable for you but I set the Affinity Mask in the P3D.cfg to 85 and then run ASN and TrackIR on logical threads(?) 3,4,5,6 and 7. Process Lasso starts up automatically with Windows and  applies the right cores whenever I start ASN and TrackIR. I went into more detail about this here:

http://www.avsim.com/topic/484333-blurries/

 

I got all my info from SteveW and Nyxx pretty much.

 

Hope that helps.

  • Upvote 1

Share this post


Link to post

Definitely something unique to some users and not others.  3.1 and especially 3.2 are the most free of hesitations/micro-stutters yet to date--stay with it as it is clearly for myself and others what we might have hoped P3D would be.

 

I am using a 3930K at 4.43Ghz and had always used AM=4290.  SteveW suggested using a completely different approach, AM=21760, and I must say my HT enabled 6 core is working much less but producing the same result, and I can't quite explain that except that apparently it was unnecessarily 'busy' as manifested by considerably more heat at the same core voltage.

Share this post


Link to post

I have successfully installed 3.2.2 plus Orbx FTX Base, OLC Europe, England and Vector, and I must admit it all looks superb. The performance isn't as good as FSX-SE (nowhere near in fact), but I thought P3D should make up for this in the ability to put sliders up for better visuals, and above all, in smoothness.

 

Pretty much sums up my conclusions. It looks pretty, but performance gets very rough and gets nowhere near as good as FSX:SE if I load in a tubeliner.

 

So the microstuttering issue bothered me as well. I did lots of testing and found that a few tweaks helped alleviate the microstuttering. I documented it in a post http://www.avsim.com/topic/477057-a-frame-time-analysis-of-p3d-v3-effects-of-cpu-affinity-frame-lock-and-ht/#entry3315905. My findings are in the first two pages, while others chime in for the rest.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this