Jump to content

Sign in to follow this  
Bionor

I just trippeled my FPS in XP10

Recommended Posts

 

 


Once exception is when SMP and RW connector decide to reflect current weather, it is then and only then that I get the dreaded 1 sec pause.

 

have you tried lowering the cloud draw distance in SMP?

Share this post


Link to post
Share on other sites

Glad to see it at least helped some people:-) I guess this applies only to those who have a GPU that does not "throttle up" when running X-plane. Running gpu-z while using x-plane should reveal wether this applies to your gpu or not, if your gpu is at full throttle in adaptive mode, this tip probably wont help you. In my case, running the gpu unwillingly at 640/400 must have bottlenecked my cpu as well. This Maximum Power mode seems to "force" the GPU to 100% and thus giving the cpu an opportunity to run at full power or at least not being bottlenecked by a slow gpu. I've so far only seen this behaviour in X-plane, all other 3D-applications throttles the gpu to full power@1500/1000 in the adaptive mode. This whole thing might j just be a result of a bad drivers on certain nVidia-gpus like my EVGA 780. Its not happening to everybody, so could be a case with EVGA gpus, could be something that only applies to some gpus running on certain MBs, who knows, at least now I know and it will always be part of my system check:-)

 

On a sidenote; for those of you running your OS and/or X-plane on a Samsung SSD and using the Samsung Magician software, be aware that running the Magican at Maximum Reliability will cause X-plane to OOM when using complex addons. It took some time to figure out, but this mode adjust the pagefile-setting and sets the "Start" and "Maximum" pagefile at 1gb flat and X-plane does not like that at all. Have not checked the other modes and what those do to the pagefile, but you're better of letting the OS handle the pagefilesize:-)


Phanteks Eclipse P500A D-RGB || Ryzen 9 5900X || G.Skill TridentZ RGB 32GB@3600CL16(b-die) || Asus ROG Strix Gaming-E X570
Asus Geforce RTX 3080 TUF Gaming  || Corsair iCUE H115i RGB PRO XT LCS || XPG SX8200 Pro 2TB M.2 NVMe || Phanteks Revolt Pro 1000W
Samsung 32" Odyssey G7 1440p@240hz || X55 Rhino || G27 || TrackIR5 || Oculus Quest 2

 

Share this post


Link to post
Share on other sites

have you tried lowering the cloud draw distance in SMP?

 

It's on default settings, will try that to see if it helps, thanks.


Carlos Franklin

Sims: MSFS2020 (for now, will see what XP12 will bring)

Asus Sabertooth z77 - i7 3770k @ 4.3 HT WC - 32gb Corsair @ 2133 (XMP) - Asus GTX 1070 - 250 Evo Pro SSD for Win10 Pro - 500 Evo Pro SSD for MSFS2020, 

 

Share this post


Link to post
Share on other sites

Thank you so much for pointing this out Tom.  I'd noticed X-Plane seemed to maintain much better FPS in heavy areas like LA after running FSX (which is in max power mode in Nvidia Inspector) than when run first and it looks like you've hit the nail on the head.  I can't wait to try this when I get back from uni.


Finlay Waller

Share this post


Link to post
Share on other sites

Hi Tom,

 

Thanks for the info. It took me a while to find "The "Power Management Mode" - NVidia Control Panel > 3D Settings > Manage 3D Settings > Power Management Mode. I was indeed in Adaptive Mode and switched.

 

At KEWR - Newark,NJ - I had a substantial rise in frame rates of about 20FPS. This with the Drzewiecki Design New York Airports! However, once en route the  FPS dropped to about 20FPS where I expected better frame rates.

 

At any rate, thanks again for the topic. I will  fiddle around with my settings and try to improve performance beyond what I have now.


Jim Morgan

Share this post


Link to post
Share on other sites

 

 


- "1/2 refresh rate"
- "texture filtering negative LOD bias to Clamp"

 

Jose,

 

I just added those two and, for the first time, I flew my A330 without the "low framerate" warning trying to raise it's ugly head.  The frames always showed okay, but would trigger the warning for some reason.  Now, it appears to be gone.

 

John


John Wingold

Share this post


Link to post
Share on other sites

 

Hi!

 

So I decided to write this post to those who might be struggeling with what apparently was low fps. This might be for a few only since this is a result of my own stupidity and/or neglegance. I've been a XP10 user for roughly one year and I've always been content with the fps I was achieving. Its always been hovering somewhere between 25-35 depending on what ac I loaded up and the current weather. I've never given it much thought because I thought this was where the fps should be considering the complexity of ac's, addons and such. Before I go into details, this is my setup;

 

i5 3570k@4,4Ghz

16gb RAM

nvidia 780 3gb

XP10 on a dedicated 500gb SSD

 

XP10.45, HD Mesh v3, w2xp Europe, Norway Pro by tonywob, all Norwegian airports by tdg and a few European as well, SkyMaxxPro3.1.2, FSGRW, RWC, SoundMaxx, a bunch of libraries, some ZonePhoto, Rotate MD80, JarDesign 320/330 and IXEG

 

So, last week I bought the long sought after IXEG733 and I was quit happy with it. I read reports that fps was on par with the default aircraft and my experience was the pretty much the same loaded up on an addon airport, roughly 30 fps. I flew a couple of flights and then started watching some online videos and I was a bit baffled how smooth its seemed to run. My first thought was that it must be some super OP hardware, but realizing that this was run on hw similar to mine I began suspecting something was off with my setup. I started changing pretty much every setting I could find, but nothing seemed to do anything with my fps except lowering it when pushing them higher(had to check). So, as the sim-guy I am, I did the only reasonable thing a sim-guy would do, I deleted the whole thing and started over.

 

Now, I wanted to test the vanilla XP and fired it up to se how the fps was on default settings and, yeah, it was around 100fps. My initial thought was, "yeah buddy, something was up, but now its ok". I began installing my addons again, downloaded all new versions of pretty much everything. After all this was done, I fired up IXEG733 to test my new achievement, but dammit all, the fps was back down again to around 30. Crap, my HW suck!

 

So, I started doing some online research, but found nothing that could shed a light on my situation, except for a suggestion(to a completely different problem) running gpu-z and a resource monitor while using XP. What I saw was my CPU bearly reaching 30% utilization and according to GPU-Z, my GPU was running at a abbysemal Core@640Mhz and memory@400Mhz. I tried doing the same while using other games only to see my GPU now was running at Core@1500 and memory@1000Mhz. This must be it! This has to be IT! How do I solve this? 

 

Turns out,(and this is what pretty much all of you already must know, hence no such topics in XP-forum:-)), its a simple setting in nVidia CP called Power Managment Mode. Change this from "Adaptive"(which its clearly not), to "Maximum performance" and lo and behold; XP fps trippled in a milisec!! From 25-30 to 70-80 in the IXEG, over a 100 in the Rotate MD80. Even with all my settings almost maxed out, its way above 50 in the IXEG! 

 

Now I know, most of you already knew this, but this thread is not for you, its for the few others who is as braindead as me! I've even read about this setting in other games, but I never did realize, or at least I forgot, that this setting is changed back to "Adaptive" everytime you change the drivers and chose to reinstall the CP(yes, it even warns you that all settings will be defaulted), but it doesnt tell you that Adaptive is the default...which sucks!

 

Tom G, finally soaring in the skies at 50fps or above:-)

 

Cheers!

 

 

 

 

 

 

Simply made my day i've been struggling to gain 15fps in the IXEG at London Heathrow EGLL Now im getting 45fps while streaming THAT YOU So much !!!!!!!

Share this post


Link to post
Share on other sites

Is it for the XP10 profile or just a global setting?

 

At the moment I'm not even using a profile - I just use built in settings within XP


|Ryan Butterworth|

| i7 4790K@4.4GHz | 32GB RAM | EVGA GTX 1080Ti | ASUS Z97-Pro | 1TB 860 Evo | 500GB 840 Evo Win10 Pro | 1TB Samsung 7200rpm | Seasonic X750W |

 

 

Share this post


Link to post
Share on other sites

It's a global setting.


Intel i-9 9900k @ 5.0 Ghz, EVGA 2080ti FTW3 11Gb, Corsair H115 PRO water cooler, Gigabyte Aorus Master motherboard, EVGA Super Nova 1000 watt G+ power supply, G.SKILL 64Gb ram @3800 MHz, HP EX 920 M.2  PCIe 3TB,Windows 10 Pro x64

Share this post


Link to post
Share on other sites

Is it for the XP10 profile or just a global setting?

 

At the moment I'm not even using a profile - I just use built in settings within XP

 

 

It's a global setting.

 

You can make it an XP specific setting as well. In the NV CP you can choose different settings for different applications.


4790K @4.9GHz, 32GB DDR3, 1080Ti, W10-64bit

Share this post


Link to post
Share on other sites

its a simple setting in nVidia CP called Power Managment Mode. Change this from "Adaptive"(which its clearly not), to "Maximum performance" and lo and behold; XP fps trippled in a milisec!! From 25-30 to 70-80 in the IXEG, over a 100 in the Rotate MD80. Even with all my settings almost maxed out, its way above 50 in the IXEG! 

Sorry I must be blind so I must ask that you point my nose in the direction of the Nvidia control panel's power management mode.... because I can't find that anywhere in the control panel.

 

Thanks in advance for your speedy response,

 

Chas


My first sim flight simulator pD25zEJ.jpg

 

Take a ride to Stinking Creek! http://youtu.be/YP3fxFqkBXg Win10 Pro, GeForce GTX 1080/i7-6700K CPU OCd,16 GB RAM,3x1920 x 1080, 60Hz , 27" Dell TouchScreen,TM HOTAS Warthog,TrackIR5,Saitek Combat Rudder Pedals.

Share this post


Link to post
Share on other sites

Sorry I must be blind so I must ask that you point my nose in the direction of the Nvidia control panel's power management mode.... because I can't find that anywhere in the control panel.

 

Thanks in advance for your speedy response,

 

Chas

Hi Chas,

 

I believe you need Nvidia Inspector for this to work. Download the latest version, run it and click on what looks like a wing (middle of screen to the right). In the new page that appears at the top left, go to Global_Driver_Profiles. Scroll to Number 5 Common where you'll find Power Management Mode. Select Prefer Max Performance.

 

Hope this helps but not certain it will improve things.

Share this post


Link to post
Share on other sites

Sorry I must be blind so I must ask that you point my nose in the direction of the Nvidia control panel's power management mode.... because I can't find that anywhere in the control panel.

 

Thanks in advance for your speedy response,

 

Chas

Open your nVidia Control Panel, located in your systray (lower right of your screen), by way of right-clicking on the nvidia icon.  Once open, Select the option Manage 3D Settings (left hand side of the window of the NCP).  There will be two tabs along the top of the settings dialog, appearing in the main window, the first being Global Settings and the other Program Settings.  You can set either one for "Prefer Maximum Performance", selected under Power Management Mode, but I typically set it for specific applications, which is under Program Settings.  If setting for XP11, it may not appear on the drop-down list, so you will have to navigate to the exe, under the folder where XP11 resides.

 

Just as a side note, I have yet to find a reason to use the nvidia inspector for XP.  For P3D and FSX, it was almost always a must, but I'm not using it in XP11, and everything functions fine...at least for the beta. :)


Engage, research, inform and make your posts count! -Jim Morvay

Origin EON-17SLX - Under the hood: Intel Core i7 7700K at 4.2GHz (Base) 4.6GHz (overclock), nVidia GeForce GTX-1080 Pascal w/8gb vram, 32gb (2x16) Crucial 2400mhz RAM, 3840 x 2160 17.3" IPS w/G-SYNC, Samsung 950 EVO 256GB PCIe m.2 SSD (Primary), Samsung 850 EVO 500gb M.2 (Sim Drive), MS Windows 10 Professional 64-Bit

Share this post


Link to post
Share on other sites

Carlos Franklin

Sims: MSFS2020 (for now, will see what XP12 will bring)

Asus Sabertooth z77 - i7 3770k @ 4.3 HT WC - 32gb Corsair @ 2133 (XMP) - Asus GTX 1070 - 250 Evo Pro SSD for Win10 Pro - 500 Evo Pro SSD for MSFS2020, 

 

Share this post


Link to post
Share on other sites

Just as a side note, I have yet to find a reason to use the nvidia inspector for XP.  For P3D and FSX, it was almost always a must, but I'm not using it in XP11, and everything functions fine...at least for the beta. :)

 

Same here Jim bye bye NI - one less thing to worry about


Rich Sennett

               

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    39%
    $9,950.00 of $25,000.00 Donate Now
×
×
  • Create New...