Sign in to follow this  
Wild_South

Quick Word of Advice!!

Recommended Posts

Hi all, 

Don't worry, I am not bashing V4 at all, just letting some people know my thoughts. Last night it ended up getting the better of me, so I fell into the trap and bought v4. After installing and loading up the first flight, everything looks good, and am sure it is going to be just amazing when we have the addons available for it (not just compatible, but approved by the developers).

I found myself a bit bored after about 20 minutes, simply due to the lack of addons, and therefore immersion. So, my advice would be just hold off a month or so until it is an established sim. I am back to v3.4 for the time being for the immersion of it.

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I suppose it depends on the add-ons you have/want.   

I have P3DV4 with official add-ons working already; FSUIPC, MakeRunways, Radar Contact 4.3, Orbx, A2A, PMDG, Active Sky, Envtex, FSForce, FSRealTime, Navigraph Ultimate, GSX, and a bunch of free AFCAD airport upgrades.

A few with very simple workarounds; UT Live, STB, PFPX, EditVoicePack, no big deal.  

I'm having a much more productive simulation/flight training time in V4, with higher FPS, stutter free, VAS OOM free, a much more full scene, with 100% air traffic, and not a concern in the world of a CTD because my sim can't handle all the add-ons.

I'm never going back to 32-bit because 64-bit is much more immersive for me.

  • Upvote 5

Share this post


Link to post
24 minutes ago, pracines said:

I'm never going back to 32-bit because 64-bit is much more immersive for me.

Agreed. The performance is simply amazing on my new rig. I've been in the shadows and not flying for 3 years. I've been monitoring AVSIM and patiently waiting for 64bit and bam! Not looking back here.

  • Upvote 1

Share this post


Link to post

Drumcode

How did you get editvoicepack working?

Thanks

John

Share this post


Link to post
8 minutes ago, johnbla said:

Drumcode

How did you get editvoicepack working?

Thanks

John

Not sure how that came about, I don't use it. Radar Contact here.

Share this post


Link to post
40 minutes ago, pracines said:

I suppose it depends on the add-ons you have/want.   

I have P3DV4 with official add-ons working already; FSUIPC, MakeRunways, Radar Contact 4.3, Orbx, A2A, PMDG, Active Sky, Envtex, FSForce, FSRealTime, Navigraph Ultimate, GSX, and a bunch of free AFCAD airport upgrades.

 

In all fairness, only one addon from A2A, and only one addon from PMDG, is available at this current time. Not to mention Orbx, only Global, LC, and Regions released. Who knows when the rest will be. 

Share this post


Link to post
31 minutes ago, johnbla said:

Drumcode

How did you get editvoicepack working?

Thanks

John

Here's a snippet off their website. Last line is what you're looking for.

 

Supported flight simulators:

Microsoft Flight Simulator X – Original DVD Release

With or without the “Acceleration” expansion pack.

If your ATC text is not in English, enabling the optional ICAO or FAA phrases will result in English text mixed into your ATC text. All other features works without problems on non-English versions of FSX.

Microsoft Flight Simulator X: Steam Edition

Lockheed Martin® Prepar3D®

Lockheed Martin’s Prepar3D® v2

Lockheed Martin’s Prepar3D® v3

Lockheed Martin’s Prepar3D® v4

Share this post


Link to post
1 hour ago, Wild_South said:

Hi all, 

Don't worry, I am not bashing V4 at all, just letting some people know my thoughts. Last night it ended up getting the better of me, so I fell into the trap and bought v4. After installing and loading up the first flight, everything looks good, and am sure it is going to be just amazing when we have the addons available for it (not just compatible, but approved by the developers).

I found myself a bit bored after about 20 minutes, simply due to the lack of addons, and therefore immersion. So, my advice would be just hold off a month or so until it is an established sim. I am back to v3.4 for the time being for the immersion of it.

 

Huh? Virtually all my payware airports have been ported over. And that's a lot. All Orbx over. PMDG 777 over. My beloved Duke ported over. ActiveSky ported over. I can use my Rex Overdive textures and all. MyTraffic over. EFASS NG over. This week supposed to be PMDG 737NG over. Not sure what you're talking about. Easily forgetting OLD 32 bit 3.4 and it's OOMs.

  • Upvote 1

Share this post


Link to post

Not sure why a few posts pop up here and there advising us not to get ver. 4 yet, cause it's too boring.

As far as I know, a lot of us are on ver. 4 and not a bit bored with it. 

Each one has their own thoughts on it.  

  • Upvote 3

Share this post


Link to post
1 hour ago, SolRayz said:

In all fairness, only one addon from A2A, and only one addon from PMDG, is available at this current time. Not to mention Orbx, only Global, LC, and Regions released. Who knows when the rest will be. 

Barely 2 weeks in....that's more than fair to me, and I have not been bored at all. Plus the only expense out of all I have in add-ons was for the new FSUIPC, everything else was a fast free upgrade.

BTW the PMDG 744 and the 777 are both already out...737 is next.....this is very fast customer service at its best.

  • Upvote 1

Share this post


Link to post
53 minutes ago, Lenny777 said:

Huh? Virtually all my payware airports have been ported over. And that's a lot. All Orbx over. PMDG 777 over. My beloved Duke ported over. ActiveSky ported over. I can use my Rex Overdive textures and all. MyTraffic over. EFASS NG over. This week supposed to be PMDG 737NG over. Not sure what you're talking about. Easily forgetting OLD 32 bit 3.4 and it's OOMs.

Literally nothing there is officially supported...

Share this post


Link to post

Why do you care if something is "officially supported" or not? In 70% of cases it will simply be repacked to new installer where instead of pointing to p3d folder manually it'll do the job automatically. Not a big difference to me. 

Share this post


Link to post

I don't see what's the benefits of holding off for a month or so if most addons are on their way to V4 which mean at the end I will get it. So I suppose get it now, get it tweaked, ready, and enjoy whatever avaliable.

  • Upvote 2

Share this post


Link to post

I am having a blast loading things into my new platform and giving them a go. As new items become compliant, then it is fun getting that loaded into the sim and watching it evolve. If people want to wait, then wait, but for many of us, it is a process of building the platform up.

  • Upvote 1

Share this post


Link to post

A month. My timeline is "maybe" this time next year. Mine looks great,runs great, most planes are collecting dust and most Orbyx sceneries are unexplored or rarely used. Whats the point? I can understand someone running the advanced airliners and will settle for nothing but slammed right sliders or running 3 monitors at Cern level speeds.

I would rather have 2 root canals done through my ear in a dark alley by a wino than reinstall all my addons.

Share this post


Link to post

I didn't wait and couldn't be happier.  PMDG 747, A2A 172, ORBX, AS4, ASCA, PTA, MT6a, Flightbeam, FSdreamteam, ENVTEX, smooth 30FPS, no CTD's, and no OOM's.  Ya probably should have waited. 

  • Upvote 2

Share this post


Link to post

Hi,

kinda funny, now that nearly everyone (at least it felt to me) waited for an FSX based 64bit simulator that would be backwards compatible so the community could use all their old FSX add ons. Well now almost 14 days ago LM delivered it and now one should hold off for a few weeks? Why?

I see it that way that we play a major part in the development of Prepar3d. Only the community can give viable information of what works or not and what needs to be overlooked or enhanced. The bunch of betas and 3rd party devs who work close with LM cnt give as much information as the community can.

Now on the bottom line if we all would hold off v4 development could stagnate or could move slower ahead. I for myself bought it and i was very astonished that lots of add ons worked right away with the sim. Not only that even that some usual add ons like AS16, PMDG, basic ORBX stuff, FSDT and FB etc was available almost within a few days after release. To me it looks like they are faster with v4 support than with support for any other version before.

Well at the end everyone must make his/her own choice. Anyway thanks for sharing your thoughts.

  • Upvote 1

Share this post


Link to post

I'm being cautious with installing anything into V4.  So far only the ORBX regions and both the RealAir Duke and Lancair V2 versions.  Also EZDOK V2 beta.  Only 1 odd crash about a week ago but all good so far.

I'm reluctant to install Wx and traffic apps and really don't need them anyway.  I may install these at a later date but only after my ORBX airports have been tested out.

Moral of the story is to go slow and test all addons out individually before adding another.  So in my case I won't add any other addons until EZDOK is in production release and fully tested.

 

Cheers
bs

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this