ryanbatcund

Why are some Scenery entries greyed out?

Recommended Posts

I'm having an issue where P3D crashes to the desktop without any reason when I get in the proximity of KTNP airport.  It's the addon payware scenery by 29Palms.

It used to work fine.  Recently I installed Lorby's scenery organizer and I noticed when I go into the default P3D scenery setup the option is disabled.  I can't even deselect the TNP scenery.  Anyone know why these sceneries are grey?  And anyone have an idea why the sim will CTD in the vicinity of TNP?

 

27529679088_4f2fe2e212_o.jpgscenerygreyed by ryan b, on Flickr

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

They are grey because they are locked in place  by their installer, usually the addon xml. This is normal - you can move them or disable them using the xml file but not in the scenery lib.

As to why P3D crashes there - not a clue. Disable the addo xml that installs it ( use Lorby's tool) and see if the CTD goes away.

Vic

Share this post


Link to post

The greyed out sceneries have been installed using the addon.xml method. The others have been installed directly into the scenery.cfg file. 

Share this post


Link to post

Yeah I did that - it's definitely an issue with the payware scenery.  Disabling loads the Orbx SCA version fine.

In fact I even was able to slew to the photoscenery area of TNP and was okay until the airport itself loaded, then CTD.

Share this post


Link to post

What apps/module is listed in the CTD as the error Ryan? Can you disable all static aircraft and shut down traffic and services in that airport and retest?

Regards

Steve

Share this post


Link to post
Posted (edited)

you can access them in the menu bar..look in the addons entry and they are listed there.

 

 cheers

   steve

Edited by steve howlett

Share this post


Link to post

 

5 hours ago, ryanbatcund said:

It used to work fine.  Recently I installed Lorby's scenery organizer and I noticed when I go into the default P3D scenery setup the option is disabled.  I can't even deselect the TNP scenery.  Anyone know why these sceneries are grey?

Addon.xml based scenery references can't be managed with the P3D scenery library dialog, never could. They have always been grey, even back in P3D V3. Which is one of the reasons why the P4AO tool exists, you can do all of that (enable, disable, reorder) with the tool.

Best regards

Share this post


Link to post

Do you have the “high resolution texuters” unticked in the display options? If so, tick and try. I used to have unexplained ctds and doing so fixed it.

Share this post


Link to post

What is shown in your Windows logs as the reason for the crash?

Share this post


Link to post

Nothing new with the gray entries

REQUIRED=TRUE

was even in FSX scenery.cfg.

 

Share this post


Link to post

Ryan, here's a tip for you.

While using the Lorby's tool, save your add-on.xml scenery to "scenery.cfg". It will make the scenery "more" available.

And see if that cures the problem.

Cheers

Pierre

 

Share this post


Link to post
3 hours ago, Slayer said:

What is shown in your Windows logs as the reason for the crash?

Nothing 

Share this post


Link to post
8 hours ago, ppo said:

Ryan, here's a tip for you.

While using the Lorby's tool, save your add-on.xml scenery to "scenery.cfg". It will make the scenery "more" available.

And see if that cures the problem.

Cheers

Pierre

 

I didn't know it was possible...Thank you for that.

Regards,

Share this post


Link to post
6 hours ago, ryanbatcund said:

Nothing 

In your event viewer are you getting some kind of esent error?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now