IanHarrison

Windows update

Recommended Posts

Yesterday Nov.20. my P3D v4 was working fine.

This morning Nov 21, I find that Windows has updated overnight and now my P3D will not start at all.

Anyone any ideas on what Microsoft have changed or what has happened?

Ian Harrison

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I came here searching for inspiration for a solution to my p3dv4 crashes that started happening overnight. I think I found it in your post. Windows update probably changed something that made p3d v4 unstable. I haven't installed or changed any configuration on my pc to warrant these crashes all of a sudden. 

However, I do not have any problems starting p3d - the problem shows itself only after a couple of hours when the sim quits on me. 

Share this post


Link to post

Would be great if anyone has some insight, same happend to me. 

Share this post


Link to post
3 minutes ago, Johnny19 said:

Would be great if anyone has some insight, same happend to me. 

And when you say the same happened to you, do you mean you can't start the sim, or that it crashes after a while?

Share this post


Link to post

I just updated my nvidia drivers (13th nov version). I don't know if it will help. 

Share this post


Link to post
18 minutes ago, Andreas Stangenes said:

And when you say the same happened to you, do you mean you can't start the sim, or that it crashes after a while?

Crashed three times since. Froze when i started to watch a movie in default windows player, and just quit with no error mid flight twice. Also there were sessions where there was no problem. Go figure!

Share this post


Link to post

You could delete the Prepar3d cfg file and let it rebuild a new one if worst comes to worst. I've been running Windows 10 version 1809 since it's initial release in October with a subsequent updates and P3D and Xplane run fine. I'm on an i5 6600K, 16GB DDR4,  GTX 1080.

Share this post


Link to post

I've found that some Windows updates have a nasty habit of altering USB settings.

Try checking in Device Manager\USB Controllers\Properties (of each controller)\Power Management.

You may find that the power to turn off option is ticked.  Untick any that you find. 

Share this post


Link to post

I have no problems with that new Win10 version. I installed it last week nothing better, nothing worse with P3Dv4.3. As usual, every machine reacts different.

Share this post


Link to post
29 minutes ago, Jonahbird said:

I've found that some Windows updates have a nasty habit of altering USB settings.

Try checking in Device Manager\USB Controllers\Properties (of each controller)\Power Management.

You may find that the power to turn off option is ticked.  Untick any that you find. 

Checked, and nothing had changed.

Share this post


Link to post

I have not had a problem since the update, could be an addon you run with P3D has the problem with the update try turning them off.

Share this post


Link to post

Resolved.

Still don't know what happened but the "good ol' delete generated files" did the trick and now we are back with a starting P3D.

Share this post


Link to post

That will explain why my USB hub just stopped working with four of the cables! Absolutely first class!!

Share this post


Link to post

All if the issues I have with Windows updates revolve around nVidia drivers.  After I get through the issues I 'clean' install the latest version driver only.  

 

Regards
bs

Share this post


Link to post

I do not have any problems as I refuse to update Windows even though that is not a wise thing to do, it keeps me from endless headaches every time W10 needs updating and causing P3D issues. 

However - why cannot LM move forward and address the issues with windows updates as soon as the updates are released? P3D is the only program I have ever had an issue with, with Windows Updates on almost all updates. In my opinion, LM really ought to create a section of their team that primarily focuses on Windows updates and making P3D compatible with the latest updates, as well as that - create a program which can automatically update P3D without having to delete generated files and or un & re-install the Client. We are a month and a half away from 2019, an easier process is much needed! 

Share this post


Link to post
14 minutes ago, shamrockflyer said:

as I refuse to update Windows

+++1, same here. Version 1607 and still running with no problems!

Edited by vc10man

Share this post


Link to post

Windows gives you the option to turn upgrades off or to get notifications.  There is an option to turn off additional software / driver updates with a general Win 10 update also.  Drivers will always be the big thing.  I need to be current but am watchful.

Cheers
bs

Edited by bean_sprout

Share this post


Link to post
8 minutes ago, bean_sprout said:

Windows gives you the option to turn upgrades off or to get notifications.  There is an option to turn off additional software / driver updates with a general Win 10 update also.  Drivers will always be the big thing.  I need to be current but am watchful.

Cheers
bs

Hi, can you post some information on how to do this in Windows10, as I have been unable to figure this out. Turned off in Services simply gets turned on again after the next boot up.

Share this post


Link to post

Sure Howard - if you have a search / Cortana on you taskbar type updates.  On the Windows Update screen click the Advanced options.  These are the options you have for Windows Update.

Cheers

Share this post


Link to post
6 minutes ago, bean_sprout said:

Sure Howard - if you have a search / Cortana on you taskbar type updates.  On the Windows Update screen click the Advanced options.  These are the options you have for Windows Update.

Cheers

I can't remember how, but I did turn off automatic display driver updates. I'm still at 388.13, which work well for me.

However, I have the HOME version and I cannot 'refuse' the other Windows 10 updates as you can with the PRO version.

Edited by flyblueskies

Share this post


Link to post
1 hour ago, bean_sprout said:

Sure Howard - if you have a search / Cortana on you taskbar type updates.  On the Windows Update screen click the Advanced options.  These are the options you have for Windows Update.

Cheers

You can disable device driver updates, but you can't disable updates in general under Windows 10.
You can also postpone updates.  But not disable them.

Has that now changed? 

Edited by Mace

Share this post


Link to post
1 hour ago, flyblueskies said:

I can't remember how, but I did turn off automatic display driver updates. I'm still at 388.13, which work well for me.

However, I have the HOME version and I cannot 'refuse' the other Windows 10 updates as you can with the PRO version.

I have Win10 Pro.  If I can refuse updates I want to know how that is done :)  (!)  I only know of refusing device drive updates (mine is set to do that, so I don't get a magical nVidia x-mas present next time I boot my sim) -- or postponing /delaying updates. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now