pmb

Blurries under Prepar3d4 - and how I got rid of them

Recommended Posts

Hi,,

this is NOT a plea for help but rather I want to give others a hand who happen to run into a similar issue.

My Prepar3d4.4 was running quite well until 10 days ago. That was the point where I started to come to terms with ORBX TE GB South. After endless modifications of settings, I ended up with mixed results. Next time I took off from my testbed, KSFO and the Bay Area, I got shocked, notably about the blurry roads.

Blurries_Bay_Area_Prepar3d.jpg

To make a long story short, this was NOT caused by ORBX breaking my system. Neither were these the "common" blurries clearing up after a couple of seconds. The latter are nearly always caused by your system - and mostly your CPU - not keeping up. Mine didn't clear up.

I am not going to list all the hoops I jumped through including deactivating all scenery, reinstalling Client, reinstalling Contents (yes), deleting all settings files, switching Hyperthreading on/off etc. - to no avail.

I didn't expect it, but the solution was in the Nvidia Control Panel which I had toyed with as well. I already had tried to reset all Prepar3d 3D settings to the default before. Just by chance, I had a glimpse on the Global Settings to detect that Anisotropic Filtering was Off instead of the default Application controlled which setting was transferred to Prepar3d  (and supposedly more was broken). So I just reset the Global plus the Prepar3d specific 3D settings to their Nvidia defaults - to find all crisp again.

Just in case someone runs into this, too, it's something very simple to try. 

Kind regards, Michael

  • Like 7
  • Upvote 2

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hello, Michael. Thanks for posting this. I didn't have a blurries issue, But, you did make me check my NVIDIA control panel and It was set the way that you recommended. Very useful info, incase I ever run into it.

Thank you!

Mike

Share this post


Link to post

Hi Michael

Thanks for sharing.

I was curious if you had made the changes to the Nvidia Control panel settings you refer to and forgot and if so were they in your efforts to improve the Orbx scenery? I assume these can be light switched on your system to cause the blurry issue.

Glad you figured out your issue, this hobby is always testing our problem solving skills. Something I actually don’t mind as an engineer as long as its not too frequent and can ultimately be solved.

Joe

Share this post


Link to post
7 minutes ago, joepoway said:

Hi Michael

Thanks for sharing.

I was curious if you had made the changes to the Nvidia Control panel settings you refer to and forgot and if so were they in your efforts to improve the Orbx scenery?

I don't think so. I can't recall setting AA to off by intention under the Global Settings. (And, maybe, there were even more settings wrong which I didn't check before hitting the Nvidia button.)

I tried to set energy saving for Prepar3d only from optimum performance to maximum for ORBX TE, which someone suggested but didn't help a iota. Plus, I recall , I was in the NCP for setting DSR in the hope to mitigate shimmering under X-Plane a few days ago. DSR has to be set in the Global Settings and maybe I just was unlucky to press a wrong entry in the list by accident as well.

Kind regards, Michael

Share this post


Link to post

Great heads-up, Michael. Kudos to you.

Share this post


Link to post

Restore/Apply fixes so many problems I never start debugging without performing a Restore/Apply as I always mention it is worth doing before messing around in P3D or FSX.

  • Like 1

Share this post


Link to post
On 2/18/2019 at 7:27 PM, pmb said:

 

I didn't expect it, but the solution was in the Nvidia Control Panel which I had toyed with as well. I already had tried to reset all Prepar3d 3D settings to the default before. Just by chance, I had a glimpse on the Global Settings to detect that Anisotropic Filtering was Off instead of the default Application controlled which setting was transferred to Prepar3d  (and supposedly more was broken). So I just reset the Global plus the Prepar3d specific 3D settings to their Nvidia defaults - to find all crisp again.

 

Hi Michael,

Just checked my Nvidia control panel P3D settings, just to be sure. There, I found...

Anisotropic filtering        16x 

 

While at it, I figured I'd check Nvidia Inspector to see what was over on that side....I found there are -2- settings for P3D....

Anisotropic filtering mode          User-defined / Off

Anisotropic filtering setting         16x

 

I'm guessing you're referring to what ends up as Anisotropic Filtering setting. But, for the heck of it, if you run Nvidia Inspector, what is your setting there for mode??

Thanks,

Mike

Edited by orbmis

Share this post


Link to post

In the control panel, 3d settings, select the global profile and restore/apply it. If it's already grey, as if no changes were made to it, even so, make a setting, save it, then go back and restore/apply. Then do this (which seems pointless) with the P3D profile as well.

From here we can make the settings we desire in the global or in the P3D profile.

 

With P3D it is best to stick with the P3D Display Settings window in P3D for all settings, unless absolutely necessary to make changes in NCP.

 

Regarding the reason to restore/apply is that this definitely ensures the tables under the hood are in order. These can become confused even though a driver has been recently installed. That can happen simply because a driver is updated and an error in the profile may not be evident even though the settings look right. Restore/Apply first, and then make settings. It's just a precaution.

  • Like 1

Share this post


Link to post
2 hours ago, orbmis said:

I'm guessing you're referring to what ends up as Anisotropic Filtering setting. But, for the heck of it, if you run Nvidia Inspector, what is your setting there for mode??

 

Mike,

in my case it was the first entry under the global settings "Anisotropic Filtering" which was "off", why ever, but should be "application controlled".

Generally, Steve is completely right, though, do what he says and you''ll be on the safe side.

Kind regards, Michael

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now