GEKtheReaper

P3D v4.5 Add-On Compatibility List

Recommended Posts

Posted (edited)

Hello guys,

up to this point I did not find any P3D v4.5 Compatibility List. I propose this thread to list the known Add-On's that are compatible with P3D v4.5.

I'm personaly interested in:

*Environment*

FS Global Ultimate NG

GEP3D

REX Airports HD

ORBX Trees HD

ENVTEX

ENVSHADE

ASPv4

ASCA

VFX Tools: PrecipitFX / 737 Immersion

 

*Aircraft*

PMDG 737 NGX

FSL A319 / A320

AS CRJ 700/900

 

*Tools*

GEX Level 1 and Level 2

EZCA v2

 

*Traffic*

UTLive

 

Edited by GEKtheReaper
Tipo

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

ENVDIR / ENVTEX / ENVSHADE updated acc. to TOGA projects forum page:

Changelogs:

• Envdir | Version 1.2.0.4
- Compatibility update for Envtex 1.2.2 and Envshade 1.0.7
- Installation process optimized (50% faster compared to previous version which was already 70% faster)
- ASCA weather influence settings backup not working properly fixed
- Restore function optimized
- Minor issues fixed

• Envtex | Version 1.2.2
- Compatibility update for Prepar3D v4.5

• Envshade | Version 1.0.7
- Compatibility update for Prepar3D v4.5
- Adjusted HDR night lighting for better nights
- Adjusted night rendering for better nights

Share this post


Link to post

PSXseeconTraffic is compatible.

Nico

  • Like 1
  • Upvote 2

Share this post


Link to post

So far.............

ASP4 - Yes (needs update to latest beta)

REX SF3D - Yes

Black Marble (all) - Yes

UK2000 Airports for P3D v4 - Yes

Aerosoft Airbus Pro - Yes

PMDG 737NG - Yes

UT Live - Yes

Chaseplane - Yes (works, but a couple of items to be updated)

FS2Crew Reboot - Yes

GSX Level 2 - Yes

 

Share this post


Link to post

Compatible:

PTA

Active Sky

Aerosoft (I have asked about compatibility on their forum and they said that all of their planes are compatible without updating them)

Share this post


Link to post

FSLabs have commented on their forums saying that the A320 wont work on v4.5 and requires the new update that they'll be releasing soon

Share this post


Link to post
1 hour ago, Nickbe said:

EZCA 2.8 - compatible with P3D 4.5 - will be around in a week.

This is great news. THANK YOU!

Share this post


Link to post
Posted (edited)
6 minutes ago, YoYo said:

Chaseplane?

Works fine with update

Spoiler
Spoiler

 

 

 

Edited by MPL
  • Like 1

Share this post


Link to post
14 minutes ago, MPL said:

Works fine with update

  Reveal hidden contents
  Reveal hidden contents

 

 

 

Thx!

Share this post


Link to post

For those that fly in VR, the Aerosoft Bus will crash P3D4.5 upon enabling Oculus Rift.  This might be off topic but thought I'd throw it out there....

VR works fine in 4.5 with stock aircraft, and with PMDG 737.  But the Aerosoft bus will crash it every time. 

Share this post


Link to post
Posted (edited)
27 minutes ago, davetfc said:

Just for your information, the current open beta of Active Sky (ASP4) B7035 is not compatible with the latest v4.5 of P3D (see attached images).

Are you sure you're running 7035?  There's a weird issue on the download page at HiFi.  Where you see the hyperlink text "Download Link", if you click on "Download" you get a different file than if you click on "Link".  For other downloads (like for Cloud Art) this is one hyperlink, not two.  According to discussions on the HiFi forums, the one to choose is "Download" not "Link".

Scott

 

Edit: See this post... https://hifisimtech.com/forums/showthread.php?10605-AS-7013-not-compatible-with-P3Dv4-5&p=48652&viewfull=1#post48652

 

Edited by tttocs

Share this post


Link to post

Even though our friend tttocs is a Cubs fan (lol guess who my team is) he is spot on.  Beta 7035 is absolutely compatible with v4.5.

  • Like 1

Share this post


Link to post

There is a new version of FFTF Dynamic (1.5), but if you can get it to run, you are a better person than I am.

Share this post


Link to post
9 minutes ago, jabloomf1230 said:

There is a new version of FFTF Dynamic (1.5), but if you can get it to run, you are a better person than I am.

So it is not just me! I raised a support ticket with them.

Mark

Share this post


Link to post

Hi,

Both the genuine Reality XP GTN 750/650 Touch and the genuine Reality XP GNS 530/430 V2 for FltSim are always compatible with any future 4.x P3D4 version* and we've just released new updates compatible with the P4D v4.5 autopilot (v2.5.16 and v2.4.11 respectively).

*unless Lockheed Martin is breaking gauge compatibility with the SDK in a 4.x update. Note: although the autopilot needs a specific GTN and GNS V2 update for each new Prepar3D 4.x update, the Reality XP gauges are designed to be P4D4 future-proof for all their other features..

  • Like 5

Share this post


Link to post
2 hours ago, mwa05 said:

So it is not just me! I raised a support ticket with them.

Mark

Me too. Haven't heard anything from them however.....

Share this post


Link to post

Yep added my voice to FSPS not working either even after there new update.

Share this post


Link to post
Posted (edited)

I'm getting CTD with PMDG 777 and Majestic Q400. Anyone else?

 

Edit: Cancel that......... delete your P3D cfg people! 😅

Edited by mdreyer

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now