SledDriver

Out of nowhere... DXGI-ERROR_DEVICE_HUNG crash

Recommended Posts

Minding my own business testing out things to get a smooth sim when this ugly error crashed the sim, twice now. Seems totally unrelated to what I'm doing in the sim stress wise.

Looking through the forum, I see its happened before and the fix was to update to the latest GeForce drivers. Well I did that and it's still happening.

Anyone know how to fix this?

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I hate to say there is no specific fix since it can be caused by various issues. You will hear many solutions soon I’m sure and maybe one of them will work but this is not a one issue one solution problem. There are several posts that have gone on for months you can read through.

Good luck

Joe

Share this post


Link to post
Share on other sites

Do you use Nvidia inspector? I stared getting these last year after one of their driver updates but I used NI for FPS limiter.  Disabling NI fixed the problem.....but if you aren't using NI than this won't help😄

Share this post


Link to post
Share on other sites

It happens with certain graphics driver versions. I used to have this problem, testing different drivers the Nvidia 417.22 fixed it. Since then no more hangs and i don't update the driver unless it is absolutely needed.

Share this post


Link to post
Share on other sites

NI is installed, but isn't running.

I'm using RTSS in frame limited mode as the sync limit doesn't seem to want to work here.

 

Share this post


Link to post
Share on other sites
2 minutes ago, Aeronildo said:

It happens with certain graphics driver versions. I used to have this problem, testing different drivers the Nvidia 417.22 fixed it. Since then no more hangs and i don't update the driver unless it is absolutely needed.

What I'm reading seems to suggest later drivers cause the problem. It first happened here on 419.67 after several happy weeks on P3D as a newbie, so I updated to 425.31 and the problem continues. It's rare, but annoying.

Share this post


Link to post
Share on other sites

What type of cable are you using between your monitor and video card?  I had a few of these abominable crashes last year after I upgraded my monitor... and went to a DisplayPort cable.  Went back to an HDMI cable and no problems since.

HTH or I'm just lucky,

Greg

Share this post


Link to post
Share on other sites

I know this is a long shot but I had this problem no matter what driver and it happened after 4.4 update (not sure if coincidence). I read somewhere that these new video cards these days are heavy and can lose good connection if they are just hanging into the slot with no support. I reseated my card and ever since, it’s been ok. There was also a .net update version I was missing that I had updated the same day too though so I’m not 100% which (or if either) truly fixed it. 

Share this post


Link to post
Share on other sites
15 hours ago, SledDriver said:

Minding my own business testing out things to get a smooth sim when this ugly error crashed the sim, twice now. Seems totally unrelated to what I'm doing in the sim stress wise.

Looking through the forum, I see its happened before and the fix was to update to the latest GeForce drivers. Well I did that and it's still happening.

Anyone know how to fix this?

 

do you have a 1080ti by any chance?  are you overlocking your gfx card ?

Share this post


Link to post
Share on other sites
2 hours ago, tooting said:

do you have a 1080ti by any chance?  are you overlocking your gfx card ?

I was just about to say this. Overclocking the video card is a major cause.

Share this post


Link to post
Share on other sites
Posted (edited)

On my GTX 1080Ti overclocking did that, I reduced it with 100MHz (offset to the GPU clock and MEM clock) and it is usually stable. Still, sometimes I get a CTD without any error message, I suppose still due to overlock, overload of GPU or due to switching the focus between my 2 monitors.

Sometimes the driver can get also corrupted(but rare).

Edited by Vali

Share this post


Link to post
Share on other sites

This turned out to be a dying video card for me. 

Replaced with a 1080ti and all is well.

Cheers,

Mark

Share this post


Link to post
Share on other sites
2 hours ago, Vali said:

On my GTX 1080Ti overclocking did that, I reduced it with 100MHz (offset to the GPU clock and MEM clock) and it is usually stable. Still, sometimes I get a CTD without any error message, I suppose still due to overlock, overload of GPU or due to switching the focus between my 2 monitors.

Sometimes the driver can get also corrupted(but rare).

i have a 1080ti and using asus gpu tweak II used to give me this ctd.  I no longer use gpu tweaK and the issue is gone

Share this post


Link to post
Share on other sites

OK thanks for all the ideas. GTX980Ti ASUS Strix factory overclock here. Never been a problem up til P3D. Maybe it's being pushed harder.

I'll bear in mind all these things when/if it happens again.

Cheers.

 

Share this post


Link to post
Share on other sites
Posted (edited)
22 hours ago, SledDriver said:

Minding my own business testing out things to get a smooth sim when this ugly error crashed the sim, twice now. Seems totally unrelated to what I'm doing in the sim stress wise.

Looking through the forum, I see its happened before and the fix was to update to the latest GeForce drivers. Well I did that and it's still happening.

Anyone know how to fix this?

 

h

Edited by Wennerholm

Share this post


Link to post
Share on other sites
5 minutes ago, Wennerholm said:

It requires an extra sub key entry into the Windows registry, so please only implement if you feel OK with editing your registry!

- Click on the Windows Start button, type regedit in the Search box,double-click regedit.exe from the results above. 
If you are prompted for an administrator password or confirmation, type the password or provide confirmation,
- Browse to and then click the following registry subkey: 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers
- On the Edit menu, click New, and select the QWORD (64-bit) value from the drop-down menu.
- Type ‘TdrLevel’ as the Name and click Enter.
- Double-click TdrLevel and set the value as 0 (it is set to that by default, but double check) and click OK.
- Close the registry editor and restart your computer for the changes to take effect.

Can you give us any info what this is doing?

Double-click TdrLevel and set the value as 0 (it is set to that by default, but double check) and click OK.

If this is the default value anyway, then how does your suggestion make any difference, or have I misunderstood?

Share this post


Link to post
Share on other sites

This has been discussed at length in the AVSIM CTD Forum so moving this there.  Please read some of the pinned topics concerning this issue.

Share this post


Link to post
Share on other sites
Posted (edited)
5 minutes ago, SledDriver said:

Can you give us any info what this is doing?

Double-click TdrLevel and set the value as 0 (it is set to that by default, but double check) and click OK.

If this is the default value anyway, then how does your suggestion make any difference, or have I misunderstood?

h

Edited by Wennerholm

Share this post


Link to post
Share on other sites
3 minutes ago, SledDriver said:

Can you give us any info what this is doing?

Double-click TdrLevel and set the value as 0 (it is set to that by default, but double check) and click OK.

If this is the default value anyway, then how does your suggestion make any difference, or have I misunderstood?

The TdrLevel  is not std input.

Share this post


Link to post
Share on other sites
Posted (edited)

Ok Ta.

Does this apply to my 980Ti too?

 

Edited by SledDriver

Share this post


Link to post
Share on other sites
1 minute ago, SledDriver said:

Ok Ta.

Does this apply to my 980Ti too?

 

I have stolen the text from P3D forum. I don´t know but it works for me 1080 Ti.

Share this post


Link to post
Share on other sites

I can't say for sure that I have solved the problem but this is what I did:  I was getting the DXGI error on almost every flight.  Tried about all the suggestions to fix it.  Tried the latest drivers and the older drivers - no joy.  My CPU was slightly overclocked so I undid the OC and put it back to the original configuration.  The second thing I did was to disable the NVIDIA  High Definition Audio in the Device Manager.  Am operating with the Realtek High Definition Audio selection.   Haven't had the DXGI error since changing these two things.  Been about a month now.  I know I'll probably get the error as soon as I post this.   Many times before I thought I had it fixed only for it to re-occur.   So far so good.

Jim 

I7 6800K 3.40 Ghz                                                                                                                                                                                                         GTX 1080

 

  • Like 1

Share this post


Link to post
Share on other sites
22 minutes ago, planenut said:

Many times before I thought I had it fixed only for it to re-occur.   So far so good.

Thanks for passing the information to our membership!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now