Jump to content
Sign in to follow this  
styckx

I'm over it - AI Piloting enables itself every flight

Recommended Posts

So the other day I decided. Hey Bill, can't hurt to try AI Piloting just to see how it works and if it's even any good at it.

WRONG

EVERY-SINGLE-FLIGHT it's enabled again.  

Turn it off. Exit. Quit to desktop. Restart sim. Start flight..  It's enabled again

Go to AI options, set piloting BACK to hard (since it always reverts to custom), save, exit sim. Restart. Start a flight. IT"S ENABLED AGAIN

I Googled and see this is a problem dating back to AUGUST with no fix in sight.  Despicable. 

It used to be with simming you fought addons being up to date with the sim. Now I'm fighting the sim to be up to date with itself.  

I'm done for awhile. 


ASUS ROG STRIX Z390-E GAMING / i9-9900k @ 4.7 all cores w/ NOCTUA NH-D15S / 2080ti / 32GB G.Skill 3200 RIPJAWS / 1TB Evo SSD / 500GB Evo SSD /  2x 3TB HDD / CORSAIR CRYSTAL 570X / IPSG 850W 80+ PLATINUM 

Share this post


Link to post
Share on other sites
2 minutes ago, styckx said:

So the other day I decided. Hey Bill, can't hurt to try AI Piloting just to see how it works and if it's even any good at it.

WRONG

EVERY-SINGLE-FLIGHT it's enabled again.  

Turn it off. Exit. Quit to desktop. Restart sim. Start flight..  It's enabled again

Go to AI options, set piloting BACK to hard (since it always reverts to custom), save, exit sim. Restart. Start a flight. IT"S ENABLED AGAIN

I Googled and see this is a problem dating back to AUGUST with no fix in sight.  Despicable. 

It used to be with simming you fought addons being up to date with the sim. Now I'm fighting the sim to be up to date with itself.  

I'm done for awhile. 

I am glad I have had zero interest in AI piloting. Looks like a good thing to avoid. 


spacer.pngBob Cardone         MSFS 2020 , Kodiak 100,  PMDG DC6,    Carenado Seminole, Simple Traffic  

TrackIR   Avliasoft EFB2    ATC  by PF3    FlyVirtual.net  CLX PC

 

 

Share this post


Link to post
Share on other sites
2 minutes ago, Bobsk8 said:

I am glad I have had zero interest in AI piloting. Looks like a good thing to avoid. 

Yeah it's absolutely infuriating. I'm over this sim. Complete amateur hour development 

https://forums.flightsimulator.com/t/how-do-i-start-a-flight-with-ai-piloting-off/435529

Edited by styckx

ASUS ROG STRIX Z390-E GAMING / i9-9900k @ 4.7 all cores w/ NOCTUA NH-D15S / 2080ti / 32GB G.Skill 3200 RIPJAWS / 1TB Evo SSD / 500GB Evo SSD /  2x 3TB HDD / CORSAIR CRYSTAL 570X / IPSG 850W 80+ PLATINUM 

Share this post


Link to post
Share on other sites
7 minutes ago, styckx said:

So the other day I decided. Hey Bill, can't hurt to try AI Piloting just to see how it works and if it's even any good at it.

WRONG

EVERY-SINGLE-FLIGHT it's enabled again.  

Turn it off. Exit. Quit to desktop. Restart sim. Start flight..  It's enabled again

Go to AI options, set piloting BACK to hard (since it always reverts to custom), save, exit sim. Restart. Start a flight. IT"S ENABLED AGAIN

I Googled and see this is a problem dating back to AUGUST with no fix in sight.  Despicable. 

It used to be with simming you fought addons being up to date with the sim. Now I'm fighting the sim to be up to date with itself.  

I'm done for awhile. 

Thanks for the warning! I hope they'll fix it soon. Was it ever mentioned in the weekly bug list presentation?

Edited by Nemo

- Harry 

i9-12900K (12 Cores, 16+8 Threads, max 5.2 GHz, Aorus X 360 AIO H20, ASUS Z690 ROG Strix F), 32 GB RAM (DDR5 5200, CAS 38), RTX 3090 (Alpacool Eiswolf 360 AIO H2O).  Windows 11 Pro (1TB M.2 SSD C drive).  MSFS 2020 (MS Store, installed on C, MSFS Content on seperate 2TB M.2 SSD).   P3Dv5.3 (1TB M.2 SSD).

 

 

 

Share this post


Link to post
Share on other sites

For the record. AI Piloting is awful. It stuck the landing about as well as a rock being dropped from a 3 story building and porpoised down the runway 

Edited by styckx

ASUS ROG STRIX Z390-E GAMING / i9-9900k @ 4.7 all cores w/ NOCTUA NH-D15S / 2080ti / 32GB G.Skill 3200 RIPJAWS / 1TB Evo SSD / 500GB Evo SSD /  2x 3TB HDD / CORSAIR CRYSTAL 570X / IPSG 850W 80+ PLATINUM 

Share this post


Link to post
Share on other sites
37 minutes ago, styckx said:

Turn it off. Exit. Quit to desktop. Restart sim. Start flight..  It's enabled again

Nasty AI pilot, some have such an urge to assert.


Eric from EHAM, a flying Dutchman

Share this post


Link to post
Share on other sites

I have had this same behavior but with the AI Radio assist option. You put power to the aircraft and 2 seconds later the AI guy is on the horn asking for pushback. Apparently no preflight is necessary. I had to start checking the Assist options every time before beginning a flight. This sim is good for helping  me practice patience!


Dan Scott

Share this post


Link to post
Share on other sites

Same happened here! I was wondering why the Autopilot kept disconnecting!


i9-11900K | 64 GB RAM | RTX 3090

B747-400/800 Pilot

 

Share this post


Link to post
Share on other sites

All the assistance settings are reset e every time you start the sim again.

You just have to switch all the parameters to your discretion before departure. I integrated it into my checklists.

Share this post


Link to post
Share on other sites
1 minute ago, PTI139 said:

All the assistance settings are reset e every time you start the sim again.

You just have to switch all the parameters to your discretion before departure. I integrated it into my checklists.

I only get assistance resets if I go into the content manager. As long as I don't enter the content manager, my setting stay the same over multiple sessions.

It's an odd issue, doesn't seem to effect everyone the same.

Edited by Tuskin38
  • Upvote 1

Share this post


Link to post
Share on other sites

Yes I think youre kind of right.

I assume it has something to do with the content being changed - for example if you add scenery to the community directory maybe by changing things in addon manager app - then it is not synchronized with the content.xml.

Last time the assistance reset kerfuffle occurred again frequently after I deleted two asobo sceneries in the content manager (LOWI and LSZH, that I own as payware and which reinstalled themselves by an update). But after that I have the phenomenon everytime I start the sim (without changing content).

 

Share this post


Link to post
Share on other sites

I used the AutoPilot the other day, flew a 747 from Charlotte to Key West.

Pilot was able to take off and fly the whole trip unassisted, but he overran the end of the runway on takeoff. At Key West he landed late and ran off the runway there too.

But the opposite happened to me aftermath.

For my next flight I selected the Volocopter, but when I went to activate the autopilot, it wasn't in the menu bar anymore, and I can't find it now.

Share this post


Link to post
Share on other sites

Those who get settings switched to "easy", are you spending a lot of time in the "Market Place"? Just recently there was a problem with settings going "easy" after every visit to the MP.

edit* sorry it's the Content Manager, not Market place.

Edited by jimcarrel

Intel(R) Core(TM) i7-10700F CPU @ 2.90GHz (8 cores) Hyper on, Evga RTX 3060 12 Gig, 32 GB ram, Windows 11, P3D v 5, and MSFS 2020 and a couple of SSD's

Share this post


Link to post
Share on other sites

Dev mode turns assistance options on for me, but I have not had the AI options activate on their own.

I can say with 100% certainty that I never go into either marketplace or content manager, so that may be why I haven't seen it and you guys have. 

Share this post


Link to post
Share on other sites

So I figured out how to stop this ridiculous bug. 

Upon starting a flight I had to turn off AI Piloting as usual.

The key to make it stick for all future flights. Saving the flight after turning the dreaded AI Piloting off from the toolbar. Then loading the flight you just saved and then exiting the flight.  Now I can start the sim and create a flight without the AI Piloting automatically turned on. What an absolute circus of development. 

  • Like 2
  • Upvote 1

ASUS ROG STRIX Z390-E GAMING / i9-9900k @ 4.7 all cores w/ NOCTUA NH-D15S / 2080ti / 32GB G.Skill 3200 RIPJAWS / 1TB Evo SSD / 500GB Evo SSD /  2x 3TB HDD / CORSAIR CRYSTAL 570X / IPSG 850W 80+ PLATINUM 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...