Jump to content
Sign in to follow this  
vonduck

CTD's all the time now!

Recommended Posts

2 minutes ago, odourboy said:

Well that was short lived... three 0xc0000005 crashes this morning. Ugh.

Nah. Empty all of from community folder, uninstall all 3rd party addons including from the marketplace first.

That exception, I am sorry to say, is one of the worst but also related to addons. I would venture to say its an addon (scenery or otherwise) that is conflicting with another addon causing the CTD. Even if the scenery is nowhere near the other one it can apparently cause this.


Hero X--8086k@5.1ghz--32GBddr4--2080ti--Acer GSync 4k Monitor + 1080p Monitor--Honeycomb Alpha/Bravo+Saitek Pedals--Thrustmaster T16000+Throttle. P2ATC, AIG/FSLTL, GSX, 600gb of scenery, PMS/TDI 750, Auto FPS, FG Mod, FSrealistic, FScrewRAAS,RexTextures/Seasons,Navigraph etc

A2A Comanche---Bae146, F28, Arrow(s), BS Bonanza & BS King Air---FSR500--COWS DA42---Fx HJet+VisionJet---FSW 414 +LearJet---FSS E175+P2006T+Analog Version---Fenix 320-------PMDG DC-6+737+9---C22J---Milviz C310+Porter---SWS PC-12, Kodiak, Zenith+RV14---Big Radialsl Goose---IFE MB339+F-35---NextGen EMB----Carenado Seneca + PC12---AS CRJ Series----Asobo ATR---

Share this post


Link to post
Share on other sites
Just now, Sonosusto said:

Nah. Empty all of from community folder, uninstall all 3rd party addons including from the marketplace first.

That exception, I am sorry to say, is one of the worst but also related to addons. I would venture to say its an addon (scenery or otherwise) that is conflicting with another addon causing the CTD. Even if the scenery is nowhere near the other one it can apparently cause this.

If you'd bothered to read this thread before weighing in, you'd see I've already tried those measures.

  • Like 1

13900K@5.8GHz - ROG Strix Z790-E - 2X16Gb G.Skill Trident DDR5 6400 CL32 - MSI RTX 4090 Suprim X - WD SN850X 2 TB M.2 - XPG S70 Blade 2 TB M.2 - MSI A1000G PCIE5 1000 W 80+ Gold PSU - Liam Li 011 Dynamic Razer case - 58" Panasonic TC-58AX800U 4K - Pico 4 VR  HMD - WinWing HOTAS Orion2 MAX - ProFlight Pedals - TrackIR 5 - W11 Pro (Passmark:12574, CPU:63110-Single:4785, GPU:50688)

Share this post


Link to post
Share on other sites

I read your previous thread before that one and you said you flew with all of your regular addons.....

The most interesting aspect is how many people are plagued by this but so many more are not at all.

The last time I had this issue I noticed that whatever I did, the community folder still had content in it (broken links) which I assume is MS/Asobo fault.

Did you fly with a completely default plane? No GNS or anything like that installed? 3rd party planes of any kind? The reason why I ask is because people still end up having something in their folders that they've downloaded. Hence me asking

Edited by Sonosusto

Hero X--8086k@5.1ghz--32GBddr4--2080ti--Acer GSync 4k Monitor + 1080p Monitor--Honeycomb Alpha/Bravo+Saitek Pedals--Thrustmaster T16000+Throttle. P2ATC, AIG/FSLTL, GSX, 600gb of scenery, PMS/TDI 750, Auto FPS, FG Mod, FSrealistic, FScrewRAAS,RexTextures/Seasons,Navigraph etc

A2A Comanche---Bae146, F28, Arrow(s), BS Bonanza & BS King Air---FSR500--COWS DA42---Fx HJet+VisionJet---FSW 414 +LearJet---FSS E175+P2006T+Analog Version---Fenix 320-------PMDG DC-6+737+9---C22J---Milviz C310+Porter---SWS PC-12, Kodiak, Zenith+RV14---Big Radialsl Goose---IFE MB339+F-35---NextGen EMB----Carenado Seneca + PC12---AS CRJ Series----Asobo ATR---

Share this post


Link to post
Share on other sites
On 11/9/2023 at 11:19 AM, odourboy said:

I did: removed all addons and marketplace purchases, turned off traffic and weather, no overclocks, repaired msfs app, triple-scanned the file system, memory check, DX11, no caching, deleted exe.xml. No improvement. 

@SonosustoThere's what I said. In fairness, I do have premium deluxe, which I did not unistall.

Edited by odourboy
  • Upvote 1

13900K@5.8GHz - ROG Strix Z790-E - 2X16Gb G.Skill Trident DDR5 6400 CL32 - MSI RTX 4090 Suprim X - WD SN850X 2 TB M.2 - XPG S70 Blade 2 TB M.2 - MSI A1000G PCIE5 1000 W 80+ Gold PSU - Liam Li 011 Dynamic Razer case - 58" Panasonic TC-58AX800U 4K - Pico 4 VR  HMD - WinWing HOTAS Orion2 MAX - ProFlight Pedals - TrackIR 5 - W11 Pro (Passmark:12574, CPU:63110-Single:4785, GPU:50688)

Share this post


Link to post
Share on other sites
1 hour ago, Sonosusto said:

After a few Windows updates, I noticed that some of my USB settings were changed in device manager. You want all USB devices to NOT turn off to save power. Ie, they are always on if the computer is running. Surprisingly, after longer flights, some of these turned off...causing CTD's for me.

Well, surprisingly, all of my USB devices in Device Manager has the 'Allow the PC to shut down to save power' box checked, as you suggested might have been the case. I remember checking all of these a while back when you had this problem now that I think about it, and they were NOT checked then. So, as you suggest, some Windows update must have checked them. Now, whether or not those are the cause of MY CTD problems since SU13, time will tell. I would be very happy if this is the solution in my case. 

  • Like 1

AMD Ryzen 7800X3D & Gigabyte X670E Aorus Master MB, w/32 Gb GSkill DDR5 RAM, MSI 4090 GPU, lots of SSD's and M.2 drives, Fractal Torrent Case, Virpil VPC MongoosT-50CM3 Throttle, Virpil Constellation Alpha Stick, Thrustmaster TCA Yoke Boeing Edition and MFG Rudder pedals. Currently on Win11

 

 

Share this post


Link to post
Share on other sites
1 hour ago, odourboy said:

@SonosustoThere's what I said. In fairness, I do have premium deluxe, which I did not unistall.

Ah, got it. Thanks. That is crazy, though. I don't think premium deluxe could do anything "off" unless you had some Navigraph data that changed anything with the Longitude etc. or something similar.

I am sure this was asked, but have you rolled back any NVIDIA drivers to a previous version? I know there were several instances where this caused issues. I have the latest version for now but about a few months ago I had to stick to an earlier build. Very annoying.

Question: where/when do these CTD's occur?

Also, I would check the USB issue I mentioned as well.

I REALLY want to help you because I suffered through this as well and it was aggravating. Especially when it was something small that was causing it.

1 hour ago, sniper31 said:

Well, surprisingly, all of my USB devices in Device Manager has the 'Allow the PC to shut down to save power' box checked, as you suggested might have been the case. I remember checking all of these a while back when you had this problem now that I think about it, and they were NOT checked then. So, as you suggest, some Windows update must have checked them. Now, whether or not those are the cause of MY CTD problems since SU13, time will tell. I would be very happy if this is the solution in my case. 

It's very frustrating but I was surprised that this was one of my culprits. It's as bad as unplugging something while flying in the sim from the USB. It has been known to cause CTD's. I had a wired headset that my toddler "removed" from the computer causing the sim to crash. I thought it was pretty funny, actually.

Also, I found that AddOnLinker really helped with managing mods but it also has a function that renames some parts in the folder. It seems like some devs would have similar names in their folders causing crashes. It really helped me as well.

Edited by Sonosusto

Hero X--8086k@5.1ghz--32GBddr4--2080ti--Acer GSync 4k Monitor + 1080p Monitor--Honeycomb Alpha/Bravo+Saitek Pedals--Thrustmaster T16000+Throttle. P2ATC, AIG/FSLTL, GSX, 600gb of scenery, PMS/TDI 750, Auto FPS, FG Mod, FSrealistic, FScrewRAAS,RexTextures/Seasons,Navigraph etc

A2A Comanche---Bae146, F28, Arrow(s), BS Bonanza & BS King Air---FSR500--COWS DA42---Fx HJet+VisionJet---FSW 414 +LearJet---FSS E175+P2006T+Analog Version---Fenix 320-------PMDG DC-6+737+9---C22J---Milviz C310+Porter---SWS PC-12, Kodiak, Zenith+RV14---Big Radialsl Goose---IFE MB339+F-35---NextGen EMB----Carenado Seneca + PC12---AS CRJ Series----Asobo ATR---

Share this post


Link to post
Share on other sites

That USB Power Box was the issue back in the early days of VR for me, for whatever reason the OS thought I wasn't using it when I was so it shut VR down mid game and bang CTD!

So that could well be the issue of it thinks one of your devices isn't being used perhaps (when it is), I'll check mine to see what they say now as I'm not suffering from CTDs.


HP Reverb G2 - Windows 11 64bit, Gigabyte Z590 Aorus Elite Mobo, i7-10700KF CPU, Gigabyte 3070ti GPU, 32gig Corsair 3600mhz RAM, SSD x2 + M.2 SSD 1tb x1

Saitek X45 HOTAS - Saitek Pro Rudder Pedals - Logitech Flight Yoke - Homemade 3 Button & 8-directional Joystick Box, SNES Controller (used as a Button Box - Additional USB Numpad (used as a Button Box)

Share this post


Link to post
Share on other sites
3 minutes ago, MarcG said:

That USB Power Box was the issue back in the early days of VR for me, for whatever reason the OS thought I wasn't using it when I was so it shut VR down mid game and bang CTD!

So that could well be the issue of it thinks one of your devices isn't being used perhaps (when it is), I'll check mine to see what they say now as I'm not suffering from CTDs.

Yes, my CTD's have always happened in VR... suspect that could be the case... if you could let me knwo what you did, that could indeed help... will try another VR flight this afternoon to see if still occurs...

There is no specific time limit on when it CTD's.... once 5 mins before takeoff...then 1 minutes brofe landing after an hour flight... very odd!


i9 13900KF @ 5.5Ghz | MoBo MSI PRO Z690-A WiFi | Corsair Vengeance Black RGB RS 64gb DDR4 3200MHz | PNY RTX 4090 XLR Gaming Verto EPIC-X RGB TF | MP33 Pro 1TB M.2-2280 NVME SSD for OS | Samsung 870 QVO 2.5" 4TB SSD SATA2 | Corsair RM1000X 2021 1000W 80 Plus Gold PSU | Antec Dark Fleet DF700 Flux Gaming Case | Win 11 home | LG 48" C2 OLED 4K TV | G512 Keyboard | Razer Basilisk V2 Mouse | TCA Throttle, Sidestick and addons, peddles, TM1600 Hotas | TrackIR 5 | Tobii Eye Tracker | HP Reverb G2 HMD

Doug 

Share this post


Link to post
Share on other sites
1 minute ago, vonduck said:

Yes, my CTD's have always happened in VR... suspect that could be the case... if you could let me knwo what you did, that could indeed help... will try another VR flight this afternoon to see if still occurs...

There is no specific time limit on when it CTD's.... once 5 mins before takeoff...then 1 minutes brofe landing after an hour flight... very odd!

I had a mix of USB stuff with the box ticked & unticked, I've now unticked them all (just to be safe). Go through them all in device manager, not all of them will have the Power Management option but the ones that do untick the Allow box and see what happens.

I'd also check if your keyboard/mouse have a setting to "go to sleep" or something like that, heard that has caused issues with games in the past.

  • Like 1

HP Reverb G2 - Windows 11 64bit, Gigabyte Z590 Aorus Elite Mobo, i7-10700KF CPU, Gigabyte 3070ti GPU, 32gig Corsair 3600mhz RAM, SSD x2 + M.2 SSD 1tb x1

Saitek X45 HOTAS - Saitek Pro Rudder Pedals - Logitech Flight Yoke - Homemade 3 Button & 8-directional Joystick Box, SNES Controller (used as a Button Box - Additional USB Numpad (used as a Button Box)

Share this post


Link to post
Share on other sites

I never had any of these CTDs until post SU13.

Two things will happen once in a blue moon....

 

Only VR display/image will freeze, while the sim continues on my 2D screen.

I can reset the Oculus runtime and reboot and hop back into the sim in VR mode.

OR

My VR display/image will freeze first, then the sim itself will pretty much hard freeze/crash requiring a complete hard restart of my PC.

I'll run the sim in safe mode to see if I can replicate this issue...if not then I'm pretty sure it's some particular addon.

 

Edited by blueshark747
  • Like 1
  • Upvote 1

Asus Maximus X Hero Z370/ Windows 10
MSI Gaming X 1080Ti (2100 mhz OC Watercooled)
8700k (4.7ghz OC Watercooled)
32GB DDR4 3000 Ram
500GB SAMSUNG 860 EVO SERIES SSD M.2

Share this post


Link to post
Share on other sites

Try turning off turbo-boost for you CPU. When MSFS was first released I remember reading that the sim doesn't work well with overclocked CPUs.

Share this post


Link to post
Share on other sites

Just completed the flight that was crashing.  

Updated PMDG to latest version

Updated AIG

Updated packages with updates available from Content Manager within the sim

Completed the flight with no issues.  

I guess my best guess from personal experience is make sure everything outside the sim ecosystem as well as inside the sim ecosystem are updated.   

 

Edited by psolk
  • Upvote 1

Have a Wonderful Day

-Paul Solk

Boeing777_Banner_BetaTeam.jpg

Share this post


Link to post
Share on other sites
23 hours ago, Sonosusto said:

Odd. SU13 has been very stable. I am curious what else all of you tried after emptying out your com folder, uninstalled all marketplace items and followed the Zendesk guide?

USB settings? This was an issue for me several months back

Ironically enough, my last rash of CTDs was in September. I used WinDbg to examine the dump file, and it indicated USB interrupt issues (many interrupts happening in a very short period of time) coming from my mouse  I switched things to different ports and changed some cables, but the CTDs for the same reason continued. Even though it was apparently working fine, I went ahead and ordered a new mouse from Amazon. Logs do not lie. I received it on October 2nd and I have not had a CTD ever since. MSFS has been rock solid for the last 5 weeks. SU14 is running fantastic for me.

Don't write off the simple stuff.  

I use the addon linker, so on any given flight, I only have the airplane I'm using, the departure and arrival airports (if I have them), GSX, navigraph nav data, and AIG active when I fly.

Edited by MDFlier
  • Upvote 1

 i9-10850K, ASUS TUF GAMING Z490-PLUS (WI-FI), 32GB G.SKILL DDR4-3603 / PC4-28800, EVGA GeForce RTX 2080 Ti BLACK EDITION 11GB running 3440x1440 

Share this post


Link to post
Share on other sites
8 hours ago, Sonosusto said:

It's very frustrating but I was surprised that this was one of my culprits. It's as bad as unplugging something while flying in the sim from the USB. It has been known to cause CTD's. I had a wired headset that my toddler "removed" from the computer causing the sim to crash. I thought it was pretty funny, actually.

Also, I found that AddOnLinker really helped with managing mods but it also has a function that renames some parts in the folder. It seems like some devs would have similar names in their folders causing crashes. It really helped me as well

Well, I had a total of ONE successful flight after the USB adjustment, and then on second flight, about halfway into it, CTD. And, I have been using Addon Linker long before SU13, so that is not anything that will matter with this issue. I am about to give up and nuke my entire MSFS install, something I said I would never need to do before SU13 came along. I am going to sleep on it before I do that, but boy, I am getting more and more frustrated. My system runs everything else without issue and at extreme settings. I am running MSFS in 1440p on a 7800X3D and a 4090 I can't even have two stable flights in a row after this last SU. 

  • Upvote 1

AMD Ryzen 7800X3D & Gigabyte X670E Aorus Master MB, w/32 Gb GSkill DDR5 RAM, MSI 4090 GPU, lots of SSD's and M.2 drives, Fractal Torrent Case, Virpil VPC MongoosT-50CM3 Throttle, Virpil Constellation Alpha Stick, Thrustmaster TCA Yoke Boeing Edition and MFG Rudder pedals. Currently on Win11

 

 

Share this post


Link to post
Share on other sites
9 minutes ago, sniper31 said:

I am getting more and more frustrated. My system runs everything else without issue and at extreme settings. I am running MSFS in 1440p on a 7800X3D and a 4090 I can't even have two stable flights in a row after this last SU. 

I hear you! Just tried a flight... all going swimmingly well with an almost empty community folder... 3 minutes to landing after 1.5 hour flight... sim freezes... VR freezes... CTD... same error code...

I am over this..... grrrrrrrrrrrrrr

  • Like 1

i9 13900KF @ 5.5Ghz | MoBo MSI PRO Z690-A WiFi | Corsair Vengeance Black RGB RS 64gb DDR4 3200MHz | PNY RTX 4090 XLR Gaming Verto EPIC-X RGB TF | MP33 Pro 1TB M.2-2280 NVME SSD for OS | Samsung 870 QVO 2.5" 4TB SSD SATA2 | Corsair RM1000X 2021 1000W 80 Plus Gold PSU | Antec Dark Fleet DF700 Flux Gaming Case | Win 11 home | LG 48" C2 OLED 4K TV | G512 Keyboard | Razer Basilisk V2 Mouse | TCA Throttle, Sidestick and addons, peddles, TM1600 Hotas | TrackIR 5 | Tobii Eye Tracker | HP Reverb G2 HMD

Doug 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...