Sign in to follow this  
RW1

NVIDIA users:Raise your FPS

Recommended Posts

Click the windows icon in the bottom left and search "services" http://i.imgur.com/NF1TAXr.png Next open up services and locate "NVIDIA Streamer Service" http://i.imgur.com/JQQmRVr.png Open the service and stop the service if its running then disable the service. http://i.imgur.com/lNvZSyg.png Do all this and hit apply and you'll be able to see a noticeable framerate boost and drop in your cpu usage! i hope this help a couple people out!"

 

I`m not the original Poster here, just sharing a tweak i found today from EK Waterblocks.

 

Rick

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Thanks for the tip Rick!

 

I'll give this a try later on today.

 

Cheers,

 

Jerome

Share this post


Link to post

Thanks for that heads-up, Rick but I had long stopped that service. I use the Black Viper guide to trim background services to a bare minimum. And I had disabled a few Nvidia services after the last driver update.

Share this post


Link to post

Not in my Service log only the Nvdia driver?

 

but thanks anyway

Share this post


Link to post

Thanks for the headsup Rick, just checked, it's enabled on my PC, so I'm going to test if disabling it makes any difference.

Share this post


Link to post

To avoid this service getting installed again next time if you run an NVidia Geforce driver update installer, make sure you only select the NVidia driver only option. Do not select these bloatware items: 3D Vision driver/controller; Nvidia update, GeForce experience, Physics.

Share this post


Link to post

Yeah I'm going to try it too… Also I'm considering getting a dedicated audio board since I've heard that using the built-in audio board really taxes the CPU .

 

Chas

Share this post


Link to post

To avoid this service getting installed again next time if you run an NVidia Geforce driver update installer, make sure you only select the NVidia driver only option. Do not select these bloatware items: 3D Vision driver/controller; Nvidia update, GeForce experience, Physics.

Very good advice. That is precisely what I do.

Share this post


Link to post

To avoid this service getting installed again next time if you run an NVidia Geforce driver update installer, make sure you only select the NVidia driver only option. Do not select these bloatware items: 3D Vision driver/controller; Nvidia update, GeForce experience, Physics.

+1

Share this post


Link to post

To avoid this service getting installed again next time if you run an NVidia Geforce driver update installer, make sure you only select the NVidia driver only option. Do not select these bloatware items: 3D Vision driver/controller; Nvidia update, GeForce experience, Physics.

No Physics and also no audio driver?

Share this post


Link to post

No Physics and also no audio driver?

 

Not for most users. FSX/P3D do not need Physics and most if not all modern mainboards have on-board sound chips so you do not need the NVidia GPU sound driver.

Share this post


Link to post

On Windows 10 Right Click in lower left corner and select Computer Management.and then Services.

Share this post


Link to post

It is using a rather large amount of system resources, I just disabled and testing effect now. Thanks for the tip!

And in an above post, I know Asus ROG boards use their own on-board audio processor, so there is little need to disable audio in this case. Check the specs on your mobo to see if you are so equipped.

Share this post


Link to post

So NVIDIA added this service only to lower our framerates by purpose...?

 

Thanks for any explanation, Michael

Share this post


Link to post

be advised, some may still utilize the service

i believe this feature allows you to stream to TWITCH TV as well as using GeForce ShadowPlay (for recording)

Share this post


Link to post

Has anyone here seen a FPS increase by stopping the service?

Share this post


Link to post

Its not definitive, but seems to reduce my stutters when REX injects weather. There is no doubt that this service is resource intensive though.

Share this post


Link to post

It makes no difference to my sim ;) 

Share this post


Link to post

I posted this in a different thread but nVidia Streaming will only cause FPS hit if it's enabled and triggered - from my other thread:

 

FYI,  nVidia Streaming service shouldn't be doing anything unless you set ShadowPlay up for streaming (which is enabled by default if you turn ON ShadowPlay, but ShadowPlay itself is NOT turned on by default) ... HOWEVER, streaming doesn't activate unless you trigger it ... I think what happens is that some folks accidentally trigger streaming because the default hot keys to turn On/Off are those are also used in the FS platform (which is actually the case with default ShadowPlay setup).
 
When setting up ShadowPlay I set all triggers to None with the exception of "Manual Recording" (Ctrl+F12) and then make sure nothing in P3D is setup to use Ctrl+F12.
 
But it's worth investigating to make sure you're not accidentally streaming (or even recording for that matter).
 
Cheers, Rob.

Share this post


Link to post

Here is the screen I'm referencing in regard to streaming (twitch broadcast):

 

8d14b17199bec9fd41b31dfe316136b2.jpg

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this