Sign in to follow this  
GSalden

P3D v3.3 Hotfix Released

Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

Thanks gerard

just tested with FsDreamteams Zurich and works really well.

so thanks to LM for their hard work..

 

  steve

Share this post


Link to post

GTN 650/750 updated. Just run the configuration tool which will update the tool to version 1.07. That will update the GTN to work with the P3d hotfix.

Share this post


Link to post

I downloaded the client, didn't see any change for my broken scenarios, I checked the build still 3.3.3.17556, what is the build number for the hotfix?

Share this post


Link to post

3.3.5.17625

 

Kind regards, Michael

Share this post


Link to post

Downloaded the client, fixed my runway flashing issue with Orbx Payware airports such as KRDD. However, each time start P3D, receive a notice that Orbx Module ObjectFlow not tested with FS version you have installed; Run Once or Don't Run. I click Run Once with no issues that I am aware of.

Share this post


Link to post

Downloaded the client, fixed my runway flashing issue with Orbx Payware airports such as KRDD. However, each time start P3D, receive a notice that Orbx Module ObjectFlow not tested with FS version you have installed; Run Once or Don't Run. I click Run Once with no issues that I am aware of.

ORBXLibs need an update to eliminate that error message. FTX Central just added an update for it, but it doesn't say what the update is for. Other addons that rely on "nonstandard" interactions with P3d:

 

Flight GTN 650/750 - updated, run the F1 Update  tool

FSUIPC - Pete Dowson hasn't posted anything beyond 4.955, so maybe somebody else knows if that works with the hotfix or not

ASN - not yet

TacPack - not yet

Share this post


Link to post

Just learned of FTX Central update but didn't fix objectFlow msg. Sure things will be sorted. Thanks much for info!!!

Share this post


Link to post

ORBX will only provide any further updates after their servers stabilized. Until then all updates are deliberately disabled. 

 

Kind regards, Michael

Share this post


Link to post

maybe it was a cache, got the update now, happy to have airport running back. I also noticed ORBX FTX Central v2 going back and having to Apply Group again

Share this post


Link to post

I also notice that the only overlay that works with P3D so far (Precision X) is not working anymore to check my vram usage.

 

Did anyone notice it?

Share this post


Link to post

FSUIPC - Pete Dowson hasn't posted anything beyond 4.955, so maybe somebody else knows if that works with the hotfix or not

 

Yes, no change for FSUIPC since the main 3.3 release. The installer will complain that it doesn't know the later build number, but it does no harm, and anyway if it's already installed you don't need to reinstall after applying a Client uninstall/install.

 

Pete

  • Upvote 2

Share this post


Link to post

third time I started P3D after the hotfix and it's asking to test the object flow

Share this post


Link to post

third time I started P3D after the hotfix and it's asking to test the object flow

and it will keep asking until Orbx updates it. Just clock past it and go fly.

 

Vic

Share this post


Link to post

Has it resolved all the scenery problems like UK2000? Hesitating to re-update until i am sure all my current addons (all P3D v3 compliant) will not be adversely  affected.

Share this post


Link to post

Good stuff. I know what I'll be doning when I get off work today  :smile:

Share this post


Link to post

Perhaps you have all seen it already , but the SDK has also been updated from v3.3.3 to v3.3.5...

  • Upvote 1

Share this post


Link to post

Hi, I am about to go from 3.2 to 3.3.5. If I just reinstall Client, will I have problems with Orbx Global/OpenLC and/or GSX? Thanks. 

Share this post


Link to post

Can I just install the 3.3 client and then install the hotfix? is that the way to go if I'm only updating the client?

 

Cheers Rod.

Share this post


Link to post

Hi, I am about to go from 3.2 to 3.3.5. If I just reinstall Client, will I have problems with Orbx Global/OpenLC and/or GSX? Thanks. 

 

 

Can I just install the 3.3 client and then install the hotfix? is that the way to go if I'm only updating the client?

 

Cheers Rod.

 

 

From the LM Website:

 

06-09-16

 

A hotfix has been released for the Prepar3D v3.3 Client.

The v3.3.5 hotfix is available now and can be downloaded from your Downloads page.

This update only requires an update to the Client. See the Prepar3D v3 Download and Installation Directions for more details on how to quickly update. If this is your first time downloading v3.3, it is automatically included in the available downloads.

This hotfix corrects two major issues identified quickly after release:

  • Third party scenery visual anomalies. Various visual artifacts, increased memory usage, and missing features.
  • Multiplayer sessions only showing other players if they were the last to join.

Thank you to the community for assistance in identifying the issues and to third developers for providing more information.

The Prepar3D Team

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this