Jump to content

Sign in to follow this  
mazelda

P3dv4.4 slow to start

Recommended Posts

Hi,

Just wondering if there may be a solution to this.

Since upgrading to 4.4 my start up time has massively increased in both getting to the selection screen and then loading to my start airport.This has increased by about 4 times.

I've not added any scenery and i've already tried deleting the shader and p3d.cfg files.

I've also upgraded my nvidia drivers to the latest version

I have most of the orbx regions and global textures and vector installed, but these were present in 4.3 also.

When i upgraded i did a new install but did not remove anything left after p3d had uninstalled.I then reinstalled p3d into the same directory so everything was in the same place prior to update

Any ideas as to why its much slower to load and any ideas on a fix

Thanks


Pete Little

Share this post


Link to post

FWIW, I think my boot time has decreased somewhat. It still takes several minutes, but I think it is down to around 8-9 minutes. With v4.3 I would have almost double the load time. However, once into the select screen and a scenario is chosen, the load up is as long as ever...the 6% stall and then incremental loading. 

 

Sherm

Many ORBX Sceneries and Vector, ASus 97-A mobo, Nvidia 760gtx card.

Share this post


Link to post

I have seen no real change in load times.  Load times depend on many factors, including whether a drive is fragmented which can happen after repeated P3D installs and uninstalls, especially if you get down to less than a third of hard drive space, even if you have more space free P3D can still get fragmented, even its default scenery.  I do not defragment too often, only if I notice a pronounced slowdown in starting times.  If my Win 10 boots in seconds I tend not to worry, and I have had Win 10 boot in seconds more often than not, as compared with older versions of Windows which used to boot painfully slow.

If anything, as compared to FSX on my older system which had less content than P3D, P3D even with photoscenery loads amazingly fast.  Xplane11, even faster although for some reason Xplane11 takes longer to shut down.  Different strokes for different folks, I guess.

John

Share this post


Link to post
51 minutes ago, shermank said:

FWIW, I think my boot time has decreased somewhat. It still takes several minutes, but I think it is down to around 8-9 minutes. With v4.3 I would have almost double the load time. However, once into the select screen and a scenario is chosen, the load up is as long as ever...the 6% stall and then incremental loading. 

 

Sherm

Many ORBX Sceneries and Vector, ASus 97-A mobo, Nvidia 760gtx card.

Wow. 8-9 minutes and it was almost double that with 4.3?.  

I have noticed that 4.4 is taking longer to load then 4.3 did for me, contrary to what others are experiencing. I guess I should consider myself lucky, as it takes my system about  3 minutes, and I thought that was long.  


Rick Verhallen

i7-8700K OC to 5.0 Ghz | 32 GIG- G.Skill 2400 RAM | Asus ROG Maximus X Hero Motherboard | Asus RTX 2080Ti |  47" Samsung 4K Monitor I HTC Vive Pro HMD

Share this post


Link to post

You could try doing several things.

Load times are impacted by the number of aircraft (payware and AI) as well as the number of sceneries you have active. Given that few of us want to change those....

 

1. Delete your P3D Shaders folder (not the one in the main P3D folder).

2. Delete your Prepar3d.cfg file (which wasn't changed during the update to 4.4)

Both of the above will automatically be rebuilt for you.

 

Best wishes.

 

 


Dave-Aerosoft-Signature-Banner-2019.png

Share this post


Link to post

Perhaps you introduced some of the Prepar3d4.4 specific tweaks floating around, which may extend loading times seriously. Notably, TEXTURE_SIZE_EXP=10 would be a good candidate for this.

Dave's suggestion of deleting prepar3d.cfg would be a good test to see if it's the reason.

My loading time is roughly the same as before, but I used TEXTURE_SIZE_EXP=10 in 4.3 already most of the time. Loading takes several minutes when this is active, though (typically 5 min or so).

Kind regards, Michael


Prepar3d Professional v4+5, AeroflyFS2, XP11; Beta tester of SimStarter, SPAD.neXt, and FS-FlightControl

Intel i7-6700K 4.0 GHz / Asus Z170 / Kingston 32 GB DDR4 / Samsung SSD M.2 500 GB + Samsung SSD 1 TB + Intel SSD 500 GB + WD HD 6 TB / EVGA GTX 1080Ti 11 GB / LG 34UM95 3440 x 1440 /  XTOP/Saitek hardware panel / HP Reverb / Win 10/64

 

 

Share this post


Link to post

Since my first post in this thread a few days ago, I have had some key problems....the first I ran into were scenery spikes at and around CYKF. I have found no solution for this, including a reinstallation of the scenery and client elements. So, I am really going back to square one by deleting all three existing clients and then reinstalling the entire setup. I am not very happy about this, but it is what it is....and I hope it will be time well invested.

Along the way, and I do not know whether it is connected per se to the 4.4 installation, I have had dreadfully slow new installations of ORBX Vector and FTX Global. HD Trees, a much smaller file, went quickly and smoothly.   However, the long and slow installations of the larger file programs literally froze out other operations of my computer. As Doug Sawatzky noted over in an ORBX forum, this probably stems from a problem with my computer. I did a full hard drive error check as well as a memory check, and though errors were found on the drive which houses P3D, the W10 scan program corrected them.

I evidently will have to repeat that process when I finish with the fresh P3d 4.4 work. As I have often said about all of this, computering and flight sim are nothing but a giant variation of a Rubik's Cube...you just have to take some time and concentration to get everything in place.  🙂

 

Sherm

Share this post


Link to post
On 12/3/2018 at 12:43 PM, mazelda said:

When i upgraded i did a new install but did not remove anything left after p3d had uninstalled.I then reinstalled p3d into the same directory so everything was in the same place prior to update

I do not know anything about Orbx/FTX but doesn't the vector replace some of the scenery files?  If you reinstalled the P3Dv4.4 Scenery, the install might have written over the Orbx/FTX files.  I do know the Regions are standalone other than Orbx places several files in the Scenery/World/Scenery folder, mostly to adjust elevations.  You could have a mess.  I would follow the guidance from Poppet in the P3D Tricks, Tips, and How To's Forum - https://www.avsim.com/forums/topic/522254-ftx-orbx-scenery-prepar3d-updating-reinstalling-troubleshooting/.


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post

I have few ideas about slow start and at the moment I myself was diagnosing load times as I write this post.

1) Mesh does take time to load - for example on my system

All US FTX Regions + US FTX Airports & Global + Vector Only the only addons - Load time start is about 20 Seconds to Scenario screen.

2) Add FreeMeshX USA Beta (50GBs) - Load time goes to 31 Seconds to Scenario screen at bootup.

Please run Lorby Freeware Addon Tool for Prepar3d (this is a critical app to have with Prepar3d v4) - Go to Tools sections <-- click on the right arrow and go to tools

Here click on check encoding.  This option will tell you if any off the new XML files have wrong encoding.  

The wrong encoding slows the boot of prepar3d down.

If there are errors

Download Notepad++ (it is free and opensource).  Once the file is opened in it - All you have to do is click on Encoding --> Encode in UCS-2 LE BOM and save the file.  

Rerun Lorby's tool and go to tools again - check the encoding.  It should say no files have errors.

Try the sim.

If you have any addons which use SODE - make sure your sim is registered on it - Click Register Sim in the SODE app.

I hope these suggestions can help you out

Edited by Skywolf
  • Like 1

Share this post


Link to post

Since I started this topic and reading some other peoples start times,its seems mine was of a similar sort of start time.

Due to a few other issues that kind of annoyed me a bit, i decided to wipe everything and restart it from scratch. Although i'm still adding the last few airports the startup time has reduced by a few minutes, so overall  its been worth the time restarting from scratch and the other issues have also gone

 


Pete Little

Share this post


Link to post

Two things that affect load times. Active Scenery and no. of aircraft.

  • Like 1

Shez Ansari

Windows 10 Home 64-bit; CPU: Intel Core i7-8700K; GPU: EVGA GEFORCE GTX 1080Ti 11GB; MB: Gigabyte Z370 AORUS Gaming 5; RAM: 16GB; HD: Samsung 960 Pro 512GB SSD, Samsung 850 Pro 256GB SSD; Display: ASUS 4K 28", LG HD 22"

Share this post


Link to post

My load times where 8-9 minutes, every time I crashed or reset airport location it was 8-9 minutes.  I then read from a developer at Lockheed Martin to turn autogen and scenery draw distances, under Graphics\World, to medium or less.  His explanation was that v4.5  loads much more than 4.4 and medium is still more in 4.5 than 4.4.  this helped me tremendously.  Hope it helps you.

Share this post


Link to post

I am still running P3Dv4.4 and have many ORBX regions/openLC/airports and UK2000 airports, and have suffered very long load times. These scenaries have all been loaded and ticked active in the Scenery Library. It has typically taken a few minutes to get to the initial scenario select screen (I use the default LM: Eglin AFB Florida and one of the LM jet fighters); then I select the aircraft I want and the area I wish to  fly (usually an Orbx or UK2000 airport in FTX England Region). It has been typically another 10 minutes to get to the selected airport/aircraft. I don't have an SSD by the way.

But I have tried something that seems to help enormously. I have gone into the scenery library and unticked all of the Orbx regions and areas (I have FTX Scotland, Wales, NI, Ireland, Germany N and S, and nearly all of the regions on the US west coast); I also have all of Orbx Open LC (Europe and North America) and Orbx Vector. The only scenery that I now have ticked are the four for FTX England. In this new "mostly unticked" arrangement, my load times as measured by stop watch: 25 seconds to get to the scenario/flight select screen, and an additional 4 minutes 20 seconds to get to my selected aircraft (Milviz Twin Comanche) at a UK2000 airport in FTX England (these left ticked of course). I think this is a practical and flexible way to go. Keep your scenery library ticked to only the region you mostly fly to speed up loads. If you wish to change where you want to fly, when you get to the first screen and BEFORE going to the selected flight, select the SCENERY button, and tick the new area you wish to fly, and untick the old one. Then choose the new flight/scenario as usual. Five minutes total is not great, but it is a reduction of about half what it was previously. 


My system specs: i7 4790k @4.0 GHz, Nvidia GeForce 970, 16 Gb RAM, Windows 10.  Sim: P3Dv4.5 Professional; Orbx Global and Vector, Orbx OpenLC Eu and NA, and most Orbx FTX regions in EU and NA. Preferred aircraft: PMDG DC-6, Manfred Jahn DC-3 and A2A Bonanza, Comanche and Cherokee

Share this post


Link to post

Update to 4.5 with hotfix. Load times is one of the issues addressed.


Gigabyte Z97X-UD5H-BK, Blk Ed MB; Intel I7-4790K CPU (@4.5 Ghz); 16 Gb G.Skill RAM (F3-2400); Win10 Pro (P3D V5 HF1); 2 Samsung 1Tb SSDs;Toshiba 3Tb hard drive; Gigabyte Aorus Extreme 1080ti 11Gb VRAM; Toshiba 43" LED TV @ 4k;

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    14%
    $3,635.00 of $25,000.00 Donate Now
×
×
  • Create New...