Jump to content

Sign in to follow this  
vl1

P3Dv5 is single core AGAIN 🤦

Recommended Posts

Posted (edited)

Loaded AS EGLL with full traffic, had the same observation, first core in the task manager is fully loaded without a break while others are at 25% or less. Performance seems to be near same as V4.

Edited by him225

Share this post


Link to post
8 hours ago, vl1 said:

This is just unacceptable!

I assume you didn't have understood how an Mainthread works. Its nothing you just can magically split up.

And having the fastest CPU doesn't mean you can't bring it down to its knees with too high settings / addons / wrong "tweaks".

  • Like 1

System: i9 9900k@4.9 - 32 GB RAM - Aorus 1080ti --- Sim/Addons: P3D v5 + ProSim737
Signature3.png

Share this post


Link to post
Posted (edited)

I think you will find even modern Games that are multi- threaded use core 0 the most.

But they use the GPU more Now That`s a problem with some flight sim users.

Edited by G-RFRY

i9 10900K\ASUS APEX MB \ MSI RTX 2080Ti GAMINGX TRIO \ M.2  Samsung 970 EVO Plus 1TB C Drive \ 2+1TB Samsung 850 EVO \ 2TB BarraCuba \ 32GB G.SKILL Z DDR4 3600MHZ \ Windows 10 Home\ ASUS 28" 4K monitor\ 4TB Portable Drive\P3DV5

Raymond Fry.

PMDG_Banner_747_Enthusiast.jpg

Share this post


Link to post
Posted (edited)

The most important thing would be the understanding of the difference between "Single-Thread", "Multi-Thread" and "Main-Thread".

P3D is multi-threaded and has been for ages, but that doesn't mean the main thread can't overload the CPU.

Edited by JoeFackel
  • Upvote 1

System: i9 9900k@4.9 - 32 GB RAM - Aorus 1080ti --- Sim/Addons: P3D v5 + ProSim737
Signature3.png

Share this post


Link to post
Posted (edited)

I noticed this in v4.5:

When you are on the ground and not moving, core 0 is 100% and all other cores are almost at idle.

When you start flying all the cores and threads except one are almost at 100% (my experience with i7-7700 running at 4.2GHz, HT enabled). I think that other cores handle the scenery loading while flying.

Did the usage of other cores increase when you were flying with i9-9900?

Edited by Branimir
  • Upvote 1

I7-10700 (4.8 GHz with HT enabled)

2x8 DDR4 

Gigabyte RTX 2070 Super OC Gaming

Share this post


Link to post

My 9900k uses all 8 cores evenly now like butter melting on the whole slice of toast, no need for process lasso now, hyper threading off, agh man i am so happy, f...... happy, the heading of this discussion is absolutely senseless and BULL DUST.😂

  • Like 1

Share this post


Link to post

My 8700k froze in flight, and core0 was pegged at 100, with the others barely doing anything. Ill have to try turning off hyperthreading. 

Thank you from those of us who are not technically inclined nor snarky. 

Share this post


Link to post
Posted (edited)

I have an interesting behavior. 

I have a 9990XE with 14 Cores without HT.  But P3D only uses  Core 0 - 4 and 9 - 13 🙂 

Process lasso is set to not set any affinity. 

No Performance issues only interesting, so i don`t know is it a bug or a feature 🙂

Edited by 331BK

sfo_a320.png

 

C. W. ,I9-9990XE, 32 GB RAM, Samsung SSD980 1 TB, Radeon VII Watercooled

Share this post


Link to post

Interesting, as my usage is incredible well-balanced as I fly along. Though logical core 2 and 4 seems underutilized most of the time.

CZf5V8l.jpg


8700K Delid @ 5GHz | G.Skill 32GB DDR4 @ 3600MHz | MSI 1080 Ti Sea Hawk X | Windows 10 Pro (2004) | Monitors: LG 27UK650 / Acer XB270HU

Share this post


Link to post

today i bought RTX 2070

I have 12 fps in London Heathrow!!!
Is this normal? No!
I have i9-9900K and RTX 2070 with settings MEDIUM but full AI (950 flightplans)

  • Like 1

Share this post


Link to post

You should all report at LM support forum. As that is the correct and most effective way. All your posts may bring attention to this point

Share this post


Link to post
27 minutes ago, vl1 said:

today i bought RTX 2070

I have 12 fps in London Heathrow!!!
Is this normal? No!
I have i9-9900K and RTX 2070 with settings MEDIUM but full AI (950 flightplans)

Maybe it’s the AI? 

Share this post


Link to post

What's the point of using P3D without AI??

Share this post


Link to post
1 minute ago, vl1 said:

What's the point of using P3D without AI??

Did you try without AI? What percentage was your slider at? Then you can determine how big an impact it has? 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    31%
    $7,860.00 of $25,000.00 Donate Now
×
×
  • Create New...