Jump to content

Archived

This topic is now archived and is closed to further replies.

Recommended Posts

Hello, my name is Tom and I have such problems to run FSX smoothly. Does anyone have tweaks, to remove the stutters perfectly?I have such good frames, also with addon aircrafts ( like PMDG NGX ) and Addon sceneries ( Aerosoft Mallorca X ) par example. But when I am taxiing around the airports i receive stutters, especially on addon airports in Virtual Cockpit mode or in wingview mode. ( Not only in taxiing, also when I fly in VC it is laggy ).With bufferpools setting to 0 I receive always graphic interruptions, like white flashing artifacts, flashing black stripes etc. Need your perfect tweaks to solve this problem. Does anyone have tweak suggestions? Thanks for any help, I did bojote tweaks and I don't know what else I can do! I have been used the fps limiter to 30 and in fsx to unlimited, but without fps limiter and the limiter in FSX set to unlimited, I get better results and a more smooth FSX, but not perfect.What could I do to fix that issue? My pc specs are: CPU: I7 2600K Clock speed: 5 GHZRAM: 16 GB 1600 MHZ1 TB HDD Samsung 7200 RPMGPU: Colorful GTX 580 1536 MB Thanks for helping me :-) Best regards, Tom


Tom Romero Sanchez

Finca La Costa / Mallorca

www.fincalacosta.com

Share this post


Link to post
Share on other sites

Tom, I'm going to move this to a more appropriate forum so you'll receive better response.


Sincerely,

Chase 

 

My 2017 Build: Liquid Cooled i7 7700K CPU idle @ 4.2GHz | MSI GTX 1080 Gaming X 8G | 16GB's DDR4 4000 RAM | ASUS 27" 144hz Gaming Monitor | MSI Z270 M7 Motherboard  | Windows 10 | Samsung 960 EVO M.2 500GB SSD

Share this post


Link to post
Share on other sites

Hi Tom, As you have a good GPU, I would recommend adding the following lines to the end of your FSX.cfg: [bufferPools]UsePools=0 This casues fsx to use the faster videoram more than the slower system ram and will give much improved performance on systems with a 1 gig or more videocard. Also add these lines to the start of your fsx.cfg: [JOBSCHEDULER]AffinityMask=14 This will make fsx run on cores 1, 2 & 3 leaving core 0 to run your operating system and background processes (often the casues of stutters). Let us know how well these tweaks work for you (they work for me and many others). Cheers, IAN


Ryzen 5600X, AM4, 6 Core 12 thread - Nvidia 3070 founders edition - 32 Gig RAM - Windows 10 64 bit MSFS 2020 Premium Deluxe Edition Resolution 1920 x 1080

Share this post


Link to post
Share on other sites
Hello, my name is Tom and I have such problems to run FSX smoothly. Does anyone have tweaks, to remove the stutters perfectly?I have such good frames, also with addon aircrafts ( like PMDG NGX ) and Addon sceneries ( Aerosoft Mallorca X ) par example. But when I am taxiing around the airports i receive stutters, especially on addon airports in Virtual Cockpit mode or in wingview mode. ( Not only in taxiing, also when I fly in VC it is laggy ).With bufferpools setting to 0 I receive always graphic interruptions, like white flashing artifacts, flashing black stripes etc. Need your perfect tweaks to solve this problem. Does anyone have tweak suggestions? Thanks for any help, I did bojote tweaks and I don't know what else I can do! I have been used the fps limiter to 30 and in fsx to unlimited, but without fps limiter and the limiter in FSX set to unlimited, I get better results and a more smooth FSX, but not perfect.What could I do to fix that issue? My pc specs are: CPU: I7 2600KClock speed: 5 GHZRAM: 16 GB 1600 MHZ1 TB HDD Samsung 7200 RPMGPU: Colorful GTX 580 1536 MB Thanks for helping me :-) Best regards, Tom
Many people dispute what I am about to say, but I tested my rig, (2600k with GTX 580 @ 5Ghz), with various memory and I would never give up my 2133 CL9... K

Share this post


Link to post
Share on other sites
Hi Tom, As you have a good GPU, I would recommend adding the following lines to the end of your FSX.cfg: [bufferPools]UsePools=0 This casues fsx to use the faster videoram more than the slower system ram and will give much improved performance on systems with a 1 gig or more videocard. Also add these lines to the start of your fsx.cfg: [JOBSCHEDULER]AffinityMask=14 This will make fsx run on cores 1, 2 & 3 leaving core 0 to run your operating system and background processes (often the casues of stutters). Let us know how well these tweaks work for you (they work for me and many others). Cheers, IAN

Tom Romero Sanchez

Finca La Costa / Mallorca

www.fincalacosta.com

Share this post


Link to post
Share on other sites

Hello, first of all many thanks to all, giving me some hints. I did a much of tweaking myself, but I got stutters. The tweak with the bufferpools are great with usepools set to 0, frames are good and smooth experience. But then especially in turns, i receive black flashing stripes and white flashing artifacts. This is my worst problem also!!! Has anyone hints to fix this? Thank you very much indeed.Best regards,


Tom Romero Sanchez

Finca La Costa / Mallorca

www.fincalacosta.com

Share this post


Link to post
Share on other sites

If you did this

HIGHMEMFIX=1, & Water at High 2.x for flashing.
and stiill have flashing or artifacts, then do this:- [bufferPools]UsePools=1PoolSize=8388608RejectThreshold=262144 // If this fixes it - drop the RTh to 131072 and try the lower size. By the way - what memory and timing are you using?

Share this post


Link to post
Share on other sites

Now that I have a good machine I am using UsePools=0 along with AffinityMask=14 with excellent results. These excellent results were not possible until I upgraded to the i7 2600k runnint @ 4.7. I do get the ocassional white flash which I have not been able to do away with. Still working on it. Highmemfix did nothing for me. RegardsBob


Officially retired

 

Share this post


Link to post
Share on other sites

Highmemfix does not effect performance Bob, but very important to have if you have and use payware aircraft like PMDG, LVLD etc.


System: MSFS2020-Premium Deluxe, P3D 5.0, ASUS Maximus XI Hero,  Intel i7-8086K o/c to 5.0GHz, Corsair AIO H115i Pro, Corsair Spec Omega Case,Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, 32Gb Corsair Vengeance DDR4 3200Mhz RAM, EVGA 850+ Gold PSU,Win 10 Pro 64-bit, Samsung 43 UHD TV, LG 43UD79 43" 4K IPS Panel., Logitech X56 Hotas Stick and Throttle, Logitech/Saitek Flight Yoke System, Multi, Radio, Switch Panels

 

Share this post


Link to post
Share on other sites

I'm amazed how people are complaining about stutters while in the same time using wrong tweaks at the wrong time - maybe I'm trying to be clever now but Bojote himself said that Usepools=0 is not to be used on fast hardware or it might cause crashes.But anyway: flashes are caused by Usepools=0 (Bufferpools=0, it's the same thing) + Water *lower* than High 2.0. Either water high or Usepools=1 and then use RejectThreshold.Try the clean fsx.cfg.Limit inside the FSX, rather than externally. Run a light airport with light aircraft, somewhere where you get 60fps easily - limit FSX to 60fps and check the smoothness. If it ain't smooth, it ain't the FSX's fault. Check then for external programs causing it.As others pointed out, without hyperthreading set:[JOBSCHEDULER]AffinityMask=14

Share this post


Link to post
Share on other sites
Highmemfix does not effect performance Bob, but very important to have if you have and use payware aircraft like PMDG, LVLD etc.
I am aware that this is not a performance tweak, but thought it might offer some benefit to the white flashing I get. I thought the Highmemfix was for video mem exhuastion which is what I thought I was experiencing when seeing the the white flashes. Bob
I'm amazed how people are complaining about stutters while in the same time using wrong tweaks at the wrong time - maybe I'm trying to be clever now but Bojote himself said that Usepools=0 is not to be used on fast hardware or it might cause crashes.But anyway: flashes are caused by Usepools=0 (Bufferpools=0, it's the same thing) + Water *lower* than High 2.0. Either water high or Usepools=1 and then use RejectThreshold.Try the clean fsx.cfg.Limit inside the FSX, rather than externally. Run a light airport with light aircraft, somewhere where you get 60fps easily - limit FSX to 60fps and check the smoothness. If it ain't smooth, it ain't the FSX's fault. Check then for external programs causing it.As others pointed out, without hyperthreading set:[JOBSCHEDULER]AffinityMask=14
I have nad no crashes (fingers crossed) but using UsePools=0 is working well along with AM-14. I guess I may be one of the lucky ones. Bob

Officially retired

 

Share this post


Link to post
Share on other sites
Hello, my name is Tom and I have such problems to run FSX smoothly. Does anyone have tweaks, to remove the stutters perfectly?I have such good frames, also with addon aircrafts ( like PMDG NGX ) and Addon sceneries ( Aerosoft Mallorca X ) par example. But when I am taxiing around the airports i receive stutters, especially on addon airports in Virtual Cockpit mode or in wingview mode. ( Not only in taxiing, also when I fly in VC it is laggy ).With bufferpools setting to 0 I receive always graphic interruptions, like white flashing artifacts, flashing black stripes etc. Need your perfect tweaks to solve this problem. Does anyone have tweak suggestions? Thanks for any help, I did bojote tweaks and I don't know what else I can do! I have been used the fps limiter to 30 and in fsx to unlimited, but without fps limiter and the limiter in FSX set to unlimited, I get better results and a more smooth FSX, but not perfect.What could I do to fix that issue? My pc specs are: CPU: I7 2600KClock speed: 5 GHZRAM: 16 GB 1600 MHZ1 TB HDD Samsung 7200 RPMGPU: Colorful GTX 580 1536 MB Thanks for helping me :-) Best regards, Tom
Add these lines to the cfg: BufferPools]UsePools=30000 [JOBSCHEDULER]AffinityMask=14 and as PJ stated, set water to High 2x. Your problem can be related to ram timings, but most of the time is just a simple bufferpools teak that is needed to get FSX smooth and flash free.

Share this post


Link to post
Share on other sites
If you did this and stiill have flashing or artifacts, then do this:- [bufferPools]UsePools=1PoolSize=8388608RejectThreshold=262144 // If this fixes it - drop the RTh to 131072 and try the lower size. By the way - what memory and timing are you using?
Hello, first of all thanks very much for your help and assistance. :-) My RAM is 16GB Timing 1600 MHZ

Tom Romero Sanchez

Finca La Costa / Mallorca

www.fincalacosta.com

Share this post


Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    42%
    $10,670.00 of $25,000.00 Donate Now
×
×
  • Create New...