Jump to content

Archived

This topic is now archived and is closed to further replies.

Guest

How to Update P3DV2.2 to P3DV2.3

Recommended Posts

Guest

 

 


When starting P3D I got an automatic update message from objectflow, very nice!

 

I was hoping that would happen, sounds like Orbx are on top of it, excellent news.

 

Cheers, Rob.

Share this post


Link to post

 

 


Some of the 3rd party products I did test for 2.3:..

 

Awesome work on all the testing Rob!! I know you mentioned this was equivalent to a second full-time job, and we can certainly appreciate why... 

Share this post


Link to post

Thanks for the list of tested addons, Rob.

 

I can add a couple to that list:

-Carenado C337

-Carenado C152

-Migration Tool seems to work for installing addons, but legacy mode is not supported

 

Does anyone have any news about FSG2010 for FTX yet?


Cheers!

Maarten Franken

Share this post


Link to post

Glad to see a list will help others to know when they may load up 2.3 - thanks


Rich Sennett

               

Share this post


Link to post

 

You need to make sure you backup 3 directories and delete 4 directories before you applying the patch.

 

Cheers, Rob.

Followed your guidance, downloaded FSUIPC update and the patch went perfectly. Orbx OF updated automatically. A2A Cherokee and Cessna work perfectly (and I now have strobe, nav and landing lights on the former). So thanks Rob - would have been a dogs dinner otherwise.

 

Loving the update - performance is fabulous and smooth. Did some night flying around Prince Rupert in Orbx PNW. Don't know if they were there before but the channel buoys are all flashing away. Brilliant immersion - of course needed for those who use boats and ships in the sim - but a first in my simming experience.

 

Now if only there were more hours in the day.

 

Cheers

Peter


Peter Allen

Chillblast custom built: Intel Core i7-7700K 4.5Ghz, Nvidia GTX1080Ti, Corsair Hydro H100i v2,  Asus Maximus Hero IX Z270, 32Gb DDR4 3000Mhz  (4 X 8Gb), 250Gb Samsung 960 Evo SSD PCie, 2 x 1Tb Crucial SSD, 1 x 4Tb, Corsair 850W PSU.  PFC C2 Pro Console with Hall Effect . PFC GA Rudder pedals

Share this post


Link to post

 

 


1. Virtuali - no go (add-on manager which basically means no FSDT and/or FB airports) - will need an update

 

As I have posted before: Umberto from FSDT had already uploaded the new add-on manager this morning. So if you have installed any FSDT products, you just need to download the new add-on manager from the FSDT website and install it. After that, all FSDT products work fine with v2.3.

Share this post


Link to post
Guest

Does anyone have any news about FSG2010 for FTX yet?

 

I think that was in my good to go list. (did I miss it?)

 

 

 

Umberto from FSDT had already uploaded the new add-on manager this morning.

 

Just confirmed, yes new version .. excellent.

 

3rd party are responding very quickly.

 

Cheers, Rob.

 

 

So thanks Rob - would have been a dogs dinner otherwise.

 

Loving the update - performance is fabulous and smooth. Did some night flying around Prince Rupert in Orbx PNW. Don't know if they were there before but the channel buoys are all flashing away. Brilliant immersion - of course needed for those who use boats and ships in the sim - but a first in my simming experience.

 

Glad you like ... at least you wouldn't turn me into sushi.  I must admit, v2.3 has made me want to fly at night now ... the night lighting feels so much better ... toss in a little winter snow, some night lights, great textures, some delicious clouds, a little wind to bring up the waves, moon reflection on the waves ... be sure to checkout some of the Bathymetry areas (East and West Coast US and Hawaii) ... wave height changes with water depth (I think this is new for 2.3).

 

Hopefully there is enough to keep folks busy until v2.4 is released later this year.

 

Cheers, Rob.

Share this post


Link to post

Holy cow - will there be an easier way to update or is this it for now?

 

And mines not working....  I run the msi file and the installer just says "computing space requirements"

 

If I get it working how do I then install my old addons?  What about TIR profile and controls?  Can I just recopy those controls files into the directories I deleted them from?


|Ryan Butterworth|

| i7 4790K@4.4GHz | 32GB RAM | EVGA GTX 1080Ti | ASUS Z97-Pro | 1TB 860 Evo | 500GB 840 Evo Win10 Pro | 1TB Samsung 7200rpm | Seasonic X750W |

 

 

Share this post


Link to post

I just have to repeat that I haven't had any problems with patching (and, yes, I have had the hotfix applied)

 

In my opinion, the key is in peoples DLL.xml or EXE.xml.

Be sure to disable all entries and try running P3D v2.3

I just saw this and wondering if you really have your P3dV2.2 upgraded to 2.3. Rob specifically stated the folder that contains the dll.xml, exe.xml, the p3d.cfg, etc., must be deleted before applying the patch. So those the dll.xml and exe.xml are not even seen by an upgraded installation and will have nothing to do with your upgrade as the upgrade will create new ones. Remember, when you patch 2.2 to 2.3, the installer will state it has completed successfully even if it didn't complete successfully. If you look at the P3D.exe version in your P3D folder you will see it was not updated by looking at the date of the file. If it's not the date you installed the update, then your upgrade was not successful.

 

Apologize if this has already been brought to your attention.

 

Best regards,


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post

Is Carenado aircraft (aerosoft airports - flytampa - Flightbeam) working in2.3 ? if so I'm off to the races - thank you

 

Ooops just saw Robs list - thank you Rob


Rich Sennett

               

Share this post


Link to post

After all my hesitation, decided there was nothing to lose in trying the patch - so applied it over 2.2.10438 with no rollback to 10437.  Seems to have worked perfectly.  Still sorting out some small glitches (Opus doesn't want to communicate it but I might have downloaded the wrong version or otherwise misconfigured something).  But overall, it seems like a huge improvement - tried a short flight in an urban area with the gray and rainy theme and cloud shadows on - that would have been a performance killer in 2.2 but it ran very smoothly.  Heading off now to explore some more.



Alan Ampolsk

"Ah, Paula, they are firing at me!"
-- Saint-Exupery

Share this post


Link to post

After all my hesitation, decided there way nothing to lose in trying the patch - so applied it over 2.2.10438 with no rollback to 10437.  Seems to have worked perfectly.  Still sorting out some small glitches (Opus doesn't want to communicate it but I might have downloaded the wrong version or otherwise misconfigured something).  But overall, it seems like a huge improvement - tried a short flight in an urban area with the gray and rainy theme and cloud shadows on - that would have been a performance killer in 2.2 but it ran very smoothly.  Heading off now to explore some more.

 

Alan great news - thanks for sharing


Rich Sennett

               

Share this post


Link to post

Hi all,

 

FWIW, i had 2.2.10438 and patched it (before seeing this thread) and have no problems. Didn't delete any files, just backed up the \AppData\Roaming\Lockheed Martin\Prepar3D v2 folder just in case, used 4934f FSUIPC and deleted the ASN entry from dll.xml before patching.

All seems to be working as it should, but im losing half my FPS when i have to access the top menu, and also can't reactivate SweetFX after deactivating it ingame. These 2 problems didn't happen before.


Alvega

Share this post


Link to post

 

 


Opus doesn't want to communicate it but I might have downloaded the wrong version or otherwise misconfigured something

 

As suspected - operator error.  I mistakenly tried to run the client instead of the server software on a single-PC system.  Too many moving parts.  Opus is fine and all is well.



Alan Ampolsk

"Ah, Paula, they are firing at me!"
-- Saint-Exupery

Share this post


Link to post

I applied the patch before I was aware of Rob's installation instructions. Fortunately I had not applied the hotfix.

What should I do now? Reinstall the patch using Rob's method?

The P3D exe file shows as the patch date but the P3D.exe xml file (whatever that does) shows 16-Oct-2010


Cheers

Steve Hall

Share this post


Link to post
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    22%
    $5,600.00 of $25,000.00 Donate Now
×
×
  • Create New...