spilok

My "pauses" or stutters fixed!

Recommended Posts

There are several threads on this forum relating to P3d pauses and stutters.  I had them too.  I blamed ORBX like so many others did, and I have pretty much all of ORBX scenery and their Global, Vector, and LC North America and Europe. Additionally, I fly a lot near Orlando so I also have the new City Scene Orlando.

I would get relatively long pauses several times at critical flight situations (landing, etc), changing views, bad weather and clouds, etc.,  and it really annoyed me since my system is a state of the art Jetline system.

Well, today, I tried one more idea I read about on this forum, and that idea worked.  I tested it by loading KMCO (long load time, as usual), kept my sliders at full right in most of the autogen and World option screen, and took two flights:  Took off from KMCO in Embraer 170 in Active Sky weather to Miami.  Weather very overcast today, and I have the full Miami Scenery from Latin VFR.  NO PAUSES OR STUTTERS!  My second flight was 747 from Orlando to Philadelphia.  Very smooth...NO PAUSES.

My fix was this:  I turned off "AutoSave" in my paid version of FSUIPC!.  That simple.  For me, it worked, and it worked in very demanding scenery and weather.  I'm sold.  No more saves after crashes.  Not worth it.  Nice having a relatively smooth day of flying.

Stan

  • Like 1

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

7 minutes ago, spilok said:

There are several threads on this forum relating to P3d pauses and stutters.  I had them too.  I blamed ORBX like so many others did, and I have pretty much all of ORBX scenery and their Global, Vector, and LC North America and Europe. Additionally, I fly a lot near Orlando so I also have the new City Scene Orlando.

I would get relatively long pauses several times at critical flight situations (landing, etc), changing views, bad weather and clouds, etc.,  and it really annoyed me since my system is a state of the art Jetline system.

Well, today, I tried one more idea I read about on this forum, and that idea worked.  I tested it by loading KMCO (long load time, as usual), kept my sliders at full right in most of the autogen and World option screen, and took two flights:  Took off from KMCO in Embraer 170 in Active Sky weather to Miami.  Weather very overcast today, and I have the full Miami Scenery from Latin VFR.  NO PAUSES OR STUTTERS!  My second flight was 747 from Orlando to Philadelphia.  Very smooth...NO PAUSES.

My fix was this:  I turned off "AutoSave" in my paid version of FSUIPC!.  That simple.  For me, it worked, and it worked in very demanding scenery and weather.  I'm sold.  No more saves after crashes.  Not worth it.  Nice having a relatively smooth day of flying.

Stan

This is a well known issue and the first thing most users make sure is off.

  • Like 1

Share this post


Link to post

During critical phases of flight and I want a SAVE I just hit the ; key then the X key. Easy to remember my own saved (Autosave) flight.

Share this post


Link to post
1 hour ago, spilok said:

There are several threads on this forum relating to P3d pauses and stutters.  I had them too.  I blamed ORBX like so many others did, and I have pretty much all of ORBX scenery and their Global, Vector, and LC North America and Europe. Additionally, I fly a lot near Orlando so I also have the new City Scene Orlando.

I would get relatively long pauses several times at critical flight situations (landing, etc), changing views, bad weather and clouds, etc.,  and it really annoyed me since my system is a state of the art Jetline system.

Well, today, I tried one more idea I read about on this forum, and that idea worked.  I tested it by loading KMCO (long load time, as usual), kept my sliders at full right in most of the autogen and World option screen, and took two flights:  Took off from KMCO in Embraer 170 in Active Sky weather to Miami.  Weather very overcast today, and I have the full Miami Scenery from Latin VFR.  NO PAUSES OR STUTTERS!  My second flight was 747 from Orlando to Philadelphia.  Very smooth...NO PAUSES.

My fix was this:  I turned off "AutoSave" in my paid version of FSUIPC!.  That simple.  For me, it worked, and it worked in very demanding scenery and weather.  I'm sold.  No more saves after crashes.  Not worth it.  Nice having a relatively smooth day of flying.

Stan

Had you ever enabled autosave in FSUIPC? Or was it ON by default?

Edited by Nemo

Share this post


Link to post

Stan,

Try this. I had the same issue as you and was very skeptical about this solution, but guess what no more stutters or pauses of up to 10 seconds and with autosave on. I don't remember the link but I did copy the text. Credit goes to the fellow who provided this solution.

Let me know if it works:

__________________________

Hi Pete
 
I have amended my PC settings and used FSUIPC functions to eliminate the autosave issues under windows 10
and thought it might benefit others, subject to your approval
 
For me the 2-3 second hesitation was caused by windows antimalware service (Windows Defender)
using a lot PC  CPU/Memory resource. Unfortunately if realtime protection is turned off
manually it is automatically set to ON when the pc is next started.
However, Defender's settings options allows the user to add exclusions for:
specific folders / file types /processes and this was the fix I needed and it permanently
stops Defender causing the sim to pause.
 
If you have installed your own 3rd party antivirus/anti malware software check that
windows defender "realtime protection" is OFF
 
To access the settings screen
open the win 10 action center and select all settings
then Update and Security
select windows defender
select add an exclusion
 
The only exclusions actually needed was process-  adding the executable file for each sim,
I was taking no chances and included folders & file types to be 100% certain defender
does not quarantine/check any sim files
In processes I added
Prepar3d.exe
 
In folders I added;
c:/drive .... documents/folder names (where saved flight files are kept)for both sims
main install folder for each sim
 
In file types I added;
FLT
FSSAVE
WX
FLT.fmc
FLT.sav
FXML
FXML.fmc
FXML.sav
 
The hesitation was reduced significantly to a micro-pause (sometimes none) in both sims.
 
--------------------------------

This post was edited to be relevant for P3D only.

Good luck,

Jorge

 

  • Like 1

Share this post


Link to post

If your PC is configured correctly (permissions and antivirus) the FSUIPC autosaves should be almost imperceptible. On my PC each autosave is a quarter second hiccup (a bit longer on some aircraft that have larger panel states and such to save, but still less than a second.) When they are spread to every 10 minutes, they are almost totally unnoticeable.

Edited by molleh

Share this post


Link to post

I enabled Autosave.  It was not on by default.  

2 hours ago, BillS511 said:

During critical phases of flight and I want a SAVE I just hit the ; key then the X key. Easy to remember my own saved (Autosave) flight.

I have to admit:  This is interesting, and I will try this.

Stan

Share this post


Link to post
19 minutes ago, spilok said:

I enabled Autosave.  It was not on by default.  

I have to admit:  This is interesting, and I will try this.

Stan

Stan, you know that the semi-colon is the long-time (since at least FS2004 days) "save scenario" key in our sim.

"x" is just the filename he's using for a quick save.

I do the same -- I save my scenario if I think I need to.  I don't use the FSUIPC autosave function.

Share this post


Link to post

Does auto save only available with the paid version ?

Mike

Share this post


Link to post
2 hours ago, Mikelab6 said:

Does auto save only available with the paid version ?

Mike

Yes.

Share this post


Link to post

autosave disabled does not change it in my sim.tested over and over and .......

Share this post


Link to post
12 hours ago, spilok said:

There are several threads on this forum relating.....

I checked, but default settings (FSUPIC was installed few days ago) looks like this:

CVpuTJFh.jpg

So You turned on auto save manually I think. Default = OFF.

 

Share this post


Link to post
12 hours ago, spilok said:

My fix was this:  I turned off "AutoSave" in my paid version of FSUIPC!. 

That, Stan, has been a well-known fix for ages if you read through here. Nothing utterly earth-shattering there, just surprised it took you so long to cotton onto it.

Share this post


Link to post

AutoSave in FSUIPC just calls SimConnect to save the flight, and is the same as activating 'Save Scenario' from the P3D menu or hot key. The time taken to save is mainly due to the aircraft being used, with complex add-on aircraft such as those by PMDG known to take several seconds or more, so autosave is not recommended for such aircraft.

  • Upvote 1

Share this post


Link to post

Again, if your PC is taking several seconds to autosave, something is not configured correctly.

Share this post


Link to post

I've been using autosave for years and see very little stutter, if any, even when using PMDG birds with extra save info.  I did have a problem once, and it was due to mapping my documents folder to a network share.  Once I moved documents back to my local SSD, all stutters disappeared.

The only thing that solved my pauses was disabling ORBX regions when not flying there.  Went from 9 second pause in LAX area to none.  Even with just S.Cal enabled, I see very slight pause, but not very noticeable.  I do have Orbyx vector and LC enabled as well, and tried turning those off with no change.  Just the extra regions did for me.

Share this post


Link to post
1 hour ago, molleh said:

Again, if your PC is taking several seconds to autosave, something is not configured correctly.

I disagree. My PC is well configured and performing brilliantly.

Flying a simple aircraft like Carenado PC-12 or Xtreme Solutions Learjet 25 I never had a problem with AutoSave.

But the PMDG has a lot of systems and all that needs saving. You can't blame FSUIPC for taking so long to save. It's simply using the inbuilt Save Scenario feature.

If you want complexity that's the price you have to pay. As someone else said the occasional manual save is probably a good compromise.

Share this post


Link to post
36 minutes ago, Ray Proudfoot said:

the occasional manual save

A couple of nights ago, flying the 747-8i around the Hudson Bay area, going on past experiences of getting CTDs in that area based on that infamous crook, ntdl.dll, I did a Scenario Save, just in case.

Edited by vc10man
bad grammar

Share this post


Link to post

Rick,

Is there really a criminal around that area? Crook? Or creek?

I've been flying the 738 around Europe for a week now and not a single crash. Pleased at how stable everything is. No Autosave and no manual ones either.

Share this post


Link to post
7 hours ago, vc10man said:

That, Stan, has been a well-known fix for ages if you read through here. Nothing utterly earth-shattering there, just surprised it took you so long to cotton onto it.

Guess we learn something every day.

Stan

  • Like 1

Share this post


Link to post
Quote

I've been flying the 738 around Europe for a week now and not a single crash.

I am trying to imagine you at the controls of a 737, Ray. All I am able to hear are the words "why are you so slow?!!" :laugh:

Edited by Christopher Low
  • Like 1

Share this post


Link to post

I have always been using the autosave function in the FSUIPC paid version and have not noticed any stutters. What I have done is set the autosave interval to 600 seconds (10 minutes) and the keep number to 2. I don't believe that one save every 10 minutes would create any issue with stutters. This is the main reason I have bought FSUIPC as the autosave function is a real savior in any potential crash. 

Edited by Daedalus

Share this post


Link to post
5 minutes ago, Christopher Low said:

I am trying to imagine you at the controls of a 737, Ray. All I am able to hear are the words "why are you so slow?!!" :laugh:

Too bloomin’ true Chris. Mach 0.78 when I should be transporting my pax at Mach 2. Lefteris and Andrew need to get their skates on. They’re still buggering around with the Airbus! 😢

Share this post


Link to post
2 minutes ago, Daedalus said:

I have have been using the autosave function in the FSUIPC paid version and have not noticed any stutters.

It’s aircraft dependent. What are you flying?

Share this post


Link to post
1 minute ago, Ray Proudfoot said:

It’s aircraft dependent. What are you flying?

Any type. I'm not saying I never had stutters but I never attributed them to the autosave function. The reason is that I have set it to a save frequency of 10 minutes. I can't imagine how one save every 10 minutes would create more than one stutter in 10 minutes. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now