Jump to content

Sign in to follow this  
BMW969

P3D v4.5 FPS down

Recommended Posts

Dear @AnkH,

because you obviously did not read what LM (e.g. Kayla) has posted here: https://www.prepar3d.com/forum/viewtopic.php?p=196274#p196274

I will quote:

***************

" Hello all,

Can you post your system specs?

Have you tested this without any addons installed?

*****************

It was also mentioned a dozen of times before (in this exact thread) from Devs working with LM that your findings should be without addon's.

 

I will not turn this thread in a personal matter between you and me. Keep up your good work and contribute to the community as you can.

 

Edited by GEKtheReaper

Gerald K. - Germany

Core i7 4790 / ASUS H87-PRO / MSI GTX 970 / 16 Gb RAM Corsair Vengeance 1600 / 24" Full HD.

WIN 10 HOME 64 + P3D v4 + GEP3D + UTX Europe + FS Global Ultimate NG + ORBX Trees HD + ASP4 + ASCA/SF3D + ENVTEX + ENVSHADE + GSX + EZCA + (EnvForce).

"Flightstick" = X56 HOTAS RGB Logitech

Share this post


Link to post

Dear All,

Can someone with the confirmed 30% performance drop FPS issue please try the following test:

1) Right click your Prepar3D.exe V 4.5, find the compatibility tab and set "disable full screen optimisation" 

2) Under Prepar3d settings, disable the "Black-out Desktop".

Let me know if your FPS go back to normal, if not then :

3) Under Prepar3d settings, enable the "Black-out Desktop".

Retest if your FPS go back to normal.

Please note that if you use FSLabs Airbus, you cannot perform this test as FSLabs always reset the full screen optimisation settings back to enabled.

The reason for this test is because Lockheed Martin reverted the WPF rendermode back to SoftwareOnly as per users request since some users were having difficulties with some 3rd party recording software and REShade, so I want to confirm if the settings above are having a conflict with the new WPF rendermode configured by LM causing an adverse effect with P3D 4.5 new features.

Many thanks
Simbol

Edited by simbol
  • Upvote 2

Share this post


Link to post
12 minutes ago, simbol said:

Dear All,

Can someone with the confirmed 30% performance drop FPS issue please try the following test:

1) Right click your Prepar3D.exe V 4.5, find the compatibility tab and set "disable full screen optimisation" 

2) Under Prepar3d settings, disable the "Black-out Desktop".

Let me know if your FPS go back to normal, if not then :

3) Under Prepar3d settings, enable the "Black-out Desktop".

Retest if your FPS go back to normal.

Please note that if you use FSLabs Airbus, you cannot perform this test as FSLabs always reset the full screen optimisation settings back to enabled.

The reason for this test is because Lockheed Martin reverted the WPF rendermode back to SoftwareOnly as per users request since some users were having difficulties with some 3rd party recording software and REShade, so I want to confirm if the settings above are having a conflict with the new WPF rendermode configured by LM causing an adverse effect with P3D 4.5 new features.

Many thanks
Simbol

I had that disabled anyway even in 4.4. Now I didn’t try black out desktop though


Angus Rowlands: i7 8700 RTX Asus Strix 2080, 16 GB RAM

Share this post


Link to post
6 minutes ago, Navigator43 said:

I had that disabled anyway even in 4.4. Now I didn’t try black out desktop though

I'm sorry if I sound edgy, but then why don't you try that first and then report back before answering, just like it was asked?

Edited by Farlis
  • Like 1

Share this post


Link to post

LM have found  a partial fix :

https://www.prepar3d.com/forum/viewtopic.php?f=6312&t=133165&start=120

Edited by supersym
  • Like 1

 

i9 9900 K 5.2 Ghz HT off 32 Gb DDR4 @ 4 Ghz CL17-19-19-44 Team Group Xtrem Asus Maximus Formula XI W10 64 bits pro sur Samsung 960 EVO M2, 2 ème Samsung 960 EVO M2 , RTX 2080 Ti Palit Power supply Corsair 1500 W Gold Screen ACER 28 inches 4K G-SYNC 
Gigabyte 3d mars WC THERMALTAKE WATER 3.0 RIING RGB 360

Share this post


Link to post
1 minute ago, supersym said:

Thanks! This are great news ☝️


- Harry J.

i7-7820X (@4.8 GHz), 32GB RAM (@3467) 2080Ti (3440x1440), SSD 500GB, (Win10x64),  SSDs 1+2 TB (P3Dv5.x + ORBX). FSGlobalNG (mesh), ORBX (Global+OLC, all FTX Regions, all TE products, many Airports), DDscenery (NY, CH, MIA), Airports (FT, FB, FSDT, AS); PMDG (737, 747, 777), MJC DQ400, RA Piston Duke, A2A C172. Weather ASP5. F1 GTN complete. AI Traffic: AIG OCI

 

 

 

Share this post


Link to post
1 minute ago, supersym said:

Not 100% there yet, they are working now with us now via the internal LM beta forums.

The tests I requested above a couple of minutes ago still stand, there is a reason why I asked..

Thanks everyone.

Regards,
Simbol

  • Upvote 1

Share this post


Link to post
1 minute ago, simbol said:

Not 100% there yet, they are working now with us now via the internal LM beta forums.

The tests I requested above a couple of minutes ago still stand, there is a reason why I asked..

Thanks everyone.

Regards,
Simbol

Will do as soon as I'm back from work.

  • Like 1

- Harry J.

i7-7820X (@4.8 GHz), 32GB RAM (@3467) 2080Ti (3440x1440), SSD 500GB, (Win10x64),  SSDs 1+2 TB (P3Dv5.x + ORBX). FSGlobalNG (mesh), ORBX (Global+OLC, all FTX Regions, all TE products, many Airports), DDscenery (NY, CH, MIA), Airports (FT, FB, FSDT, AS); PMDG (737, 747, 777), MJC DQ400, RA Piston Duke, A2A C172. Weather ASP5. F1 GTN complete. AI Traffic: AIG OCI

 

 

 

Share this post


Link to post

From the LM forum: “

Hello Everyone,

We identified and found a fix for an issue that can affect framerates in some use cases in v4.5. We are currently working with various third parties on some additional reports and will release a hotfix in the next couple of weeks. Thanks again for the reports and detailed information. Every little bit helps when tracking something down like this and we appreciate your time in helping us solve the problem. Thanks again for your support!

Regards,
Rob McCarthy


Best regards,

Kristoffer Løkke-Sørensen
 

Share this post


Link to post

Got my frames back in v4.5!

It is kind of strange but maybe it works for some one with fps lose like me. Just a hypothesis and probably a false positive. Unticking the "Black-out Desktop" and changing graphics settings maybe causing this problem.
I did now several tests with 4.4 and 4.5 and had that issue with low frames and sometimes autogen popins, black airport textures, even with vanilla settings ( by vanilla I mean the standard settings after deleting the p3d.cfg). I could not get persistent results until yesterday. Since yesterday I only updated from 4.3 to 4.4 and after that to 4.5 with client, content and scenery update.
In some occasions after updating to 4.5 again, I got the same frames as in 4.4 (maybe 5 frames less, hard to tell) for one flight. After that it deteriorated and stayed that way, even when I changed the settings back or deleted the p3d.cfg. I uninstalled 4.5 client. Installed 4.4, tested, uninstalled the 4.4 client and reinstalled 4.5. Did that nearly a dozen times. The only thing that was constant was when ever I did not unticke "Black-out Desktop" I had one or two test flights without autogen or frame issues.

Encouraged by that I wiped p3d completely. Used the fullinstaller and did not touch the "Black-out Desktop" option.

1. Installed 4.5 after wipe and restart
2. Started p3d and started vanilla and default flight
3. Ended p3d and restarted the PC
4. Started p3d and now gradually adjusting the settings
5. Locked frames at 50 fps in p3d

On my test track KFHR to KRNT on runway 50 fps and no significant drop under 40 on approach.

Latest: Windows 10 ultimate updates, latest nvidia driver, "disable fullscreen optimization" and "run as admin" in the compatibility tab active. 1080 gtx, speedtrees off

The "Black-out Desktop" does not black out the desktop every time. Some times it does after moving the scenery selection window. Before the reinstall I always unticked the blackout function and I guess most of the multiscreen users did so too.

Tomorrow I have a day off and will try to brake it again.


MCE_banner_272_68.jpg

Share this post


Link to post
1 hour ago, Farlis said:

I'm sorry if I sound edgy, but then why don't you try that first and then report back before answering, just like it was asked?

Lol just tried it didn’t work Mr. edgy lol


Angus Rowlands: i7 8700 RTX Asus Strix 2080, 16 GB RAM

Share this post


Link to post
20 minutes ago, kristolz said:

From the LM forum: “

Hello Everyone,

We identified and found a fix for an issue that can affect framerates in some use cases in v4.5. We are currently working with various third parties on some additional reports and will release a hotfix in the next couple of weeks. Thanks again for the reports and detailed information. Every little bit helps when tracking something down like this and we appreciate your time in helping us solve the problem. Thanks again for your support!

Regards,
Rob McCarthy

Awesome 


Angus Rowlands: i7 8700 RTX Asus Strix 2080, 16 GB RAM

Share this post


Link to post

I upgraded from 4.4 to 4.5 and followed the P3D Guide deleting the Prepar3d.cfg file as recommended (kept a copy first) and discovered that the newly generated .cfg file was smaller than the older one (kept copy). I had not ever edited this old .cfg file, as was as generated. When I compared the new files in an editor many lines in the new one were missing.

I am suggesting this might be the reason some are having problems. I have Orbx Global, Vector and NA installed and have no FPS reduction. I am using an i7-6400, 16Gb Ram, GTX-1060 (6Gb) and SSD.

Just something to consider.


Best Regards,

Michael. - Beta Tester (ProATC-x)

SIM: P3Dv4/Prosim737 - AivlaSoft EFB-2, ASP4. Texture Direct, World Airways, SkyForce 3D, EnvForce, TomatoShade, PFPX, TOPCAT, FSUIPC, UT Live, AccuFeel, RAAS Pro and ProATC/x

Share this post


Link to post
1 hour ago, simbol said:

Dear All,

Can someone with the confirmed 30% performance drop FPS issue please try the following test:

1) Right click your Prepar3D.exe V 4.5, find the compatibility tab and set "disable full screen optimisation" 

2) Under Prepar3d settings, disable the "Black-out Desktop".

Let me know if your FPS go back to normal, if not then :

3) Under Prepar3d settings, enable the "Black-out Desktop".

Retest if your FPS go back to normal.

Please note that if you use FSLabs Airbus, you cannot perform this test as FSLabs always reset the full screen optimisation settings back to enabled.

The reason for this test is because Lockheed Martin reverted the WPF rendermode back to SoftwareOnly as per users request since some users were having difficulties with some 3rd party recording software and REShade, so I want to confirm if the settings above are having a conflict with the new WPF rendermode configured by LM causing an adverse effect with P3D 4.5 new features.

Many thanks
Simbol

Hello Simbol

I did the tests from 1 to 3 as described.
The FPS were bad as before.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    31%
    $7,775.00 of $25,000.00 Donate Now
×
×
  • Create New...