Dane Watson

Win-10 9/11/2019 Update Problem

Recommended Posts

This is just a heads-up to those that have had a Windows-10  9/11/2019 update and P3D will not launch as well Rex SkyForce for P3D.

After updating Windows my PC rebooted no problem. I immediately started checking all my programs (Apps) and what I found, was at least for me, P3D and SkyForce would not load at all.

See attached link below for my print-screen. The item in the red border box was the first one I uninstalled - it was an easy task to do.

After the uninstall I then ran P3D as well as SkyForce and everything was normal.  I did not uninstall the other three 9/11/2019 updates as SO FAR I am not experiencing any issues.  I also activated a 7-day pause on any further Windows updates. 

 

https://photos.app.goo.gl/nrt6C5qUpWhwrFN4A

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi Dane,

I have not ran into any issues yet, the KB4515384 was to fix 100% CPU utilization issue caused by Microsoft Search facilities when the user had web searches disabled.

Quote

Addresses an issue that causes high CPU usage from SearchUI.exe for a small number of users. This issue only occurs on devices that have disabled searching the web using Windows Desktop Search.

This KB should have improved performance and shouldn't have any direct "prevention" issues with P3D or REX.  Full details on KB here.  P3D requires "Run As Admin" ... what path is your P3D installed into?

There were some additional security issues that the KB address, perhaps those block P3D and REX SF from executing?  I did have a strange issue with REX, but that wasn't related to the KB and I'll post that issue in another thread.

Cheers, Rob.

Share this post


Link to post

Same here. The update KB4515384 kills a lot of apps.

Share this post


Link to post

I also had to uninstall KB4514359 which updates .NET. That seems to be the culprit. Everything back to normal. Rather than a piecemeal solution, it's probably a better option to revert to the Windows restore point prior to the 9/10/2019 updates for Win 10 1903 and continue to pause updates until MS figures out what happened.

Share this post


Link to post

Did you folks disable AV software prior to update?

Cheers, Rob.

Share this post


Link to post

I did not have any problems , I use Windows defender as AV and did not disable it..

Jorge

 

Share this post


Link to post

I updated. Have no issues. Same as Jorge I use Windows defender.

Edited by BillS511

Share this post


Link to post
50 minutes ago, Rob_Ainscough said:

Did you folks disable AV software prior to update?

Cheers, Rob.

I did not because Windows had already run in the background and I had no opportunity to turn off my ESET AV.

Also my Windows Defender is on.

Share this post


Link to post

MS Windows Defender will work with MS OS updates, but 3rd party AV software may or may not work with OS updates ... it's a good idea to disable 3rd party AV software before doing any OS updates (also disable/quit/exit everything in SysTray if possible).

Cheers, Rob.

  • Upvote 2

Share this post


Link to post

After windows update, I had a CTD and that did not happen to me for a long time, it was the notorious Terrain.dll issue, I related directly to a windows update but without knowing that for sure, I reduce just a little my settings then a reboot and all good now. 

Share this post


Link to post

This is supposed to be a fix for KB4512941 that has shown to cause Cortana to run in background with high CPU usage, W10 insiders pointed it out but Microsoft rolled it out anyway, I have delayed this update for now.

Share this post


Link to post

Did you guys have Afterburner and Rivatuner running? By closing them the CTD stopped.

Share this post


Link to post

It appears Rivatuner is the issue for me with the current Windows updates.  With Rivatuner running I get a d3d9.dll error when P3dV4.5 tries to run.  Without Rivatuner running P3dV4.5 loads and runs with no issues.  This is with all of the current Windows 10 updates installed.  If I uninstall the latests W10 updates P3d will run with Rivatuner run with no problem.  It appears Rivatuner needs an update to be compatible with the latest W10 updates.

Danny

Share this post


Link to post

I’m using the latest RivaTuner, no issues, just make sure P3D water = high and not Ultra.

What methods do you have set for RT monitoring?  Overclocked GPU?

Cheers, Rob

Share this post


Link to post
14 hours ago, jabloomf1230 said:

I also had to uninstall KB4514359 which updates .NET. That seems to be the culprit.

Same here.  Or maybe it was the culprit.  Something in the latest series of Windows updates - from September 1 onward - completely screwed up my connectivity.  Couldn't maintain an internet connection via ethernet or wi-fi.  I depend on my internet connection for work, so I didn't have time for precise diagnosis - I just killed all the updates on or after August 1.  Everything's working beautifully now.  I've paused updates and set delays 'til Microsoft figures out what's going on.

Side note, but I have to say my faith in Microsoft's ability to deliver a streamed solution for MSFS - which wasn't all that great to begin with - just took a nosedive.

Edited by Alan_A
  • Upvote 1

Share this post


Link to post

Looks like Nvidia also updated there drivers for Gears5 with more.

Any experience with this cocktail ?

Thanks

Michael Moe

Share this post


Link to post

I had the same issue after latest WIN10 updates. I had only one restore point listed, and that one dated from today, so not from before the update yesterday. Restored nevertheless and everything seems to be back to normal despite the updates remaining installed. Riva Tuner made no difference on my system whatsoever.

Tom

Share this post


Link to post
1 hour ago, Michael Moe said:

Any experience with this cocktail ?

Yep, updated to the latest gpu drivers 360.30, no issues yet.

w10 .. 1903 build 18362.356

bob

Share this post


Link to post

Had same issue here. Appears that the Windows update causes P3D and REX for me to not start. Uninstalling it now. 

Share this post


Link to post

No issues with the W10 update and P3D or REX SF and EF here...

Share this post


Link to post

I have the same issue as well - posted in the Win 10 forum here.

P3D does not start with that new W10 update installed.  One time it hung, showing a "Suspended" status in Task Manager.  I'm using Defender and RivaTuner as well.

- Rich

 

Share this post


Link to post

My build number shows as 18362.295, and the most recent updates (after this morning's uninstalls) are KB4506991 and 4512508. Smooth running with that setup.  This is on my work laptop - I haven't tried to deal with the flightsim rig yet.  But connectivity problems are solved.

 

Share this post


Link to post

The problem appears to be from an incomplete installation of the 10 Sep updates, which is why some people have no issues and others do. It has nothing to do with anti malware software being active.

Share this post


Link to post

I'm hosed too after the update.  Really long start up time.  UT Live loads sometimes and not others.  Frame rates went down from 30+ to 5 for DEFAULT aircraft.  What a nightmare....  Thanks Microsoft.

 

Regards,

 

Todd

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now