Sign in to follow this  
AviatorMan

Micro stutters and shimmering in P3D

Recommended Posts

Have been using P3Dv2.x since it came out last year. Have thought I was happy with it compared to FSX, but another thread on this site motivated me to do some specific comparisons. Have noticed that in P3D2 I often have micro-stutters even with good FPS. Have also noticed shimmering (vibrating?) of vertical objects like light poles, particularly at addon airports. Did a comparison betweenP3D2 and FSX: the RealAir B60 at UK2000 EGBB and EGNT over ORBX FTX England, with ORBX weather theme 4: FPS 14 - 25 in both simulators; micro-sutters and vertical shimmering in P3D2, no micro-stutters or shimmering in FSX. The vertical shimmering is particularly noticeable in UK2000 EGNT (Newcastle) when approaching from the west. Does anyone else have these problems? Can anyone advise if any display/scenery parameter settings should affect the shimmering?

 

Thanks for any response.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

How are you comparing the two? The way P3D handles textures is totally different to fsx, also you would have to disable shadows, tessellation, volumetric fog, cloud and cockpit shadows, water effects and modify the affinity mask in P3D so it handles textures like fsx does.

 

In other words, you cannot really compare them like for like. Can you list your hardware and settings used in P3D? I get no shimmering or stutters but my sliders are not set to my old fsx level, they are set to whatever P3D needs for best results.

Share this post


Link to post

Have noticed that in P3D2 I often have micro-stutters even with good FPS. Have also noticed shimmering (vibrating?) of vertical objects like light poles, particularly at addon airports.

 

I cannot offer a solution, only confirm that I also have shimmering (like sparkling) objects in P3D, most notably light poles as you mention, but also other objects. Would appreciate if anyone has a fix/tweak/setting for those. And the stutters...  well flying level and looking straight ahead it's acceptable. Banking and panning views it's significant and ruins the immersion. 

Share this post


Link to post

Have been using P3Dv2.x since it came out last year. Have thought I was happy with it compared to FSX, but another thread on this site motivated me to do some specific comparisons. Have noticed that in P3D2 I often have micro-stutters even with good FPS. Have also noticed shimmering (vibrating?) of vertical objects like light poles, particularly at addon airports. Did a comparison betweenP3D2 and FSX: the RealAir B60 at UK2000 EGBB and EGNT over ORBX FTX England, with ORBX weather theme 4: FPS 14 - 25 in both simulators; micro-sutters and vertical shimmering in P3D2, no micro-stutters or shimmering in FSX. The vertical shimmering is particularly noticeable in UK2000 EGNT (Newcastle) when approaching from the west. Does anyone else have these problems? Can anyone advise if any display/scenery parameter settings should affect the shimmering?

 

Thanks for any response.

 

The object shimmering is a symptom of poor anti-aliasing in P3Dv2, in FSX this was fixable by setting AA options in Nvidia inspector to over-ride the FSX internal AA - however this approach does not work in P3Dv2 due to the DX11 graphics engine changes. We have recently learned that the P3D dev team are talking to Nvidia behind the scenes, so hopefully this will result in better graphics drivers in the not too distant future.

 

With regards to the stutters - I also experienced this when I first started using P3Dv2, the cause of my stutters was an unstable overclock on my CPU. The frequency was too high and the volts were a bit low, this was causing the CPU to constantly error correct.

Your stutters may be caused by something completely different though?

 

Your system specs and P3Dv2 settings would help us diagnose any potential issues - please provide this info if you can.

Share this post


Link to post

I set 4xSGSS in Nvidia Inspector to eliminate the shimmering. Yes, NVI works just fine, at least for that setting.

 

Vic

Share this post


Link to post

There is some confusion regarding how to use the AA settings in NI for P3d. Enhance AA seems to work but override AA doesn't.

Share this post


Link to post

Or try DSR supersampling. It works well for me. I'm now running AA with only 4x DSR in Nvidia driver plus 2x or 4x MSAA in P3D. It's not perfect, but the shimmering is minimal, at least to my eyes.

Share this post


Link to post

You can try everything and most likely will still have microstutters.  We cannot do the 1/2 refresh rate fix that worked so well with FSX due to P3D being a pseudo-fullscreen (windowed) app.  I am hoping there is a fix from this down the road either on Nvdia's side (for me) or from LM.  Fingers crossed.....I have minimized it and there are still more postives for P3D so I am for sure not reverting. 

Share this post


Link to post

Hi, my system specs below:

  • i5 3570 3.4 - 3.8 GHz
    4 Cores
  • 8 GB RAM
  • Video Board Nvidea PhysX>GeForce 650 Ti

In P3D have set:

[Display]

TEXTURE_BANDWIDTH_MULT=160
UPPER_FRAMERATE_LIMIT=0

TEXTURE_FILTERING=4
MSAA=2
SSAA=0
VSYNC=0
FXAA=1
TRIPLE_BUFFER=0

[sCENERY]
POP_FREE_AUTOGEN=1
AUTOGEN_BATCH_LOD=2
AUTOGEN_TREE_MAX_DRAW_DISTANCE=9500.000000
AUTOGEN_TREE_MIN_DISTANCE_TO_LOD=2500.000000
IMAGE_COMPLEXITY=2

Volumetric Fog OFF

Interior shadows ON (Shadows on or off don't seem to affect my FPS or micro-stutters)

 

Have set NI to 4x [4x Multisampling] (couldn't find 4X SGSS or 4X DSR on my NI?)

 

Anyway, this NI setting seems to have noticeably smoothed the micro-stutters, but the shimmering is still there.

 

Any suggestions on my settings?

Share this post


Link to post

I set 4xSGSS in Nvidia Inspector to eliminate the shimmering. Yes, NVI works just fine, at least for that setting.

 

Thx alot for that, shimmering now gone!  B)

 

 

Have set NI to 4x [4x Multisampling] (couldn't find 4X SGSS or 4X DSR on my NI?)

 

Anyway, this NI setting seems to have noticeably smoothed the micro-stutters, but the shimmering is still there.

 

Tried this setting as well, but no reduction in stuttering for me. :(

Regarding SGSS you will find it under Antialiasing - Transparency Supersampling as "Sparse Grid Supersampling". 

Share this post


Link to post

 

 


Tried this setting as well, but no reduction in stuttering for me.

 

I notice that I only get stuttering when my CPU pings out at 100% which only happens when I have background programs running alongside P3D and when I'm in a scenery intense area.  You might want to check your CPU usage when you experience stutters to either confirm or eliminate that possibility.  I also found that running the autogen building density slider at the mid setting is the best balance between building density and performance at least on my system.  However I do most of my flying in and around LA where the scenery is pretty demanding.  If your flying across Montana that slider may not mean much.

Share this post


Link to post

I only get stuttering when my CPU pings out at 100%

 

It seems my CPU core #0 goes to 100% whichever setting I choose. I can only change this by deselecting the core in taskmanager (affinity setting) and reselecting it again. Then all working cores stay below 100%. This has not eliminated my stutters though. Which I think is strange, as I'm sure it's CPU related.

Share this post


Link to post

Or inherent program flaw at this time.

 

Other sims for me (like dcs/ xp) smooth as butter, dcs even capped by my monitor refresh at 60 fps.

 

Give it time is my advise.

Share this post


Link to post

 

 


Hi, my system specs below:
i5 3570 3.4 - 3.8 GHz
4 Cores
8 GB RAM
Video Board Nvidea PhysX>GeForce 650 Ti

 

I have an i5-3570K and run it at 4.6 GHz...  No micro stutter for me....  other settings in signature.

Share this post


Link to post

I only get that shimmering when flying around England/Ireland using FTX Global. The rest of Europe looks fine. I believe this is a known Orbx issue. Would nice if they could fix it at some point in the near future.

Share this post


Link to post

I have an i5-3570K and run it at 4.6 GHz... No micro stutter for me.... other settings in signature.

Ah, so you are the one.

Share this post


Link to post

If LM and NVidia ever get together and get their heads around the driver issues P3D will be great...but I am afraid until such time and running through a hybridised window it will never be a smooth as it could be....and stutters will remain...it requires the half v synch fix.

 

Come LM step up in 2015 make it happen!

 

Cheers

Share this post


Link to post

Could be your graphics cards, the 650Ti is an entry level card - P3Dv2 loves a powerful GPU.

Share this post


Link to post

Thanks all for the help. Changing the SGSS setting in Nvidia Inspector seems to help: it reduces the shimmering effect, but does not completely eliminate shimmering. Also seems to have smoothed some of the micro-stutters.

 

 

I believe this is a known Orbx issue.

 

 

Not sure how to check if this is really the case.  If you have FTX Global, then everywhere you fly is ORBX scenery, not just the UK. So it is not possible to fly in a non-ORBX area and see if the problem disappears.  I have Global, OpenLC Europe and several FTX regions, including all of the UK regions. I seem to get the shimmering  whever there are vertical objects, and especially at addon airports. This is true for Orbx airports (e.g., EGHI) and UK2000 airports. Outside the UK FTX regions and in OpenLC Europe, I get shimmering at Aerosoft, Dreamflight and Jetstream Design airports. But the shimmering seems worst at the UK2000 airports. Whoever owns this problem, LM or ORBX, I hope they attend to it soon.

Share this post


Link to post

Thanks all for the help. Changing the SGSS setting in Nvidia Inspector seems to help: it reduces the shimmering effect, but does not completely eliminate shimmering. Also seems to have smoothed some of the micro-stutters.

 

 

 

 

Not sure how to check if this is really the case.  If you have FTX Global, then everywhere you fly is ORBX scenery, not just the UK. So it is not possible to fly in a non-ORBX area and see if the problem disappears.  I have Global, OpenLC Europe and several FTX regions, including all of the UK regions. I seem to get the shimmering  whever there are vertical objects, and especially at addon airports. This is true for Orbx airports (e.g., EGHI) and UK2000 airports. Outside the UK FTX regions and in OpenLC Europe, I get shimmering at Aerosoft, Dreamflight and Jetstream Design airports. But the shimmering seems worst at the UK2000 airports. Whoever owns this problem, LM or ORBX, I hope they attend to it soon.

 

Here's what works best for me and has been commented on by others as most effective for reducing shimmering:

  1. Open Inspector
  2. Find the prepar3d.exe profile and delete it.
  3. Click the Nvidia icon up top to reset driver settings to default.
  4. For Antialiasing Compatibility DX1x choose Bioshock from the drop down menu.
  5. For AA Mode, choose either Override or Enhanced--I don't think this matters which one.
  6. For AA Setting, choose SUPERVCAA_64x_4x
  7. For AA Supersampling, choose 2x SGSS.
  8. For Anisotropic Filtering, choose Application-Controlled
  9. In P3D:
    1. FXAA to OFF
    2. MSAA 4x
    3. AF 4x, select Apply, then change AF to 16x

I find these settings mitigate a lot of the poor AA in P3D, including shimmering and 'swimming' textures.  Not perfect, but quite good.   Add a higher custom resolution (at your own risk) and you can really get some superb image quality in P3D V2.2.

 

NOTE:  the Antialiasing Compatibility DX1x Bioshock setting was discovered to be critically effective w/ earlier versions of P3D V2.x, and I'm not sure if it's still critical, but I use it and have excellent image quality and have really mitigated the swimming textures you see on runway threshold, and to anti-aliase runway lines.   You GPU is very weak for P3D I'm afraid.   In my continuous use of FSX & P3D over the many years I have never had as smooth performance in FSX as I do now in P3D, but I have a strong system still, despite its age.  I'm a firm believer in HT enabled using an affinity mask that puts the OS on Core0, the P3D main thread on Core1, and all other 10 virtual cores on my SB-E chip busy w/ texture loading.

  • Upvote 1

Share this post


Link to post

Here's what works best for me and has been commented on by others as most effective for reducing shimmering:

 

 

Noel, thanks. Have made the settings you suggest and it does seem to improve things. As you say, better but not perfect. I may have to live with the situation until I can upgrade my graphics card.

Share this post


Link to post

Thanks Noel,

 

I linke you settings, too. They're not quite as hard on the graphics adapter as 4xSGSS, but reduce shimmering in a comparable way.

 

Actually, I wantet to "like" your contribution but obviously this is no longer possible.

 

Kind regards, Michael

Share this post


Link to post

Here's what works best for me and has been commented on by others as most effective for reducing shimmering:

  • Open Inspector
  • Find the prepar3d.exe profile and delete it.
  • Click the Nvidia icon up top to reset driver settings to default.
  • For Antialiasing Compatibility DX1x choose Bioshock from the drop down menu.
  • For AA Mode, choose either Override or Enhanced--I don't think this matters which one.
  • For AA Setting, choose SUPERVCAA_64x_4x
  • For AA Supersampling, choose 2x SGSS.
  • For Anisotropic Filtering, choose Application-Controlled
  • In P3D:
    • FXAA to OFF
    • MSAA 4x
    • AF 4x, select Apply, then change AF to 16x

 

It is important that P3D settings use the same MSAA setting that is equivalent to the SSAA or SGSSAA setting in NI. So we set 4xMSAA in P3D and 4xSGSSAA in NI, or 2xMSAA and 2xSSAA etc. No amount of setting 4. 5. or 6. to anything makes any difference to the view.

...it is true that with NI, FSX in full screen can use 1/4, 1/3, and 1/2 refresh rates with 15, 20, and 30fps fixed framerates for a smoother view with a 60Hz monitor, microstutters can be similarly reduced in P3D, which is windowed mode, by using 120 or 240Hz refresh monitors, rather than 60Hz.

Share this post


Link to post

Speaking of smoother views, whatever happened to GSYNC?


 

 


It is important that P3D settings use the same MSAA setting that is equivalent to the SSAA or SGSSAA setting in NI. So we set 4xMSAA in P3D and 4xSGSSAA in NI, or 2xMSAA and 2xSSAA etc. No amount of setting 4. 5. or 6. to anything makes any difference to the view.

 

Interesting.  I remember I ran 4x/4x when I was playing around w/ different settings and don't recall any appreciable difference over 4x/2x--I'll take another look and see if I can discern.

Share this post


Link to post

Here's what works best for me and has been commented on by others as most effective for reducing shimmering:

  1. Open Inspector
  2. Find the prepar3d.exe profile and delete it.
  3. Click the Nvidia icon up top to reset driver settings to default.
  4. For Antialiasing Compatibility DX1x choose Bioshock from the drop down menu.
  5. For AA Mode, choose either Override or Enhanced--I don't think this matters which one.
  6. For AA Setting, choose SUPERVCAA_64x_4x
  7. For AA Supersampling, choose 2x SGSS.
  8. For Anisotropic Filtering, choose Application-Controlled
  9. In P3D:
    1. FXAA to OFF
    2. MSAA 4x
    3. AF 4x, select Apply, then change AF to 16x

I find these settings mitigate a lot of the poor AA in P3D, including shimmering and 'swimming' textures.  Not perfect, but quite good.   Add a higher custom resolution (at your own risk) and you can really get some superb image quality in P3D V2.2.

 

NOTE:  the Antialiasing Compatibility DX1x Bioshock setting was discovered to be critically effective w/ earlier versions of P3D V2.x, and I'm not sure if it's still critical, but I use it and have excellent image quality and have really mitigated the swimming textures you see on runway threshold, and to anti-aliase runway lines.   You GPU is very weak for P3D I'm afraid.   In my continuous use of FSX & P3D over the many years I have never had as smooth performance in FSX as I do now in P3D, but I have a strong system still, despite its age.  I'm a firm believer in HT enabled using an affinity mask that puts the OS on Core0, the P3D main thread on Core1, and all other 10 virtual cores on my SB-E chip busy w/ texture loading.

 

 

Thanks Noel,

 

I linke you settings, too. They're not quite as hard on the graphics adapter as 4xSGSS, but reduce shimmering in a comparable way.

 

Actually, I wantet to "like" your contribution but obviously this is no longer possible.

 

Kind regards, Michael

 

PMB/Michael echoes the response that I had to the suggestion above: all of this can be solved by simply running SGSS 8x in NI but, even with my overclocked 780ti, I'll bottleneck if there are multiple cloud layers or fog or something. I can reliably run SGSS 4x without any performance degredation but 4x does not completely eliminate the shimmering. The suggestion above (Noel's) only benefits us if both the performance and quality get us somewhere in between 4x and 8x... if that makes sense. I almost wish there was a 6x...

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this