Bert Pieke

Cessna Skycatcher for free

Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

Steve says it should be compatible with FSX SE and P3D - that's news, because it was clearly stated many times that it would only be compatible with FSX box. Lots of users complained when SE was not even supported and it did not work when they tried to force the issue. I cannot imagine that Flight1 would do all the work to make it compatible with SE and P3D then just make it free. I'm not complaining, I'm just skeptical that it will work....I'm double checking with Flight1 before I bother trying to install it in P3D. 

Share this post


Link to post
Share on other sites

Well, its interesting, Steve confirmed they even made a new installer totally compatible with P3D V3.4 and SE. Very generous. 

Share this post


Link to post
Share on other sites

I just tried installing it, and the same old blank mfd and pfd panels issue is happening in SE.  Even though the installer states that it works with SE, the aircraft itself clearly doesn't.  Too bad - thought it was too good to be true.

Share this post


Link to post
Share on other sites

The usual caveat applies to this: If it sounds too good to be true, it is. . . . .  Have downloaded the file three times, won't install with the provided key.     Way to go Flight 1!

Share this post


Link to post
Share on other sites

What an amazing failure by Cessna, eh? Wow, they're scrapping all the skycatchers that won't sell. They should have just remade the 152. I don't know how anyone learned how to fly with that weird control setup. 

On topic though: pretty awesome of Fliight 1 to make this available for free. Maybe they'll turn loose of that commander and cardinal that were AOPA exclusives......

:-)

Share this post


Link to post
Share on other sites
48 minutes ago, rightseat said:

I don't know how anyone learned how to fly with that weird control setup. 

Flew one for all of 1 hour during my Instructor training - that was enough!

Share this post


Link to post
Share on other sites

Charliep... It should install with the supplied key if you enter 1212 as the password and you did not corrupt the key file. Make sure any firewall software is not blocking anything also. See the instructions at http://www.flight1.com/view.asp?page=skycatcher

If you are having MFD issues... I left out the navdata file in the rebuild I originally uploaded (sorry about that). If you downloaded BEFORE 8:40 PM on Tuesday the 25th, please re-download and install it again. This may affect some MFD and PFD screens. Note: the MFD does need to initialize the map data, so give it a moment to load everything after you start the aircraft.

  • Upvote 2

Share this post


Link to post
Share on other sites

LOL Bert, I see you are a way ahead of me. I just sent you an email about something you were well aware of.

Share this post


Link to post
Share on other sites
2 hours ago, Steve Halpern said:

If you are having MFD issues... I left out the navdata file in the rebuild I originally uploaded (sorry about that). If you downloaded BEFORE 8:40 PM on Tuesday the 25th, please re-download and install it again. This may affect some MFD and PFD screens. Note: the MFD does need to initialize the map data, so give it a moment to load everything after you start the aircraft.

Something still seems wonky with the installer.  After uninstalling the earlier version and re-installing with the updated wrapper in stock FSX, Windows throws an error about not being able to find C:\FSX\Gauges\F1_C162\f1dataimport.exe when I try to load the airplane.  I didn't have this error after using the original installer.  I took a look in the gauges subdirectory and f1dataimport.exe is definitely not there.

Share this post


Link to post
Share on other sites

downloaded the catcher (20170426-08:03z), installed it into P3Dv3.4 just to see blank PFD&MFD; no 2D panel pop-ups either, SL40 COM does not work - no clickspots at all for me

Share this post


Link to post
Share on other sites
8 hours ago, MadDog said:

Something still seems wonky with the installer.  After uninstalling the earlier version and re-installing with the updated wrapper in stock FSX, Windows throws an error about not being able to find C:\FSX\Gauges\F1_C162\f1dataimport.exe when I try to load the airplane.  I didn't have this error after using the original installer.  I took a look in the gauges subdirectory and f1dataimport.exe is definitely not there.

I have a dialog going with Steve at Flight1 about this kind of thing on the Flight1 forum with progress is being made:

http://www.simforums.com/forums/topic58073_post367083.html

 

Share this post


Link to post
Share on other sites
8 hours ago, MadDog said:

Windows throws an error about not being able to find C:\FSX\Gauges\F1_C162\f1dataimport.exe when I try to load the airplane.

Do download it again... that was fixed.

With the file in broad use among 3 different sims, I am collecting reports of things that may need addressing.

You can post here as I monitor that more frequently... http://www.simforums.com/forums/forum_posts.asp?TID=58079

Share this post


Link to post
Share on other sites

Sorry Steve, I don't have membership at the other forum.  Still no go - I have the f1d file in the right place, but still no displays I am afraid.  Shame - this is a really generous offer, but the reason I never bought it was the SE compatibility issue, and it seems not to have gone away yet.

Cheers anyway - really good deal for those who can get it to work. 

Share this post


Link to post
Share on other sites

Really generous of F1 to do this. I bought it back when it came out but had to abandon it with the move to P3D. Glad to see it's been updated, can't wait to try out the new installer tonight!

 

Share this post


Link to post
Share on other sites

SteveHalpern:

 

Followed the instructions at Flight One's site to the letter.  I have installed Other software from F1 this way for rebuilds and not had any firewall problems.  I should have tried disabling Avast.  Let's try this again. . . . . . . . . .Thanks!

 

Share this post


Link to post
Share on other sites

I just took her out for a flight from Bremerton to Tacoma Narrows in P3Dv3 and all was well.

Thanks again Steve and F1. :biggrin:

Share this post


Link to post
Share on other sites

For Prepar3D, if you get blank gauges, I believe it is actually FSX SimConnect RTM that is the required version. This version is now in the installer. It would also be in your Prepar3D folder in the following location:

PATH_TO_P3D\redist\Interface\FSX-RTM\retail\lib\SimConnect.msi

Share this post


Link to post
Share on other sites

Also, the version with SimConnect was posted last night, so if you downloaded early last night or before that, SimConnect was not automatically included.

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now