Jump to content
Sign in to follow this  
vonduck

CTD's all the time now!

Recommended Posts

8 hours ago, sniper31 said:

Okay, another update. Turns out this was NOT a solution for my CTD's, which I say once again, ONLY started with SU13. I managed only three successful flights with the Offline AI Aircraft turned off. Fourth flight, same CTD, same Event Viewer error code. I am fast running out of options. I am now testing the lowering of my NIC bandwidth, as some of you have suggested worked for you, even though I abhor the idea of suddenly having to lower my data speed just because MSFS, after three years of being released, decides it doesn't want to work with high-speed data service. IF this turns out to be a work around, it does NOT give me a lot of confidence that the upcoming MSFS 2024 that is supposed to rely on more streaming and cloud service is going to pan out well. But I digress. Back to MSFS 2020 and my current CTD SU13 issue. I have a grand total of ONE successful flight running at 100Mbps, half duplex on my NIC. That was last night. Just having time today to try and get some more attempts in, so let's see what happens. More to follow. 

 

Have you run a stress test on your hardware? It's easy enough to do and that way you can rule it out and move on the other possible solutions.


 i9-13900K @ 5.8Ghz / Asus TUF 4090 OC / 32 GB DDR 5 / Corsair 1000W PS /  Pimax Crystal / 2 SATA SSD / 2TB M2 SSD/ DOF Reality H3 motion platform/ Win 11 

Share this post


Link to post
Share on other sites
1 minute ago, Gate99 said:

Have you run a stress test on your hardware? It's easy enough to do and that way you can rule it out and move on the other possible solutions.

I am assuming you are making that suggestion because you have not read the entire thread (which, I can understand...it is lengthy). That said, yes, I have stressed test my system plenty. I have a long history of custom building PC's , so stress testing is something I do regularly, sometimes just for fun. Besides all that, as I covered earlier in the thread, in order to rule out hardware, I completely changed out my CPU, motherboard, RAM and GPU as I have plenty of spare parts available. It made no difference. Hardware is not the cause of my CTD's which specifically started with SU13. 


AMD Ryzen 7800X3D & Gigabyte X670E Aorus Master MB, w/32 Gb GSkill DDR5 RAM, MSI 4090 GPU, lots of SSD's and M.2 drives, Fractal Torrent Case, Virpil VPC MongoosT-50CM3 Throttle, Virpil Constellation Alpha Stick, Thrustmaster TCA Yoke Boeing Edition and MFG Rudder pedals. Currently on Win11

 

 

Share this post


Link to post
Share on other sites
2 minutes ago, sniper31 said:

I am assuming you are making that suggestion because you have not read the entire thread (which, I can understand...it is lengthy). That said, yes, I have stressed test my system plenty. I have a long history of custom building PC's , so stress testing is something I do regularly, sometimes just for fun. Besides all that, as I covered earlier in the thread, in order to rule out hardware, I completely changed out my CPU, motherboard, RAM and GPU as I have plenty of spare parts available. It made no difference. Hardware is not the cause of my CTD's which specifically started with SU13. 

As the OP, i appreciate your tireless efforts Sniper in doing all of this arduous testing to try and figure out this elusive anomaly... one day it will be solved..who knows how or why... thought I'd report back after doing some testing of my own... no where near as rigorous as Snipers and others...

Suffice to say.. i cleaned out my NVIDIA driver and installed a fresh latest driver version... re-set all of my settings in NCP (not using the old replace the 2 files nvdrsdb0.bin and 1.bin files to save time)... cleaned out my community folder and started agin with very few addons... uninstalled GSX...was a pain anyway... removed FSLTL and now restored it back to the comm folder... uninstalled mixed reality and reinstalled that fresh... went about updating a few files like FSUIPC (free version to latest).... and hence so far ive done 5 flights of varying length in both VR and pancake mode, all with no crashes... now whether its something i have removed or reinstalled or replaced, or a windows update...i have no clue... my brain is too tired to even guess anymore... but for some reason it now works... it truly is enough to do your head in!

  • Like 2

i9 13900KF @ 5.5Ghz | MoBo MSI PRO Z690-A WiFi | Corsair Vengeance Black RGB RS 64gb DDR4 3200MHz | PNY RTX 4090 XLR Gaming Verto EPIC-X RGB TF | MP33 Pro 1TB M.2-2280 NVME SSD for OS | Samsung 870 QVO 2.5" 4TB SSD SATA2 | Corsair RM1000X 2021 1000W 80 Plus Gold PSU | Antec Dark Fleet DF700 Flux Gaming Case | Win 11 home | LG 48" C2 OLED 4K TV | G512 Keyboard | Razer Basilisk V2 Mouse | TCA Throttle, Sidestick and addons, peddles, TM1600 Hotas | TrackIR 5 | Tobii Eye Tracker | HP Reverb G2 HMD

Doug 

Share this post


Link to post
Share on other sites
2 minutes ago, vonduck said:

far ive done 5 flights of varying length in both VR and pancake mode, all with no crashes..

Don't let it go to your head! I've had good days too. It'll crash tomorrow.  😆 

  • Like 1

13900K@5.8GHz - ROG Strix Z790-E - 2X16Gb G.Skill Trident DDR5 6400 CL32 - MSI RTX 4090 Suprim X - WD SN850X 2 TB M.2 - XPG S70 Blade 2 TB M.2 - MSI A1000G PCIE5 1000 W 80+ Gold PSU - Liam Li 011 Dynamic Razer case - 58" Panasonic TC-58AX800U 4K - Pico 4 VR  HMD - WinWing HOTAS Orion2 MAX - ProFlight Pedals - TrackIR 5 - W11 Pro (Passmark:12574, CPU:63110-Single:4785, GPU:50688)

Share this post


Link to post
Share on other sites
52 minutes ago, odourboy said:

Don't let it go to your head! I've had good days too. It'll crash tomorrow.  😆 

I must admit... every time the sim stutters (which is not that frequent)..my heart stops and i expect the CTD! I only start breathing again when it carries on !🙃🤣

  • Like 4

i9 13900KF @ 5.5Ghz | MoBo MSI PRO Z690-A WiFi | Corsair Vengeance Black RGB RS 64gb DDR4 3200MHz | PNY RTX 4090 XLR Gaming Verto EPIC-X RGB TF | MP33 Pro 1TB M.2-2280 NVME SSD for OS | Samsung 870 QVO 2.5" 4TB SSD SATA2 | Corsair RM1000X 2021 1000W 80 Plus Gold PSU | Antec Dark Fleet DF700 Flux Gaming Case | Win 11 home | LG 48" C2 OLED 4K TV | G512 Keyboard | Razer Basilisk V2 Mouse | TCA Throttle, Sidestick and addons, peddles, TM1600 Hotas | TrackIR 5 | Tobii Eye Tracker | HP Reverb G2 HMD

Doug 

Share this post


Link to post
Share on other sites

I have not followed this thread but I will say this if a entertainment product put stress on me to the point of worrying about my mental and overall health I would probably step back and give it a break for while. Did it a many of the old FSX days.

Carry on...

Share this post


Link to post
Share on other sites
9 minutes ago, JBDB-MD80 said:

I have not followed this thread but I will say this if a entertainment product put stress on me to the point of worrying about my mental and overall health I would probably step back and give it a break for while. Did it a many of the old FSX days.

Carry on...

...Just as well i play golf too! That's most therapeutic....although I tend to CTD in that as well!!! 🤤🤪

  • Like 2

i9 13900KF @ 5.5Ghz | MoBo MSI PRO Z690-A WiFi | Corsair Vengeance Black RGB RS 64gb DDR4 3200MHz | PNY RTX 4090 XLR Gaming Verto EPIC-X RGB TF | MP33 Pro 1TB M.2-2280 NVME SSD for OS | Samsung 870 QVO 2.5" 4TB SSD SATA2 | Corsair RM1000X 2021 1000W 80 Plus Gold PSU | Antec Dark Fleet DF700 Flux Gaming Case | Win 11 home | LG 48" C2 OLED 4K TV | G512 Keyboard | Razer Basilisk V2 Mouse | TCA Throttle, Sidestick and addons, peddles, TM1600 Hotas | TrackIR 5 | Tobii Eye Tracker | HP Reverb G2 HMD

Doug 

Share this post


Link to post
Share on other sites
8 hours ago, sniper31 said:

I am assuming you are making that suggestion because you have not read the entire thread (which, I can understand...it is lengthy). That said, yes, I have stressed test my system plenty. I have a long history of custom building PC's , so stress testing is something I do regularly, sometimes just for fun. Besides all that, as I covered earlier in the thread, in order to rule out hardware, I completely changed out my CPU, motherboard, RAM and GPU as I have plenty of spare parts available. It made no difference. Hardware is not the cause of my CTD's which specifically started with SU13. 

Well I'm glad that you were able to rule out it being a hardware issue. It does seem to be a perplexing issue that is affecting some users but not others. Hopefully you'll be able to track it down soon. 

  • Like 1

 i9-13900K @ 5.8Ghz / Asus TUF 4090 OC / 32 GB DDR 5 / Corsair 1000W PS /  Pimax Crystal / 2 SATA SSD / 2TB M2 SSD/ DOF Reality H3 motion platform/ Win 11 

Share this post


Link to post
Share on other sites

At some point I uninstalled all photogrammetry cities via content manager. That fixed stutters and ctd for me.

at eham (fly tampa) with installed photogrammetry cities I have times with single digit FPS.  With uninstalled cities I get around 40 FPS. 
When the photogrammetry cities are uninstalled it doesn’t matter if you have photogrammetry on or off in the data section. For me that was the key.

Share this post


Link to post
Share on other sites

I suspect most of my CTDs have resulted from incompatible add-ons or simply just trying to run too many of them.  Assuming hardware issues have been ruled out (I've only read a part of this thread) then maybe cull the addons or even ser what happens with an empty community folder.

I run Littlenavmap, FSLTL and TrackIR software in the background and do get a few simconnect errors as a result leading to a CTD.

ASOBO have recently included an object limit which can cause a CTD.  GAIST is a big problem for me as a result of this limit.  I'm not sure why it was introduced or whether there is any scope to increase it, though I do recall reading that too many objects were causing stability issues.  That said, addon scenery is held in RAM and some of us have more of that than others.

I once had a bad stick of RAM that was causing issues intermittently and also a PSU starting to fail with similar results (sometimes the intermittent faults are the most difficult to track down).

Finally any sign of overheating, especially the CPU and GPU need an eye kept on.  I run Coretemp to keep track of my CPU and Afterburner for my CPU.  I've also heard of NVMe drives getting too hot if they are not installed correctly.


Ryzen 5800X3D, Nvidia 3080 - 32 Gig DDR4 RAM, 1TB & 2 TB NVME drives - Windows 11 64 bit MSFS 2020 Premium Deluxe Edition Resolution 2560 x 1440 (32 inch curved monitor)

Share this post


Link to post
Share on other sites
3 hours ago, cianpars said:

I suspect most of my CTDs have resulted from incompatible add-ons or simply just trying to run too many of them.  Assuming hardware issues have been ruled out (I've only read a part of this thread) then maybe cull the addons or even ser what happens with an empty community folder.

I run Littlenavmap, FSLTL and TrackIR software in the background and do get a few simconnect errors as a result leading to a CTD.

ASOBO have recently included an object limit which can cause a CTD.  GAIST is a big problem for me as a result of this limit.  I'm not sure why it was introduced or whether there is any scope to increase it, though I do recall reading that too many objects were causing stability issues.  That said, addon scenery is held in RAM and some of us have more of that than others.

I once had a bad stick of RAM that was causing issues intermittently and also a PSU starting to fail with similar results (sometimes the intermittent faults are the most difficult to track down).

Finally any sign of overheating, especially the CPU and GPU need an eye kept on.  I run Coretemp to keep track of my CPU and Afterburner for my CPU.  I've also heard of NVMe drives getting too hot if they are not installed correctly.

Everything you covered has long been tried and checked off earlier in this thread by my thorough and relentless efforts. To summarize, running a clean vanilla MSFS install, empty Community folder, have swapped out all hardware and tested, no overclocking (I am running a 7800X3D) and I have been using Coretemp to monitor temps for over ten years now. I use an Arctyx AIO cooler and my temps while running MSFS are around 50 degrees Celsius. Thanks anyway. 🙂

 


AMD Ryzen 7800X3D & Gigabyte X670E Aorus Master MB, w/32 Gb GSkill DDR5 RAM, MSI 4090 GPU, lots of SSD's and M.2 drives, Fractal Torrent Case, Virpil VPC MongoosT-50CM3 Throttle, Virpil Constellation Alpha Stick, Thrustmaster TCA Yoke Boeing Edition and MFG Rudder pedals. Currently on Win11

 

 

Share this post


Link to post
Share on other sites
1 hour ago, sniper31 said:

Everything you covered has long been tried and checked off earlier in this thread by my thorough and relentless efforts. To summarize, running a clean vanilla MSFS install, empty Community folder, have swapped out all hardware and tested, no overclocking (I am running a 7800X3D) and I have been using Coretemp to monitor temps for over ten years now. I use an Arctyx AIO cooler and my temps while running MSFS are around 50 degrees Celsius. Thanks anyway. 🙂

 

Thanks again for your continual testing and relentless pursuit of a solution for all of us. I too have tried all those things, short of a complete hardware change. The only (so far) 100% solution has been the 100 Mbit half duplex solution.

I'm convinced something in SU13 or server-side around around the release of SU13 caused an error in transmission /error handling or processing that is making the program crash when it doesn't recover/receive what it expects in the necessary timeframe and that it's tied to Bing Data/Photogrammetry. When we limit the network bandwidth, I think we're allowing for enough time for that data to get processed/not missed because everything is flowing down the connection slower.

I will try the uninstallation of the photogrammetry cities to see if that has any effect.

  • Like 1

Share this post


Link to post
Share on other sites
19 minutes ago, mmcmah said:

Thanks again for your continual testing and relentless pursuit of a solution for all of us. I too have tried all those things, short of a complete hardware change. The only (so far) 100% solution has been the 100 Mbit half duplex solution.

I'm convinced something in SU13 or server-side around around the release of SU13 caused an error in transmission /error handling or processing that is making the program crash when it doesn't recover/receive what it expects in the necessary timeframe and that it's tied to Bing Data/Photogrammetry. When we limit the network bandwidth, I think we're allowing for enough time for that data to get processed/not missed because everything is flowing down the connection slower.

I am starting to agree and lean to the same thoughts with the cause and also the work around. I am on my 6th successful flight after the 100Mbps Half Duplex change, and no CTD's yet. My MSFS install is still in a vanilla state, and I am still flying default everything. Still need to knock out some more successful flights in default mode, then eventually start to add in some addons and see what happens. 

  • Like 2

AMD Ryzen 7800X3D & Gigabyte X670E Aorus Master MB, w/32 Gb GSkill DDR5 RAM, MSI 4090 GPU, lots of SSD's and M.2 drives, Fractal Torrent Case, Virpil VPC MongoosT-50CM3 Throttle, Virpil Constellation Alpha Stick, Thrustmaster TCA Yoke Boeing Edition and MFG Rudder pedals. Currently on Win11

 

 

Share this post


Link to post
Share on other sites

The only time I CTD lately seems related to State Saving where a particular livery on an addon will seem to CTD for a bit on load but usually eventually come good. No rational explanation for it.

Share this post


Link to post
Share on other sites
19 hours ago, sniper31 said:

Already there my friend. When I reinstalled MSFS a several days ago, I have since kept it completely vanilla for troubleshooting purposes. As in, nothing, no addons, nada, nix, zip. I did mention that I was going to add FSLTL yesterday, but that was only IF the Offline AI Aircraft potential solution worked, which it didn't. So, I never reinstalled FSLTL yet. I have still, a vanilla install of MSFS. To that end, I have installed the USA WU just so I can at least have a few more Asobo updated airports do vary my testing out of during this troubleshooting process. But, otherwise it's default everything....default scenery, default weather, default planes, default flight planner, you get the idea. And, I don't use FSUIPC, SPAD or anything software like that either. My Windows install itself is pretty vanilla, because in general, I don't like bloatware and I don't like a lot of apps running in the background. I've also not installed any new hardware peripherals in the last 6 months.

I am about to start my third test flight with the 100Mbps Half Duplex work around, so we'll see what happens.

That is some weird stuff going on then. Sorry for my error (on a phone) and my apologies.

I do wonder though.....if you should install all available world updates first? Maybe something is not compatible with an older version?

  • Like 1

Hero X--8086k@5.1ghz--32GBddr4--2080ti--Acer GSync 4k Monitor + 1080p Monitor--Honeycomb Alpha/Bravo+Saitek Pedals--Thrustmaster T16000+Throttle. P2ATC, AIG/FSLTL, GSX, 600gb of scenery, PMS/TDI 750, Auto FPS, FG Mod, FSrealistic, FScrewRAAS,RexTextures/Seasons,Navigraph etc

A2A Comanche---Bae146, F28, Arrow(s), BS Bonanza & BS King Air---FSR500--COWS DA42---Fx HJet+VisionJet---FSW 414---FSS E175+P2006T---Fenix 320-------PMDG DC-6+737+9---C-22J---Milviz C310+Porter---SWS PC-12, Kodiak, Zenith+RV14---Big Radialsl Goose---IFE MB339+F-35---NextGen EMB----Carenado Seneca + PC12---AS CRJ Series----Asobo ATR---

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...