Jump to content

Sign in to follow this  
Terblanche

Blurries and more BLURRRRRIES

Recommended Posts

4 minutes ago, srce said:

If you have HT off, don't set it (or set it to 15, which is the same result).

Where does 15 come from now? I've always been under the impression that with HT=OFF it should be 14 ....? And when HT=ON then 84.

15 / 253 / 244 / are all new to me.


Terblanche Jordaan
From: Cape Town (FACT)

 

Share this post


Link to post
1 hour ago, vgbaron said:

We have very similar rigs.

  • I use Lasso also
  • HT off
  • FPS locked at 20
  • VSync off
  • all sliders are NOT maxed - be selective
  • no AM or AM=15
  • FFTF 0.15
  • TBM=80

Set up with mid sliders and work from there - I would NOT use the set affinity trick - there are times when one thread SHOULD have priority - defeat that and you get strange results.

Try redownloading and reinstall the addon area causing the problem.

Vic

 

He is not listening  Vic just reading what he wants.

Thats it you keep adding  and changing HT ON and OFF.....and keep adding an AM, you will get there :mellow:...not


David Murden MSFS2020 : P3Dv5x : DCS :

10900K@4.9 All Cores HT ON  : Asus ROG Strix Z490-E : 32GB DDR4 CL14 3200MHz : RTX 3080 Corsair iCUE H150i Pro XT 360mm :

Corsair HX850i Platinum Plus : 2x 1TB Samsung EVO Plus M.2 : Phanteks Enthoo Evolo X Case : Thrustmaster : Warthog HOTAS & TPR

 

Share this post


Link to post

Has your issue been fixed? I have never seen this bad of textures. I see you have tried several things; but, I would strongly suggest to do a clean and full uninstall of your graphics drivers. Then do a registry repair with Ccleaner (Back-up first)

Finally, do a clean install of non-beta graphics drivers. (only graphics drivers- nothing else)

Fly and enjoy.

Share this post


Link to post
1 hour ago, Terblanche said:

Where does 15 come from now? I've always been under the impression that with HT=OFF it should be 14 ....? And when HT=ON then 84.

15 / 253 / 244 / are all new to me.

It's all binary, dude. 8 bits, where each bit represents an individual physical or logical CPU core. Set the corresponding bit (1) and you activate that core, 0 to turn it off.

With 8 bits you can represent all decimal values between 0-255.

CPUs with even more cores, like 16, thus need 16 bits for the affinity mask, which in decimal is 0-65535.

I'm not going further than this because all this info is already available here in the forums. Search and you shall find.

Don't know if any of this is the cause of your blurries though.

Share this post


Link to post

I used to have problems like this in both FSX and P3D and the culprit was almost always the numbering inside the scenery.cfg. For example if you look at Area.242 and Layer=242, they show the correct format. However Area.243 and Area.244, layers do not match up at all. and always caused the blurriness. If this is your issue, try correcting them manually. Save current CFG first. Your scenery.cfg can be found here: C:\ProgramData\Lockheed Martin\Prepar3D v4.

 

[Area.242]
Title=Salt Lake City Intl P3Dv4
Local=D:\P3D\PacSim\Salt Lake City Intl P3Dv4\data
Layer=242
Active=TRUE
Required=FALSE

[Area.243]
Title=TD L35 Big Bear City Airport
Local=Turbulent\TRB_Airports\L35_BigBear
Layer=280
Active=TRUE
Required=FALSE

[Area.244]
Title=Aspen Extended
Local=Ecosystem\Aerosoft\Aspen Extended
Layer=280
Active=TRUE
Required=FALSE


Troy Kemp

Win 10 64 Pro on 1TB PCIE + 500GB ssd  / P3Dv4.5 HF3 on 1TB ssd + 250GB ssd P3D addon / i7 8700K@ 5.1ghz / 32GB DDR4 3600mhz OC @3733mhz/ ASUS Maximus X Code /ASUS GTX 1070 Strix, 

 

 

Share this post


Link to post

or just rename the scenery.cfg file and let P3D rebuild it.

 

Vic


 

P3D#1 - 7700K 5.0g ROG X270F 3600 15-15-15 - EVGA RTX 2080ti 1000W PSU 1- 850G EVO SSD, 2-256G OCZ SSD, 1TB,HAF942-H100 Water W1064Pro
40" 4K Monitor 3840x2160 - AS16, ASCA, GEP3D, UTX, Toposim, ORBX Regions, TrackIR
P3D#2 - 3770K 4.7g Asus Z77 1600 7-8-7 GTX1080ti DH14 850W 2-1TB WD HDD,1tb VRap, Armor+ W10 Pro 2 - HannsG 28" Monitors
 

Share this post


Link to post
4 hours ago, dmarques69 said:

What about locking frames? did you try that?

OMW - !!! That's it ........... I've deleted p3d.cfg file and Shaders folder and then locked the FPS at 30 seeing that my VSync does it anyway with the 4K monitor and voila! No blurries!

However, the micro stutters are back but I just did the exact flight I did this morning with the Q400 from LOWI to ELLX and there were no blurries anywhere. It's like having a whole new sim.

Now I just need to find the cure for the micro-stutters. Tick-tok-tick-toc.

4eA7K3.jpg

 

yr63xJ.jpg


Terblanche Jordaan
From: Cape Town (FACT)

 

Share this post


Link to post
55 minutes ago, troyboy66 said:

and the culprit was almost always the numbering inside the scenery.cfg

Just use SceneryConfigEditor and it does it all for you with one click ...


Terblanche Jordaan
From: Cape Town (FACT)

 

Share this post


Link to post
1 minute ago, Terblanche said:

OMW - !!! That's it ........... I've deleted p3d.cfg file and Shaders folder and then locked the FPS at 30 seeing that my VSync does it anyway with the 4K monitor and voila! No blurries!

 

Glad that you solve that ;) as for the micro stutters, i also have it if i use 30hz and lock to 30 fps, however, if i use 25hz and lock 30fps smooth, try to find a good relation between your monitor refresh rate and the fps internal lock, its a try and error job!


Marques

I7-8700k@4.7Ghz | Corsair H110i GTX| MSI GTX 1080 TI | 32GB Ram @3000MHZ| Crucial MX 200 M.2 500GB |Crucial MX200 SATA 500GB | HTC Vive | Samsung 40" 4k TV | Acer Predator 27" G-Sync

Share this post


Link to post
1 hour ago, Nyxx said:

He is not listening  Vic just reading what he wants.

Oh, I'm listening David, believe me, I'm all ears and eyes and I'm listening ........ and the 'trick-or-treat' seems to be to lock FPS.


Terblanche Jordaan
From: Cape Town (FACT)

 

Share this post


Link to post
Just now, dmarques69 said:

if i use 25hz and lock 30fps smooth

I will be experimenting with it over the weekend. Thank you to all you guys with this ... really appreciate it.


Terblanche Jordaan
From: Cape Town (FACT)

 

Share this post


Link to post

Or use Vsync On + TB + monitor at 25 hrtz

 


Gerard

7940x ( 14 cores ) : 8 cores @ 4.8 - 6 cores @ 4.0 Ghz - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Gigabyte GTX 2080 TI Windforce OC @1920 Mhz - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Gigabyte GTX 2080 Windforce OC @ 1900 Mhz - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post

What if you have a 4K TV? Should you set/lock your frames from within P3D at 30 or 60? I have a Sony 4K TV that can do 60Hz all the way down to 23Hz... But I remember when I locked frames and set my TV to 30Hz that my mouse movements became very laggy and unresponsive.


ASUS ROG Maximus Hero XII ▪︎ Intel i9-10900K ▪︎ NVIDIA RTX 3090 FE ▪︎ 64GB Corsair Vengeance RGB Pro ▪︎ Windows 10 Pro 2004 64-bit ▪︎ Samsung 970 EVO Pro 1TB NVME SSD (OS Drive) ▪︎ Samsung 860 EVO 2TB SATA SSD ▪︎ Seagate 4TB SATA HDD ▪︎ Corsair RMx 850W PSU

Share this post


Link to post
9 minutes ago, captain420 said:

What if you have a 4K TV? Should you set/lock your frames from within P3D at 30 or 60? I have a Sony 4K TV that can do 60Hz all the way down to 23Hz... But I remember when I locked frames and set my TV to 30Hz that my mouse movements became very laggy and unresponsive.

My mouse is a bit laggy as well but I've become pretty used to it.  The panning isn't as smooth either but it's a trade off I'm willing to make until I get a better PC.

Share this post


Link to post
10 minutes ago, Terblanche said:

Just use SceneryConfigEditor and it does it all for you with one click

Yes, but then you should manually delete scenery.dat files, becouse SceneryConfigEditor are not going to find them :happy:  They are in "C:\ProgramData\Lockheed Martin\Prepar3D v4\SceneryIndexes_x64" and this should be done every time you rebuild scenery.cfg. 

I'm glad blurries are solved, about microstutters, i'm afraid you need to live with them. From what i've read in P3D forums over the years, they are mostly caused by autogen loading, and most important - by unloading scenery(clearing the memory). Since we don't have VAS problems anymore, In Prepar3D.cfg try to reduce MaxRegionsPurgePerFrame=16 for example to 4, and see if that helps(it should).

About this CFG entry:

[SCENERY]

MaxRegionsPurgePerFrame=16

Description:  To reduce stalls was to put a limit on the number of scenery regions purged per frame. This was part of the big updates we made to optimize trees. As you fly around, scenery regions get requested based on distance from the camera. Scenery regions hold model placements, auto-gen, etc. The terrain mesh/texture data is handled through a totally different system though which relies on the LOD radius. The scenery database loads modes based on your scenery complexity, and makes auto-gen requests based on auto-gen settings, etc. The regions represent 64km, 16km, 4km, and 1km tiles with 16 children. These are loaded as needed and stay in memory until purged. Because of parent/child dependencies, the system only purges by distance at the 64km level. When a top level region is removed, it then recursively removes its children. Autogen tree data is stored in 1k cells, so there could be up to 4,096 tiles worth of three placement data to free up. This would cause very noticeable hangs. So, rather than remove all the tiles, we que them up for remove and remove a few every frame. Originally this was set to something low like 4. We raised it during the last round of memory optimizations to help speed up the process of clearing memory and avoid potential edge cases where fly fast at a low framerate might allocate memory faster than it gets freed.

Benefit:  Decrease value to reduce long frames (stutters), but VAS usage could increase. Increase value to reduce VAS usage but will increase long frames (stutters).


Zeljko Budovic

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    31%
    $7,775.00 of $25,000.00 Donate Now
×
×
  • Create New...