Sign in to follow this  
Rob Ainscough

P3D V2.3 Beta 2 Testing

Recommended Posts

Started testing the latest beta build from LM ... performance improvement so far appears to be about 15% across the board on my setup using this build.  Cloud shadows at sunset have much less impact.  Tested using 5 cloud layers at sunset which would normally bring my system to 10-11 fps (see settings in link below).  Also tested with high speed aircraft as they will stress out performance more than "normal" aircraft.

 

Used Captain Sim 777, Lockheeds F-22, and F-35.  Scenery is all Orbx with FTX Global, FTX Vector, PILOTs FTX Edition Mesh, and FTX OpenLC EU -- so I did try to load it up with add-ons.

 

Made a quick video here:

 

 

Graphics settings used can be found on my web site here: http://www.robainscough.com/P3D_V2.php

 

I'm finding I don't need to use SGSS AA now.  LM have indicated they have done some additional work post this build that will improve water at Ultra performance -- so more improvements to come.  There were a few stutters, but they have been drastically reduced.  Sadly my video doesn't do the experience justice ... you may see stutters in my video that aren't a part of the my actual experience (yes I'm sure no believes me, but you'll just have to take my word, it is MUCH improved).

 

Looks like I'll have a busy weekend testing.

 

Cheers, Rob.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Wow! very impressive. So LM listened to your input regarding the stutters. :wink:

Can't wait for the release B)

Share this post


Link to post

That sounds very impressive!
 

I think that the lighting in this video looks much better than before, did they do anything to it?

Share this post


Link to post

Three words: Wow, wow and wow!

 

I'm curious about what kind of system you used, Rob.

Share this post


Link to post

Looks fantastic, V2 is becoming a great platform! Thanks for all your dedication to the hobby Robb.

Share this post


Link to post

 

 


I'm finding I don't need to use SGSS AA now

 

Hi Rob,

Can you comment a little bit more about this statement. Is it because the internal AA method has improved so SGSS AA is not needed any more. 

 

Are you not seeing the shimmers as much in 2.3 without the use of SGSS AA?

 

Thanks!

Share this post


Link to post

Hi Rob,

 

What water textures are you using?  If its REX 4 which  set?

Share this post


Link to post

Rob, thanks for keeping us in the loop. :)

 

It's great to hear that performance in v.2.3 will be so much better! 

 

Do you have anything that you can share about bug fixes?

 

Specifically, have the FS9 windsocks been fixed (according to Orbx, this is why so many of the windsocks in Orbx scenery's airports still don't work).

 

Also have the aircraft lights been fixed? This is mainly an issue with A2A's Cessna and Cherokee (especially the latter's landing and taxi lights), but even the default Maule's lights don't work correctly (you currently have to turn on its landing light for any of the other exterior lights to work). Also in v.2.2, there's a bug where many AI aircraft have extremely bright landing lights, that look like the sun is rising/setting when they take off/land (this may be an Orbx issue).

 

Oh, one more that I nearly forgot: Does the Anisotropic 16x setting now work without unsellecting and reselecting it in the options?

Share this post


Link to post

Looking great. Can't wait for the release to the public. I wonder if this will be a fresh install or just a patch. Any word Rob?

Share this post


Link to post

 

 


There were a few stutters, but they have been drastically reduced. Sadly my video doesn't do the experience justice ... you may see stutters in my video that aren't a part of the my actual experience (yes I'm sure no believes me, but you'll just have to take my word, it is MUCH improved).

 

I'll back you up Rob, I'm seeing the same experience on my system with the second beta.

 

About a 10-15% increase in performance, and no more drastic drop at dawn and dusk.

Share this post


Link to post

Nice job, Rob. Now, I can't wait to see a Q400/v2.3 beta video.

 

 cheers, Jazz.

Share this post


Link to post

and I was pulling my hair out because I couldn't get an average higher than 20 fps in highly populated area (Paris). This looks like I might be able to reach 30fps with this newer version.

Share this post


Link to post

Im, as many others, am seeing the Autogen spike with the new Q400 P3d version.

Share this post


Link to post

Thank you Rob

2.3 is shaping up to be a major step up for P3D performance

Share this post


Link to post

 

 


So LM listened to your input regarding the stutters.

 

Haha ... I doubt it was my specific input, but LM listen, read, watch ... Wes isn't on my payroll, however, maybe he'll take bribes? ;)  (joking, just in case that wasn't clear)

 

 

 


I'm curious about what kind of system you used, Rob.

 

i7 3960X @ 4.4 to 4.6 Ghz, 32GB RAM @ 2000 Mhz, Titan 6GB, 3TB SSDs

 

 

 

 


Are you not seeing the shimmers as much in 2.3 without the use of SGSS AA?

 

I'm not seeing shimmers with standard MSAA (but I run 2560 x 1600 so take that into account - the higher the resolution monitor the less the need for AA - can't wait for a 4K monitor) ... check my settings and in the link I provided above, SGSS AA is not being used and I don't see any shimmers in my video, in fact I have AA all set to Application controlled.

 

 

 


What water textures are you using?  If its REX 4 which  set?

 

REX 4 is not being used in this video -- P3D defaults.

 

Cheers, Rob.

Share this post


Link to post

Rob,

 

Did they improve the water textures then?

Share this post


Link to post

Rob,

Any comment on if this will be a complete reinstall? Or a simple patch?

Share this post


Link to post

and.... SLI?
 
No mention of SLI yet, but that will require nVidia driver support and LM are working with nVidia.
 
 

Do you have anything that you can share about bug fixes?
 
I'll verify those bugs you listed, but Wes B. wants me to focus on SimDirector so not sure how much of that testing I can get in.  I squeezed this "quick" testing out in the wee hours of the morning and wanted to share my positive results and let folks know that 2.3 is being worked on, the world isn't ending, and LM haven't gone bankrupt ;)
 

Any chance they will let us increase the LOD_RADIUS?
 
Haven't tried going beyond 6.5, if I have time I'll manually try via .cfg.
 

am seeing the Autogen spike with the new Q400 P3d version.
 
If I can find time and get the Activation of Q400 patch 1.010 to work, I'll try to do some testing with the latest Q400 ... my hunch is I'll need to make AffinityMask adjustments for the Q400, but who knows.  Like I said, Wes has me focused on SimDirector.
 
Yes ... water textures were improved and continue to be updated (post this build).
 
This build had a patch installer ... don't know if final 2.3 release will require a wipe and re-install - so far the patch and clearing of the 4 key directories works.  You will need to get updates from some 3rd party vendors (i.e. FSUIPC, Orbx, Virtuali, etc.) most of who are already on top of these 2.3 changes and will most likely be ready to roll out updates when 2.3 is final.
 
Cheers, Rob.

Share this post


Link to post

Thanks Rob for the update on P3d v2.3! Would love to see whether this build achieves more even frame timings to eliminate the stutters. Would be really great if it were smooth at 30 fps which it could be with better frame timings. Will you do that analysis again?

Share this post


Link to post

Great video and looks like a nice upgrade - huge thanks to LM

Share this post


Link to post

I did a re-install of the Q400 1.010 (complete installer from just flight, not the patch) and had no problems with activation. Am still getting the spikes and texture flashing. The good news is that Majestic have figured out what is causing these anomalies, and a fix will be issued in a few days, provided no other gremlins appear. 

 

  regards, Jazz.

Share this post


Link to post

Really appreciate you keeping us in the loop Rob (and for LM listening and squirelling away in the background...)!

 

Would you please be able to comment on whether the "spinning" clouds issue has been fixed (it doesn't look like it's occurring any more in your video)?

Share this post


Link to post

Sounds great, thx for the nice video Rob! Can't wait to get the V2.3 patch.

 

Marko

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this